Houdini 17.0 Character

Cycling Animation

On this page

There are several ways to cycle animation in Houdini. For this example we will explain how to cycle the first 25 keyframes through the remaining 125.

Channel Before/After extrapolation

The simplest way to cycle animation is to set the Before and After Extrapolation to Cycle or CycleOffset.

  1. Add the channels that you want to cycle to the Channel List.

  2. Click on the left column showing the selected parameter labels in the Channel List.

  3. Select Channels > Extrapolation and change the extrapolation mode to Cycle or Cycle Offset.

Expressions

One way to do this is by using the cycle() or cycleoffset() expression in the Animation Editor.

  1. Add the parameters that you want to cycle to the Channel List.

  2. Set a keyframe at frame 125 in the Graph view of the Animation Editor.

  3. Select the channel segments from frame 25 to 125.

  4. In the Function menu, choose cycle() or cycleoffset().

Tip

cycle() will continue from the starting value of your channels.

Dopesheet

If you want to create actual keyframes for the cycle, use the Dopesheet in the Animation Editor.

  1. Add the parameters that you want to cycle to the Animation Editor.

  2. Switch to the Dopesheet view.

  3. Select frames 1 to 25 (inclusive) in the All Displayed Channels row.

  4. In the Edit menu, choose Copy.

  5. Select frames 26 to 125 (inclusive) in the All Displayed Channels row.

  6. In the Edit menu, choose Paste Special ▸ Cycle (or Repeat).

Motion Effects

For more procedural cycling of animation than the cycle() or cycleoffset() expressions, you can use Motion Effects.

  1. Add the channels that you want to cycle to the Channel List.

  2. Click the playbar and choose Motion Effects ▸ Cycle.

Note

In the Extend CHOP parameter window that pops up, you can change the Right Behavior from Cycle to Repeat if you want to repeat the animation instead.

Character

Rigging

Animation

Panes