Houdini 17.0 Shelf tools

Camera shelf tool

Adds a camera to the scene. You can Ctrl-click the shelf tool to create a camera from the current view.

Placing cameras in the viewer

There are three ways you can place cameras in the scene view. They can be moved once they are placed by either dragging them in the scene view or changing the values in the parameter editor.

To...Do this

Place cameras in a specific location in the scene view

  1. Click the desired camera from the Lights and Cameras tab.

  2. Move the cursor into the scene view.

    You can hold Alt to detach the shape from the construction plane.

  3. Click to place the camera anywhere in the scene view.

Place cameras at the origin

  1. Click the desired camera from the Lights and Cameras tab.

  2. Move your cursor into the scene view and press Enter to place the shape at the origin.

Place a camera by looking through it

  1. ⌃ Ctrl click the desired camera from the Lights and Cameras tab.

  2. Use the handles or edit the values in the parameter editor to move the camera to the desired location in the scene view.

When looking through the camera there are handles on the sides of the scene view which allows you to orient and crop.

Handles

Clicking on cameras in the scene view gives you more camera and light manipulator handle options. The two that are unique to cameras are the focus handle and the frustum handle.

Frustum handle

Allows you to set the near and far clipping planes and the focal length.

Focus handle

Allows you to control the depth map focus.

Use the view keys to move a camera

  1. Look through a camera as described above. You can also choose a camera to look through once it is created by choosing it in the camera menu.

  2. Lock the camera to the view by clicking the Lock camera/light to the view button, which is located on the toolbar on the right side of the view. You can also lock the camera to view by by turning on Tie Camera (or Light) to View in the camera menu.

  3. Use the tumble, track, and dolly keys to move the camera.

  4. Unlock the camera to place it.

Make a camera look at an object

  1. Create an object.

  2. Create a camera.

  3. Click Look At on the Modify shelf.

  4. Select the object to look at and press Enter.

You can also make a camera look at an object by setting it on the Lookat Options tab on the Transform tab of the parameter editor.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Vellum tab

    The Vellum tab contains tools for creating different types of vellum effects.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical