Houdini 16.5 Shelf tools

Curve shelf tool

Creates polygonal, NURBS, or Bezier curves.

On this page

Placing Curves

  1. Click the Curve shelf option on the Create tab.

  2. Select either Polygon, NURBS, or Bezier from the Primitive Type menu on the operation controls toolbar.

  3. Move the mouse into the scene view and click to place the points.

    The points are grounded on the construction plane. You can hold Alt to detach the curve from the construction plane or hold ⌃ Ctrl to constrain the placement of the points within 45 degree angles.

    You can also reorient the construction plane completely before drawing the curve.

  4. Press Enter or ⇧ Shift + to finish the curve.

To...Do this

Delete the last placed point

Press ⌦ Del.

Move the points of the curve

Click and drag them once they are created.

Note

You can only move individual points at the geometry level. At the object level you can move the entire curve.

Insert points on an existing curve

Press ⇧ Shift + on the curve.

Insert points on the curve

Press ⇧ Shift + anywhere in the scene view.

Connect the first and last points of the curve

Turn on the Close checkbox on the operation controls toolbar. NOTE

The closed curve will appear as a surface in shaded mode.

Change the order for NURBS and bezier

Set it in the operation controls toolbar.

NURBS and Bezier

You can create either NURBS or bezier curves with the curve shelf tool. These types of curves allow you to choose CVs, Breakpoint (knots), or Freehand from the Method menu on the operation controls toolbar. NURBS automatically determine the start and end points of your curve, whereas bezier curves recognize the first point as the start point, the second and third points as control points, and the fourth point as the end point. If the bezier curve has more than four points, the fourth point is also recognized as the start point for the next set of points.

NURBS Curve

Bezier Curve

Polygons

You can also create polygons with the curve shelf tool, and choose either CVs, Breakpoint (knots), or Freehand from the Method menu on the operation controls toolbar; however, when creating polygons both CVs and Breakpoint will act the same way (allow you to place points in the scene view).

NURBS Curve

For specific parameter help see the Curve node help.

Rendering Curves

Rendering curves is done the same way as rendering other objects. However, there are special attributes you can add to curves before rendering. For example, you can specify a desired width or orientation.

Adding Attributes to Curves

  1. Create a curve in the scene view.

  2. At the geometry level, create an AttribCreate node using the tab menu, and connect it to your Curve node.

  3. In the parameter editor of the Attribute Create node, modify the values.

    To...Do this

    Specify the width of the curve

    Change the Name to width, Type to Float, and enter the Value for the width.

    Specify the orientation of the curve

    Change the Name to orient, Type to Vector and enter the Value for the orientation.

  4. Set up lights and cameras, and render the curve.

    For more information, see the Rendering chapter.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical