Houdini 16.5 Shelf tools

Mirror Capture Weights shelf tool

Applies capture weights from one side of a geometry object to another.

This tool saves you time because you can mirror the capture weights of Bones and Muscles on characters instead of creating them twice.

Using Mirror Capture Weights

  1. Click the Mirror Capture Weights tool on the Characters tab.

  2. Select the destination points to mirror the capture weights to and press Enter to confirm your selection.

    Note

    You must include the symmetry points as well.

  3. Select the source bones or muscles to mirror from and press Enter to confirm your selection.

  4. Select the destination bones or muscles and press Enter to confirm your selection.

The first image shows the capture weights before using the mirror tool. The second image shows the capture weights after using the mirror tool.

Note

If you do not get the desired results, you can specify the exact bones or muscles to mirror to by clicking the Spreadsheet button on the operation controls toolbar and choosing the corresponding bones or muscles in the drop-down menu.

You can also choose the exact bones or muscles to mirror to by changing the From and To values in the parameter editor. The first item in the From list corresponds with the first item in the To list and so on.

For specific parameter help see the Mirror Capture Weights on one side of a geometry, and have those painted weights applied to the other side.

STEP 1

To perform this operation, you first select the points in your geometry that you wish to mirror. Only points from a single object can be chosen, and the chosen object must have either a Bone Deform SOP or have the boneCapture or metaCapture capture weight attributes. Once the points on this object are chosen, right-click to proceed.

STEP 2

The second step in this operation is to select the source bone or muscle objects whose weights will be mirrored. When you complete the selection of your points, all bones or muscles with non-zero weights on those points are selected automatically. You can either use this default selection, or modify it, then right-click to proceed. Only bones (objects that contain capture regions) and objects that contain metaballs can be included in this selection.

STEP 3

The third step is to choose the destination bones or muscles that will receive the weights from the source bones or muscles selected in Step 2. After selecting source bone or muscle objects, the set of destination objects whose name match names of the source objects will be selected. Matching is performed by trying to replace the prefix of the source objects' names with a different prefix to generate the destination bone names. This tool finds the shortest prefix possible to allow this substitution. Again, you can either accept this default selection, or modify the selection. Right-click to complete the operation.

A Capture Mirror SOP will be created in the object where you are mirroring capture weights. The SOP will be created as the input to the Bone Deform SOP if there is one, or as the end of the SOP chain if there is no Bone Deform SOP. You will be presented with handles that allow you to define the plane through which the capture weights are mirrored.

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical