Houdini 16.5 Shelf tools

Paint Temperature shelf tool

This tool lets you paint higher or lower temperature on geometry in your fire simulation.

Using Paint Temperature

  1. Create a fire simulation.

  2. Click the Resimulate menu in the bottom right corner of Houdini and turn off the Enable Simulation option.

    Note

    The icon may be greyed out . Once you turn off this option the icon will change to a "do not" symbol.

  3. In the current DopNetwork, find the Gas Burn Geometry node (usually called burnsolver) for the object you want to paint and change the Ignition Temperature to 0.01 and Ignition Range to 0.001.

    In this example we modified burnsolver1 which was the Gas Burn Geometry for the torus object.

  4. Click the Paint Temperature tool on the Volume Fluids shelf.

  5. Select the object you want to paint and press Enter to confirm your selection.

  6. Set the value to paint in the Operation Controls toolbar, and drag the brush over the surface to paint it.

    Tip

    You can change the Radius of your brush by holding ⇧ Shift + and dragging or by changing the value in the Operation Controls toolbar. You can also alter the Opacity in the Operation Controls toolbar.

  7. Click the "do not" icon in the bottom right corner of Houdini and turn the Enable Simulation option back on.

The torus object burns quicker in places where the painted temperature is higher than the Ignition Temperature on the burnsolver (Gas Burn Geometry) node. In this example, the far side of the torus ignites before the side closer to the sphere because the ignition temperature is higher.

Note

Heat is transferred within the smoke box, so an object can become hot enough to ignite before a flame from another object comes in contact with it.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical