Houdini 17.0 Shelf tools

Polygon tab shelf tool

Tools on the Polygon tab let you modify polygons in the scene view.

Shelf tools

  • Poly Extrude

    Extrudes polygonal faces and edges.

  • PolyBevel

    Creates straight, rounded, or custom fillets along edges and corners.

  • Poly Bridge

    Creates flat or tube-shaped polygon surfaces between source and destination edge loops, with controls for the shape of the bridge.

  • PolySplit

    Divides an existing polygon into multiple new polygons.

  • EdgeLoop

    Creates a loop of cuts using polysplit.

  • PolyReduce

    Reduces the number of polygons in a model while retaining its shape. This node preserves features, attributes, textures, and quads during reduction.

  • PolyFill

    Fills holes with polygonal patches.

  • Poly Expand 2D

    Creates offset polygonal geometry for planar polygonal graphs.

  • Edge Collapse

    Collapses edges and faces to their centerpoints.

  • Edge Cusp

    Sharpens edges by uniquing their points and recomputing point normals.

  • Edge Flip

    Flips the direction of polygon edges.

  • Edge Divide

    Inserts points on the edges of polygons and optionally connects them.

  • Dissolve

    Deletes edges from the input polygonal geometry merging polygons with shared edges.

  • Knife

    Divides, deletes, or groups geometry based on an interactively drawn line.

  • Clip

    Removes or groups geometry on one side of a plane, or creases geometry along a plane.

  • Subdivide

    Subdivides polygons into smoother, higher-resolution polygons.

  • Facet

    Controls the smoothness of faceting of a surface.

  • Fuse

    Merges or splits (uniques) points.

  • Smooth

    Smooths out (or "relaxes") polygons, meshes and curves without increasing the number of points.

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Vellum tab

    The Vellum tab contains tools for creating different types of vellum effects.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical