Houdini 17.5 Shelf tools

Smoke Trail shelf tool

Generates a clustered simulation of smoke from an animated object.

On this page

Overview

This tool creates a complex geometry network to generate clustered source geometry for the smoke from points scattered along the object’s animated path. Each cluster of points is simulated in a separate smoke box. Simulating a series of smaller boxes along the path is much more efficient than simulating all smoke in one large box.

How to

To...Do this

Give an animated object a smoke trail

The object should already be animated before you use this tool.

  1. Select an animated object.

  2. On the Pyro shelf, click the Smoke Trail tool.

    The tool creates a Geometry object to generate the smoke source (objectname_sourcepts), a simulation network (if it doesn’t already exist), and a Geometry object to import the results of the simulation back as renderable geometry.

Prevent the smoke from rising

Modify the temperature point attribute in the objectname_sourcepts network before the rasterization loop.

or

Change the buoyancy on the pyrosolver node.

or

In the DOP network, select the source_density_from_ node and set Scale parameter for temperature import (under the Volumes tab) to 0.

Change the smoke density

Modify the density point attribute in the objectname_sourcepts network before the rasterization loop.

or

In the DOP network, select the source_density_from_ node and change the Scale parameter for density import (under the Volumes tab).

Make the smoke dissipate faster or slower

In the DOP network, select the pyrosolver node. Click the Shape tab, then change the Dissipation. Higher values make the smoke dissipate faster.

Apply a material to the smoke

  1. In the material palette, drag one of the materials from under the Volume heading in the tree on the left to the area on the right to create an instance of the material.

    Different materials give different looks to the generated smoke at render time. For example, "Wispy Smoke" looks less dense than "Billowy Smoke".

  2. In the network editor, at the object level, select the pyro_import node. This node imports the results of the simulation (the generated smoke) to make it a renderable object. This object is where you should apply the material.

  3. In the parameter editor, click the Render tab. Click the chooser icon next to the Material field. Select the material you just created (for example, /mat/basicsmoke) and click Accept.

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Vellum tab

    The Vellum tab contains tools for creating different types of vellum effects.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.

Technical