Houdini 16.5 Shelf tools

Source from Surface/Volume/Points shelf tool

Continuously generates smoke, fire, or liquid from a geometry object into a container.

On this page


These tools create nodes that convert the object into a volume and cause it to continuously emit smoke/fire/liquid into a container.

"Source from Surface" and "Source from Volume" are similar, however "Source from Volume" requires that the selected geometry form a closed ("airtight") volume. "Source from Surface" can be used on both open and closed geometry.

See fluid sourcing for information on how the tool transforms the input object into a source for the effect.

This tool continuously generates fluid from the surface of an object, and is similar to Source from Volume. Both create a continuous flow of fluid; however, this tool is can be applied to both open and closed volume objects. Source from Volume cannot be applied to open objects, such as grids or curves because they do not have volumes.

Keep in mind, this tool generates volume based fluid, as opposed to the Emit Particle Fluid tool which generates particle based fluid.


If you are sourcing from an object that deforms, or collides with a deforming object, the solvers (smoke solver, fluid solver, and pyro solver) do not pay attention to the per-point deformation. You need to set the Velocity Type to Point Velocity, which is a parameter on the Fields ▸ Sources subtab of the solvers.

Using Source from X

  1. Create an open geometry object within a container.

    For more information on containers see: Smoke Container, Flamefront Container, and Liquid Container.

  2. Select the geometry object to generate the source.

  3. Click the Source from Surface tool on the Volume Fluids tab.

  4. Select the container to put the source into and press Enter to confirm your selection.


  • The default Fluid Source surface node includes noise to create more interesting fluids. You can edit the parameter on the Fluid Source node’s Noise tab to change the source behavior.

  • To animate the source amount, keyframe the Scale source volume parameter on the Source Volume DOP in the DOP network.

  • This tool is different than using Smoke from Object, Burn from Object, and Liquid from Object because it emits fluid continuously.

    The "source from" tools let you create and simulate multiple objects in a container, whereas the "from object" tools set the initial conditions from one object.

  • If the object is only partially inside the container, only the portion of the object inside the container’s boundaries is simulated.

See also

Shelf tools

Using the shelf

  • Customize the shelf

    How to change the look of the shelf, change and rearrange its contents, and create your own shelf tools.

Shelf tabs

  • Create tab

    Tools on the Create tab let you create and place primitives, curves, and null objects in the scene view.

  • Modify tab

    Tools on the Modify tab let you easily customize objects in the scene view.

  • Model tab

    Tools on the Model tab let you edit objects in the scene view.

  • Polygon tab

    Tools on the Polygon tab let you modify polygons in the scene view.

  • Deform tab

    Tools on the Deform tab let you deform objects in the scene view.

  • Texture tab

    Tools on the Texture tab let you texture objects in the scene view.

  • Rigging tab

    The Rigging tab contains tools for creating premade rigs.

  • Muscles tab

    The Muscles tab contains tools for creating muscles.

  • Characters tab

    Tools on the Character tab let you create characters in the scene view.

  • Constraints tab

    Tools on the Constraints tab create a constraint network where you can constrain objects to each other in the scene view.

  • Hair Utils tab

    Tools on the Hair Utils tab let you quickly set up hair and fur on objects.

  • Guide Process tab

    Tools on the Guide Process tab let you influence the placement and orientation of guide hairs by painting skin attributes.

  • Guide Brushes tab

    Tools on the Grooming tab let you add and directly manipulate hair.

  • Terrain FX shelf tab

  • Cloud FX tab

    The Cloud FX tab contains tools for creating cloud effects.

  • Volume tab

    The Volume tab contains tools for creating volume effects.

  • Lights and Cameras tab

    Tools on the Lights and Cameras tab let you create and place lights and cameras in the scene view.

  • Collisions tab

    Tools on the Collisions tab let you create collision objects in the scene view.

  • Particles tab

    Tools on the Particles tab let you create dynamic particle simulations.

  • Grains tab

    The Grains tab contains tools for simulate grains of sand and other granular matter.

  • Rigid Bodies tab

    Tools on the Rigid Bodies tab let you create dynamic RBD objects in the scene view.

  • Particle Fluids tab

    Tools on the Particle Fluids tab let you create particle based liquids in the scene view.

  • Viscous Fluids tab

    Viscous fluids are FLIP simulations that use a temperature attribute to drive viscosity.

  • Oceans tab

    The Oceans tab contains tools for creating ocean simulations.

  • Fluid Containers tab

    The Fluid Containers tab contains tools for creating pyro, smoke, and liquid containers.

  • Populate Containers tab

    The Populate Containers tab contains tools for creating and removing fire, smoke, and liquid.

  • Container Tools tab

    The Container Tools tab contains tools for manipulating fire, smoke, and liquid.

  • Pyro FX tab

    Tools on the Pryo FX tab let you create simulated smoke and fire effects.

  • Cloth tab

    Tools on the Cloth tab let you create and constrain cloth objects in the scene view.

  • Solid tab

    Tools on the Solid tab let you create and modify solid objects.

  • Wires tab

    Tools on the Wires tab let you create flexible dynamic objects in the scene view.

  • Crowds tab

    The Crowds tab contains tools for creating crowds, crowd behaviors, as well as examples.

  • Drive Simulation tab

    Tools on the Drive Simulation tab let you manipulate dynamic objects in the scene view.