Houdini 11 MPlay viewer

File menu

New

Creates a new window with the view set to 2D, timeline, or histogram.

Open

Opens a new sequence, removing any sequences already loaded.

Merge

Opens a new sequence, without removing any sequences.

Prepend Sequence

Loads a sequence and inserts it before the first frame of the sequence in the current viewport.

Append Sequence

Loads a sequence and inserts it after the last frame of the sequence in the current viewport.

Recent Files

Loads a recently opened file.

Save Frame As

Saves the image in the current viewport.

Save Sequence As

Saves the entire sequence in the current viewport.

Save Preview

Saves the image in the current viewport as it appears, with color correction, transparency, cropping, the background image and component selection applied.

Load Background

Loads a background sequence.

Unload Background

Removes the currently loaded background sequence file.

Quit Application

Exit MPlay.

View menu

2D View

Switch to 2D view.

Timeline

Switch to Timeline view.

Histogram

Switch to Graph view.

Plane

Allows you to switch between planes.

Zoom
Zoom In/Out

Allows you to zoom in and out on the image.

Home

Center the view to show the whole image. You can also home the view by pressing H.

Fit Window to Image

Resize window to the size of the image.

Fit Image to Window

Resize image to the size of the window.

Layout
Columns/Rows

MPlay can layout up to 16 viewports in a 4×4 configuration, each with its own image sequence in the viewport.

Hide Blank Viewports

If this option is turned on, blank viewports are hidden.

User Interface
Fullscreen

Maximizes MPlay’s viewports to the size of the desktop, so that only the viewports are visible. Labels and guides are temporarily turned off. Press Ctrl + F or Esc to return to the MPlay window.

Hide Extra UI

Toggles off all interface bars but the playbar. This option is also accessible through the RMB menu (as the menu bar won’t be displayed).

Menubar

Toggles the menu bar on or off.

Main bar

Toggles the Main Bar on or off. The main bar lies above the viewports and contains mostly viewport management controls.

Display bar

Toggles the Display Bar on or off. The display bar is along the right side of the viewports.

Image Controls

Toggles the Image Controls on or off. It contains the color correction controls for the Image view, Preview rate for the Timeline, and Graph selection for the Graph view.

Audio bar

Toggles the Audio Bar visibility on or off. It contains controls for selecting the audio file, and adjusting the volume and timing.

Playbar

Toggles the Playbar on or off, which controls playback.

Always on Top

If this option is turned on, the MPlay window will always appear in the foreground, even if another window is selected.

Double Buffer

Toggles double buffering on or off. Single buffer mode plays faster than double buffering, but can flicker. If the flicker is distracting, turn double buffering on. (this option can be set in the command line using the -b s|d option).

Help Tips

If on, a help tag will appear when the mouse is held over an interface gadget for a short period of time.

Apply changes to all views

If this option is turned on, changes will be applied to all views. If this option is turned off, changes will only be applied to the current view.

Link Viewport Scrolling

If this option is turned on, scrolling is linked to all views.

Maximize Current Viewport

If this option is turned on,the current viewport is maximized.

Render menu

Disconnected

Disconnected from Houdini.

Listen for Renders

MPlay is connected to Houdini and will show test renders when you click the render icon in Houdini.

Listen for Flipbooks

MPlay is connected to Houdini and will show flipbooks when you click the flipbook icon in Houdini.

New Sequence

Clears previously rendered frames. The next frame rendered from Houdini will be frame 1.

Halt Current Render

Stops the active render currently displayed in the viewport. If there are other renders, they are not affected.

Halt All Render

Stops all active renders.

Disconnect

Disconnects from Houdini. This MPlay will no longer display renders or flipbooks from Houdini.

Anim menu

Play

Start the animation.

Stop

Stop the animation.

Go to First Frame

Reset animation to the first frame.

Go to Previous Existing Frame

Jump to previous frame.

Go to Next Existing Frame

Jump to next frame.

Realtime

If this option is turned on, MPlay will attempt to play the sequence back as closely to realtime as possible. (It may not do realtime playback on the first pass if disk access is not fast enough to load images in realtime.)

Play Mode

Sets the playbar mode to Loop, Play Once, or Zig-Zag.

Set Houdini Frame

Syncs Houdini to the MPlay’s current frame on the playbar.

Export Blocking

Exports the altered keyframes back to Houdini, moving the keyframes in time. This is only used for roughing in the motion.

Load Audio

Loads an audio file. Can also be done through the Audio bar.

Unload Audio

Removes the currently loaded audio file.

Image menu

Reload Sequence

Updates any images which may be out of date since they were loaded.

Remove Sequence

Removes the currently viewed sequence.

Remove Frame

Removes only the current frame. This is useful to get rid of bad test renders.

Image Pixel Scale

Allows you to select the pixel scale of the image from a list or percentages.

Enable LUT

Turns on the LookUp Table feature of MPlay. LUTs are channel files that do more advanced color correction than simple gamma & brightness correction.

Load LUT

Select a LUT file from disk to apply to the images.

Compare Images

Turns on diffing. This allows you to compare one image to another through a variety of methods, such as differencing, blending, and wiping.

Inspect Images

Causes a small inspection window to pop-up where the mouse is which shows you the values of the pixel under the cursor as well as its location in the image.

Clear Cache

Removes all cached images.

Cache All

Load all images into the cache. The cache limit will be increased to hold all the images, unless the limit would be beyond the capability of the system (in which case, pre-caching will stop prematurely).

Add Frame Comment

Allows you to add a simple text comment to the currently displayed frame. This comment will be saved with the image if the image format supports comments.

Windows menu

Preferences

Opens the Preference dialog. The preference dialog contains general MPlay settings.

Profiles

Opens the Profiles dialog . The profile dialog allows you to customize settings and the interface layout for specific uses of MPlay, like rendering, viewing, and image analysis.

Display Options

Opens the Display Options window. The display options deal with viewport settings and image display.

Sequence List

Open the Sequence List, which displays all the sequences loaded and allows you to shift, trim, reload, remove, flip or reorder them.

Textport

Opens the Textport. MPlay has a smaller HScript command set than Houdini, with some MPlay-specific commands.

Help Browser

Opens this help browser.

MPlay menu bar controls

These controls are on the right side of the menu bar.

The rendering controls will only appear if you opened MPlay from Houdini’s render menu, or if you started it from the command line with the -K option.

Halves the size of the MPlay window down to the minimum window size).

Doubles the size of the MPlay window up to the size of the screen.

Clears previously rendered frames, and starts a new sequence.

Kills the render.

Disconnects from Houdini.

Opens the help browser for MPlay.

MPlay main bar controls

Displays the image view.

Displays the timeline view.

Displays the histogram view.

Drop-down menu

Allows you to switch between planes.

Zooms in on the image.

Zooms out on the image.

Centers the view to show the whole image.

Resizes image to the size of the viewport.

Shows image information.

Maximized the current viewport.

Applies changes to all views. If this option is turned off, changes will only be applied to the current view.

Links scrolling to all views.

MPlay control bar

Shows all planes.

Shows only the red plane.

Shows only the green plane.

Shows only the blue plane.

Shows only the alpha plane.

Icon drop-down menu

Allows you to alternate between the Brightness and Contrast controls and the White & Black Points controls.

Allows you to adjust the brightness value. Click the icon to reset to the default value of 1.

Allows you to adjust the contrast value. Click the icon to reset to the default value of 1.

Allows you to adjust the bright shift value. Click the icon to reset to the default value of 0.

Allows you to adjust the black point value. Click the icon to reset to the default value of 0.

Allows you to adjust the white point value. Click the icon to reset to the default value of 1.

Allows you to adjust the gamma value. Click the icon to reset to the default value of 1.

Clicking this icon will enable the LUT. Clicking RMB on this icon will give you to option to Load LUT or Enable LUT.

Adapts the image to full pixel range.

Playbar controls

See Playbar help page.