Houdini 17.5 ノード ジオメトリノード

UV Flatten 2.0 geometry node

3Dジオメトリのテクスチャ空間に平坦化されたピースを作成します。

On this page

概要

3Dモデルにテクスチャ画像を適用するには、コンピュータ側にその平坦な画像のピクセルを3Dサーフェス上のポイントにマッピングする方法を伝えるために、まず最初にテクスチャ空間内に 平坦化された バージョンの3Dジオメトリを作成する必要があります。モデルを平坦化したこの表現は、そのジオメトリの各頂点上のアトリビュート(通常はuv)にUV座標として記録されます。

このノードは、2つの工程で動作します。 このノードは、( シーム(継ぎ目) を定義してモデルのジオメトリを扱いやすい小さなピースに分割した)個々のテクスチャピースを受け取り、それらのピースを2Dテクスチャ空間に 平坦化 して、ポリゴンサイズの均等化を試みます。

Note

このノードは、インタラクティブ性が最適化されたアルゴリズムを使って、UVピースを詰め込みます。 もっとオプションが欲しい、もっと効率的な詰め込みを行ないたいのであれば、このノードとUV Layoutノードを併用してください。

このノードは、平坦化アルゴリズム用の向けに拘束を追加することができます。 この拘束は、強制的にレイアウトアルゴリズムが特定の条件を満たすようにして、最終UVレイアウトに対してさらなる制御を可能にします。

このノードの状態でツールを使って拘束を指定すれば、このノードをインタラクティブに使用することができます。 または、 Manual Layout を無効にすれば、このノードをプロシージャルに使用することができます。

ワークフロー

To...Do this

UVが表示されるようにビューアをセットアップする

デフォルトでは、Houdiniのビューアは1個のPerspectiveビュー("Persp")しか表示しません。 マルチビューポートレイアウトに切り替えて、それらのどれかのビューポートで、現行ネットワークのジオメトリのUV空間を表示することができます。

  • ビューアの分割方法を設定するには、Scene Viewペインの一番右上にある Layoutメニューアイコンをクリックしてから、 "Four Views"や "Two Views Side by Side"などのレイアウトを選択します。

  • ビューポートがUV空間を表示するように切り替えるには、(ビューポートの右上にある左側の)Viewメニューをクリックして、 Set View ▸ UV viewport をクリックするか、マウスカーソルをビューポート上に置いて、Space + 5を押します。

UV Flattenを使って、モデルのテクスチャ空間を配置する

  1. UVビューが表示されるようにビューアをセットアップします。

  2. テクスチャ空間内に平坦化させたいジオメトリを選択します。

  3. Texture シェルフタブで、 UV Flattenツールをクリックします。

  4. (ビューアの上部に表示された)オペレーションツールバーまたはパラメータエディタのコントロールを使って、ノードの挙動を変更します。

注: 最初はほとんどのジオメトリは自己重複したピースに平坦化されます。例えばトーラスにUV Flattenを適用すると、単にトーラスの上部と下部がUV平面内にお互いに重なった状態で投影されます。 このノードが別々に3Dピースを重複のない平坦なピースに"アンラップ(展開)"できるようにするには、UVシームをカットする必要があります。

拘束を追加する

ビューア内でノードの状態がアクティブになっている時、ビューアの上部にあるオペレーションツールバー内のツールアイコンを使用することで、ビューアのクリックで拘束を追加できるツールを切り替えることができます。

(ビューア内でのコンテキストメニューからでもツールを切り替えることができます。)

クリックすると即座に動作するように、または、選択してEnterが押されるのを待ってから動作するようにツールを切り替える方法に関しては、クィック選択を参照してください。

拘束を除去する

  • シームを除去するには、Sewツールを使用します。

  • ピンを除去するには、ピンをクリックして選択してから、⌦ Delを押します。

  • 整列または直線拘束を除去するには、整列させたエッジのどれかをクリックして選択してから、⌦ Delを押します。

  • 矩形拘束を除去するには、矩形にした領域をクリックして選択してから、⌦ Delを押します。

再度ビューア内にUV Flattenインターフェースを表示させる

従来のように ⎋ Escを押してViewツールに切替えたり、別のノードに切替えると、ビューアは、その新しいツールのインターフェースの表示に切り替えます。

再度UV Flattenインターフェースを表示するには、ネットワークエディタでUV Flattenノードを選択してから、 Handlesツールをクリック、または、ビューア内でEnterを押します。

詰め込み先の領域を指定する

UV Flattenツールを有効にすると、UVビューの0,0から1,1までの領域にボックスハンドルが表示されます。 このノードは、平坦化されたピースをこの領域内に詰め込みます。このボックスの角または辺をドラッグすることで、その詰め込み領域のサイズ/形状を変更することができます。 CenterSize のパラメータを使用することで、このボックスの座標を正確に設定することもできます。

これは、既存のUV島の UV Attribute と干渉しないようにする必要がある場合、または、0,0から1,1以外のUV領域にピースを詰め込みたい場合に役立ちます。

Note

どれかのピースをピン留めしておけば、詰め込み領域を変更しても、それらのピースは移動もサイズ変更もしなくなります。

クィック選択

  • クィック選択が有効(デフォルト)になっている時、特定のツールがクリックに即座に反応します:

    • Cutツールでは、エッジをクリックすると、そのエッジがシームになります。

    • Sewツールでは、シームエッジをクリックすると、そのシームが除去されます。

    • Rectifyツールでは、四角グリッド領域上にマウスカーソルを動かすとその領域がハイライトされます。四角グリッド領域内をクリックすると、その全体の領域が選択されます(それでも、拘束を適用するには、Enterを押す必要があります)。

  • クィック選択が無効になっている時、どのツールでも、ポイント/エッジ/フェースを選択してからEnterを押さなければなりません。

To...Do this

クィック選択を切り替える

ビューア内で右クリックして、 Quick Selection を選択します。

手動によるレイアウトを理解する

UV Flattenには、インタラクティブな方法とプロシージャルな方法の2通りの使い方があります。 これらの方法を切り替えることができますが、このノードの挙動の違いを理解する必要があります。

  • インタラクティブ (デフォルト)な方法でこのノードを使用すると、詰め込み前にシームをカットするといったいくつかの拘束( Layout Constraints )を適用してから、それらの拘束の影響を受けた形状を使って、ピースを詰め込みます。すると、インタラクティブに複数の拘束(例えば、複数シームのカット、UVsのピン留め)を作成することができます。これらの拘束( Flattening Constraints )は、詰め込んだレイアウトに 対して 適用されます。

    その理由は、それぞれピースを少し変更した後に詰め込み直すと、レイアウトが根本的に変わってしまうので、それらのピースがあちこちに飛んでインタラクティブに作業するのが極端に難しくなるからです。 インタラクティブな変更を 詰め込み後 に適用することで、作業する時にピースが動かなくなります。

    インタラクティブな変更を"確定"して、新しい拘束を使ってもっと効率的なレイアウトで詰め込みし直したい場合、ビューアの上部にあるオペレーションツールバーの Repack ボタンをクリックします。 Repack をクリックすると、このノードは、インタラクティブに追加した詰め込み後の"Flattening"拘束を詰め込み前の"レイアウト"拘束パラメータに コピー します。 次に、このノードは、それらの拘束を考慮してピースを詰め込みし直します。

    インタラクティブな変更、レイアウトへの影響を確認して詰め込みし直し、必要に応じてもっとインタラクティブな変更を加えるといったサイクルで作業することができます。

  • このノードでは、平坦化処理をインタラクティブではなく プロシージャル に作業したいことでしょう。例えば、スクリプトを使って何かしらの方法でシームを計算することができます。または、既存の島があって、このノードをレイアウトまたはUVの緩和化に使用したいだけかもしれません。この場合、 Repack をクリックすることなく、パラメータを変更するだけで即座にその結果を出力に反映させたいです。

    このノードがプロシージャルに動作するように設定するには、( Layout Constraints 下にある) Enable Manual Layout パラメータを有効にします。

    Enable Manual Layout が有効な時、"Flattening"拘束が 唯一の拘束 になり、それらの拘束は 詰め込み前 に適用されます。 詰め込み後の拘束はありません。そのため、"Layout"拘束パラメータ内の値は無視されます。

    このモードでは、"Flattening"拘束に加えた変更は即座にノードの出力に反映されます。

シーム(継ぎ目)

シームには、このアルゴリズムがジオメトリをピースに切断する箇所を指定します。 モデルに何もシームがなければ、このノードは、単にジオメトリをUV平面上に投影するだけの機能になります。 モデルが極端に単純でない限り、これだと、悪い歪みとUVピースの重なりを生成してしまいます。

このノードは、自動的にシームを追加しません。 このノードの前にUV Autoseamノードを接続するか、または、Cutツールを使って手動でシームをカットすることができます。 通常では、ジオメトリを平坦化する時にそれらが重ならないように最低でも2,3個のピースにカットを加える必要があります。

To...Do this

UV Flattenツールを使って、インタラクティブにシームをカットする

  1. (ビューアの上部にある)オペレーションツールバーの Cutアイコンをクリックします。

  2. Secure選択が有効かどうかで、このCutツールの挙動が変わります。以下のSecure選択を参照してください。

シーム(継ぎ目)を結合する

  1. (ビューアの上部にある)オペレーションツールバーの Joinアイコンをクリックします。

  2. Secure選択のオン/オフによって、このJoinツールの挙動が変わります。以下のSecure選択を参照してください。

このツールは、継ぎ目にしていたエッジ(seamsグループ内のエッジまたはインタラクティブにカットしたエッジ)の"カットを戻します"。 UVビュー内で"分割線"の片側をクリック/選択するだけで両側が結合されます。このツールを使って、3Dモデルの境界になっているエッジを結合することはできません。

エッジの結合を開始する時に、平坦化されたピース自体が重なっていると個々のエッジを確認/クリックしにくいことがあります。 そんな時は、UVビューよりも3D Perspectiveビューでエッジをクリック/選択した方が扱いやすいでしょう。

新しい継ぎ目を考慮してピースを再パックする

(ビューアの上部にある)オペレーションツールバーの Repack ボタンをクリックします。

Tips

  • UVビューまたは3Dビューでエッジをクリックすることができます。

  • このノードには、継ぎ目を維持するためのパラメータが2つあります: "Layout" Seams と"Flattening" Seams 。これは、インタラクティブな継ぎ目カットに対応するためにあります。継ぎ目をインタラクティブにカットすると、その新しい継ぎ目が "Flattening" Seamsパラメータに追加されます。これらの継ぎ目は、 平坦化 に影響を与えます(カットする度にピースの形状が変化します)が、 配置 には影響を与えません(このノードは、カットする度にすべてのピースを異なる位置に再パックするわけではありません)。

    Repack をクリックすると、このノードは、"Flattening" __Seams__を"Layout" Seams にコピーし(つまり、継ぎ目が配置に影響を与えます)、 Post-Packing をクリアします。

    詳細は、以下の手動レイアウトを理解するを参照してください。

  • 島境界エッジは、UVビュー内で明るい緑で表示されます。( Post-Packing パラメータ内の)"新しい"継ぎ目の線は太くなります。

頂点のピン留め

ピンは、ピース上の単一ポイントを同じUV座標に維持します。 このノードが平坦化とレイアウトを再計算した時、その頂点がその位置のままになります。 しかし、ピンをドラッグすると、そのピン留めされたポイントが動き、他の拘束されていないポイントすべてが移動/回転して新しいピンの位置に順応します。 (回転ピボットをピン留めしてから、2番目のピンを追加してそれをドラッグすることで、1つ目のピンを基準に島を回転させることができます。)

To...Do this

頂点をその位置でピン留めする

  1. (ビューアの上部にある)オペレーションツールバーの Pinアイコンをクリックします。

  2. ピン留めしたい頂点をUVビュー内で1つ以上選択してEnterを押します。

ピンを動かす

  1. (ビューアの上部にある)オペレーションツールバーの Pinアイコンをクリックします。

  2. 既存のピンをクリックします。

    そのピン上に移動ハンドルが表示されます。

  3. ハンドルをドラッグしてピンを動かします。

  • 島の中にピンを配置して、そのピンをテクスチャ空間内でドラッグすることで、島を動かすことができます。

  • 島の中に 2個 のピンを配置して、片方のピンを基準にもう片方のピンをドラッグすることで島を回転させることができます。

ピンを削除する

  1. (ビューアの上部にある)オペレーションツールバーの Pinアイコンをクリックします。

  2. 既存のピンをクリックします。

  3. Deleteを押します。

Tip

ピンを扱うには、Pinモードが選択されている必要があります。 例えば、Cutモードの時にピンをクリックすると、このツールは、そのピン下のエッジをカットしてしまいます。

整列と直線化

特定のグループのエッジを真っ直ぐに、または、UVグリッドに整列させるようにノードに命令することができます。 このノードは、テクスチャピースを再平坦化する時に、それらのヒントを考慮します。

Tip

これらのヒントが他のピン留めなどの拘束と干渉している場合には、エッジが完全に真っ直ぐまたは軸整列しなくなります。 他の拘束を削除することで、このノードは、より真っ直ぐ/整列するように再平坦化されます。

To...Do this

エッジを真っ直ぐにする(ABFのみ)

  1. (ビューアの上部にある)オペレーションツールバーの Straightenアイコンをクリックします。このモードは、 Flattening Method が"Angle-based (ABF)"の時にのみ利用可能です。

  2. いくつかの隣接エッジを選択してから、Enterを押します。

    このノードは、テクスチャピースを再平坦化する時にこれらのエッジを真っ直ぐにする必要があることを記憶します。

頂点をU軸またはV軸に整列させる

  1. (ビューアの上部にある)オペレーションツールバーの Alignアイコンをクリックします。

  2. お互いに整列させたい頂点を選択してから、Enterを押します。

このツールは、経験則から、ポイントからもっとも近い座標軸に基づいてUまたはVのどれかに整列させます。 その整列軸を変更したい場合は、パラメータエディタで Axis Aligned Vertex Groups ヘッダを展開し、作成されたばかりの整列拘束を探し(拘束リストの最後にあります)、 Align Parallel To パラメータでその拘束にあった値に変更します。

新しい直線化/整列の拘束を考慮してピースを再パックする

(ビューアの上部にある)オペレーションツールバーの Repack ボタンをクリックします。

四角形を矩形にする

矩形グリッド状の四角形ポリゴンを含んだ領域に対して、それらのポリゴンがUV軸に沿って矩形グリッドとしてレイアウトされるように拘束することができます。 これは、歪みを軽減して、レイアウトを綺麗にすることができます。

To...Do this

  1. (ビューアの上部にある)オペレーションツールバーの Rectifyアイコンをクリックします。

  2. クィック選択が有効な場合、このツールは、四角形グリッド上にマウスカーソルを動かすと、その領域をハイライトし、1クリックでその領域全体を選択します。クィック選択が無効な場合、整列させたいプリミティブすべてを選択してからEnterを押さなければなりません。

可視化

このツールの状態がビューアでアクティブになっている時、UVを可視化できるようにモデル上にパターンを重ねます。 これによって、歪みや重なりがある箇所をはっきりとさせることができます。

To...Do this

オーバーレイを無効にする

ビューア内で右クリックして、 Visualize Texture ▸ Off を選択します。

オーバーレイをもっと上手く表示できるように、マテリアル/テクスチャの表示を無効にする

メニューの右側にあるディスプレイツールバーで、 Display Materials on Objectsボタンを無効にします。

オーバーレイパターンを変更する

ビューア内で右クリックして、 Visualize Texture を選択してから、パターンを選択します。

このメニュー内の Display Orientation Glyph を有効にすると、そのパターンに"L"形状が追加されるので、テクスチャが180度回転していないか調べることができます。

オーバーレイのスケールを変更する

ビューア内でを上または下にスクロールさせると、オーバーレイパターンのスケールが変わります。

パラメータ

Group

テクスチャ空間で平坦化させたいポリゴンフェース。 これが空っぽの場合、このノードは、すべての入力ポリゴンに対して動作します。ここにグループ名を入力したり、ポリゴン番号を指定することができます。 このフィールドの隣にある Reselectボタンをクリックすることで、ビューア内で別のポリゴンを選択することができます。

UV Attribute

UV座標を格納するアトリビュートの名前(デフォルトはuv)。 同じジオメトリ上に複数のUVセットを持たせたいのであれば、別の名前を入力します。

Flattening Method

3Dジオメトリを2Dテクスチャ空間に平坦化する方法。 このノードには、異なるヒント(拘束)を許可し、効率性の異なるメソッドが2つあります。 どちらのメソッドも 角度の歪み が最小限になるように設計されています。つまり、テクスチャを貼る3Dサーフェス上にテクスチャ画像を投影した時にそのテクスチャ画像の角度が正しく反映されます。 これらのメソッドは、主にポリゴンをテクスチャ空間でほぼ同じサイズに維持させる 面積の歪み の制御方法が異なります。

Spectral (SCP)

デフォルト。Angle Baseと比べて高速で堅牢性がありますが、若干低品質です。

Angle Based (ABF)

遅くて、必ずしも計算できるとは限りませんが、高品質(面積の歪みが少ない)です。

Existing UVs

UV Attribute のテクスチャ座標が既に存在していた場合のその既存のテクスチャピースの扱い方。

Preserve Seams

入力ジオメトリ内の既存のseams(継ぎ目)が Seams パラメータの内容に追加されます。

Preserve Layout

既存のUV島の位置を維持しつつ、それらの島周辺に新しい島の配置を試みます。

Preserve Island Boundary Shapes (SCP only)

既存のUV島の形状を維持し(回転またはスケールは可能)、その内部UVを再平坦化します。既存のUV島をそのままの位置に維持しつつUVをリラックス化させたいのであれば、このオプション Preserve Layout を有効にします。

Flattening Constraints

Seams

Enable Manual Layout が無効の時、seams(継ぎ目)は"インタラクティブ"な詰め込み後のseams(継ぎ目)になります。 このパラメータ内のエッジが"Layout" Seamsパラメータ内に入っていない場合はカット、"Layout" Seamsパラメータ内のエッジがこのパラメータ内に入っていない場合は結合されます。 Enable Manual Layout が有効の時、seams(継ぎ目)は単なる継ぎ目拘束になり、"Layout" Seams パラメータは無視されます。

詳細は、上記の手動レイアウトを理解するを参照してください。

Rectify group

矩形グリッド状の四角形ポリゴンを定義したエッジセット。このツールは、選択した領域内のすべてのエッジをリストしますが、このフィールドをプロシージャルに埋めたいのであれば、 水平な 頂点エッジのみを埋めるだけで十分です。これは、頂点エッジのリストです。

Vertex Pins

Enable Pins

すべてのピンを有効または無効にする"マスタースイッチ"。

このセクションには、各項目がピンに相当するマルチパラメータが含まれています。 これらのパラメータを変更することでピンを編集することができますが、通常では、インタラクティブにそれらのピンを変更した方が簡単です。 上記の頂点のピン留めを参照してください。

Primitive/Vertex

ピン留めされた頂点を含んだポリゴンのプリミティブ番号と、そのポリゴン内のピン留めされた頂点のシーケンスインデックス。

UV

頂点をピン留めする座標。

Reference UV

同じポリゴン内の次の頂点のUV座標。ピンがそれぞれのUV島の唯一のピンでない限り無視されます。主にインタラクティブの状態で使用されます。

Axis-Aligned Vertex Groups

Enable Axis Alignment

すべての整列拘束を有効または無効にする"マスタースイッチ"。

このセクションには、各項目が整列拘束に相当するマルチパラメータが含まれています。 ここでは個々に拘束を削除することができます。上記のエッジの整列を参照してください。

Group

一直線に揃える頂点。同じポイントに繋がっているUV内のどれかの1点の頂点を含めるだけで十分です。

Align Parallel To

整列させる軸。

Straightened Loops (ABFのみ)

Enable Loop Straightening

すべての直線化拘束を有効または無効にする"マスタースイッチ"。

このセクションには、各項目が直線化拘束に相当するマルチパラメータが含まれています。ここでは個々に拘束を削除することができます。上記のエッジの直線化を参照してください。

Group

一連のエッジを強制的に直線化させる頂点のグループ。これは、頂点エッジのリストです。

Layout Constraints

Enable manual layout

ノードを非インタラクティブな動作に切り替えます。Flattening Constraintsは詰め込み前に適用され、Layout Constraintsは無視されます。 これは、ノードをプロシージャルに利用することができ、パラメータを変更すると、 Repack をクリックすることなく即座にそのノードの出力が変更されます。

詳細は、上記の手動レイアウトを理解するを参照してください。

Seams

Enable Manual Layout が無効の時、seams(継ぎ目)は"元"の詰め込み前のseams(継ぎ目)になります。 Enable Manual Layout が有効の時、"Flattening" Seamsは単なる継ぎ目拘束になり、このパラメータは無視されます。

詳細は、上記の手動レイアウトを理解するを参照してください。

Output Groups

Seams

このパラメータの隣にあるチェックボックスを有効にすることで、seamエッジを含んだ出力にエッジグループを作成することができます。

Constrained Islands

このパラメータの隣にあるチェックボックスを有効にすることで、ピン、軸整列、直線化の拘束を持つ島すべてのポリゴンを含んだ出力にプリミティブグループを作成することができます。

Packing Area

このノードがテクスチャピースの詰め込みを試みるテクスチャ空間の領域を制御します。 これらのパラメータを使ってその領域を正確に定義したり、このノードがアクティブな時にUVビュー内のボックスハンドルのコーナーまたは辺をドラッグすることができます。

Center

詰め込み領域の中心をUV座標で指定します。

Size

詰め込み領域の幅と高さをUV単位で指定します。

頂点エッジグループについて

矩形化グループと直線化グループのフィールドには、 頂点エッジ のリストを格納します。 各エッジは、頂点番号で表現されています。 各頂点番号は、その頂点から次の頂点を時計回りで結んだ頂点エッジを意味します。

これらのフィールドには、プリミティブエッジの代わりに頂点を使用しなければなりません。 その理由は、プリミティブエッジは、両側のポリゴン間で 共有 されているからです。 どちらかのエッジがシームだった場合、どちら側のエッジを整列させるべきなのか曖昧になってしまいます。

See also

ジオメトリノード

  • Adaptive Prune

    全体的な外観の維持を試みつつエレメントを削除します。

  • Add

    点、ポリゴンを作成、または点/ポリゴンを入力に追加します。

  • Agent

    エージェントプリミティブを作成します。

  • Agent Clip

    エージェントプリミティブに新しいクリップを追加します。

  • Agent Clip

    エージェントプリミティブに新しいクリップを追加します。

  • Agent Clip Properties

    エージェントのアニメーションクリップの再生方法を定義します。

  • Agent Clip Transition Graph

    アニメーションクリップ間で可能なトランジション(遷移)を表現したジオメトリを作成します。

  • Agent Collision Layer

    衝突検出に適した新しいエージェントレイヤを作成します。

  • Agent Configure Joints

    エージェントのジョイントの回転制限を指定するPointアトリビュートを作成します。

  • Agent Constraint Network

    コンストレイントネットワークを構築して、エージェントの手足をまとめます。

  • Agent Definition Cache

    エージェント定義ファイルをディスクに書き出します。

  • Agent Edit

    エージェントプリミティブのプロパティを編集します。

  • Agent Layer

    エージェントプリミティブに新しいレイヤを追加します。

  • Agent Look At

    エージェントの頭が、指定したオブジェクトや位置に向くように調整します。

  • Agent Look At

    エージェントの頭が、指定したオブジェクトや位置に向くように調整します。

  • Agent Prep

    他の群衆ノードで使用する色々な共通Pointアトリビュートをエージェントに追加します。

  • Agent Prep

    他の群衆ノードで使用する色々な共通Pointアトリビュートをエージェントに追加します。

  • Agent Proxy

    エージェントに対してシンプルなプロキシジオメトリを用意します。

  • Agent Relationship

    エージェント間に親子関係を作成します。

  • Agent Terrain Adaptation

    エージェントの足を地形に順応させて、滑りを回避します。

  • Agent Transform Group

    新しいトランスフォームグループをエージェントプリミティブに追加します。

  • Agent Unpack

    エージェントプリミティブからジオメトリを抽出します。

  • Agent Vellum Unpack

    Vellumシミュレーション用にエージェントプリミティブからジオメトリを抽出します。

  • Alembic

    Alembicシーンファイル(.abc)からジオメトリをジオメトリネットワークに読み込みます。

  • Alembic Group

    Alembicプリミティブ用のジオメトリグループを作成します。

  • Alembic Primitive

    Alembicプリミティブの組み込みプロパティを修正します。

  • Alembic ROP Output Driver

    シーンをAlembicアーカイブとしてエクスポートします。

  • Align

    プリミティブのグループをお互いに整列または補助入力に揃えます。

  • Assemble

    一連の分解処理をキレイにしてその結果の破片を作成します。

  • Attribute Blur

    メッシュまたはポイントクラウドのポイントをブラー(または"リラックス")します。

  • Attribute Cast

    Houdiniが以前に保存したアトリビュートのサイズ/精度を変更します。

  • Attribute Composite

    2つ以上の選択要素間で頂点/ポイント/プリミティブ/Detailアトリビュートを合成します。

  • Attribute Copy

    頂点/ポイント/プリミティブのグループのアトリビュートをコピーします。

  • Attribute Create

    ユーザー定義アトリビュートを追加・編集します。

  • Attribute Delete

    Point/Primitiveアトリビュートを削除します。

  • Attribute Expression

    単純なVEXエクスプレッションでアトリビュートを修正することができます。

  • Attribute Fade

    Pointアトリビュートが時間に合わせてフェードイン・アウトします。

  • Attribute Interpolate

    ウェイトなどに基づいてアトリビュートを補間します。

  • Attribute Mirror

    平面の片側から反対側にアトリビュートをコピー・反転します。

  • Attribute Noise

    入力ジオメトリのアトリビュートにノイズを追加します。

  • Attribute Promote

    アトリビュートをあるジオメトリレベルから他のジオメトリレベルへ昇進または降格します。

  • Attribute Randomize

    多様に分布したランダムなアトリビュート値を生成します。

  • Attribute Rename

    ポイント/プリミティブのアトリビュートの名前変更・削除をします。

  • Attribute Reorient

    2つのモデル間の違いに基づいてPointアトリビュートを修正します。

  • Attribute String Edit

    文字列アトリビュートの値を編集します。

  • Attribute Swap

    アトリビュートの内容をコピー、移動、スワップします。

  • Attribute Transfer

    2つのモデル間で頂点/ポイント/プリミティブ/Detailのアトリビュートを転送します。

  • Attribute Transfer By UV

    UVの近接度に基づいて、2つのジオメトリ間でアトリビュートを転送します。

  • Attribute VOP

    VOPネットワークを実行してジオメトリアトリビュートを修正します。

  • Attribute Wrangle

    VEX Snippetを実行して、アトリビュートの値を修正します。

  • Attribute from Map

    テクスチャマップ情報をPointアトリビュートにサンプリングします。

  • Attribute from Volume

    ボリュームからの情報を追加で再マップして他のジオメトリの一部にコピーします。

  • Bake ODE

    ODE/Bulletソルバ用にプリミティブを変換します。

  • Bake Volume

    ボリュームプリミティブ内のライティングの値を計算します。

  • Basis

    NURBS曲線/サーフェスのパラメトリック空間の範囲内でノットを移動させる操作をします。

  • Bend

    ベンド、テーパ、スクァッシュ/ストレッチ、ツイストといった変形を適用します。

  • Blast

    プリミティブ/ポイント/エッジ/ブレークポイントを削除します。

  • Blend Shapes

    同じトポロジーの形状間で3Dモーフィングを計算します。

  • Blend Shapes

    同じトポロジーの形状間で3Dモーフィングを計算します。

  • Block Begin

    ループブロックの開始。

  • Block Begin Compile

    コンパイルブロックの開始。

  • Block End

    ループブロックの終了/出力。

  • Block End Compile

    コンパイルブロックの終了/出力。

  • Bone Capture

    キャプチャーウェイトをボーンに割り当てることで Bone Deformに対応します。

  • Bone Capture Biharmonic

    四面体メッシュのBiharmonic(重調和)関数に基づいてキャプチャーウェイトをポイントに割り当てることによる変形をサポートします。

  • Bone Capture Lines

    適切なアトリビュートを使ってボーンからラインを作成することで、Bone Capture Biharmonicをサポートします。

  • Bone Capture Proximity

    キャプチャーウェイトをボーンまでの距離に基づいたポイントに割り当てることで、Bone Deformに対応します。

  • Bone Deform

    ボーンから作成されたキャプチャーアトリビュートを使用して、そのボーンの動きに合わせてジオメトリを変形します。

  • Bone Link

    ボーンオブジェクト用にデフォルトのジオメトリを作成します。

  • Boolean

    2つのポリゴンオブジェクトをブール演算で組み合わせたり、2つのポリゴンオブジェクト間の交線を検索します。

  • Boolean Fracture

    切断サーフェスを使って入力ジオメトリを粉砕します。

  • Bound

    入力ジオメトリ用に境界ボックス、球、矩形を作成します。

  • Box

    立方体または6面の矩形ボックスを作成します。

  • Bulge

    1番目の入力のポイントを2番目の入力の1つ以上のマグネットを使って変形します。

  • Cache

    プレイバックを高速化するために入力ジオメトリを記録してキャッシュ化します。

  • Cap

    開口部を平面または丸めて閉じます。

  • Capture Attribute Pack

    配列アトリビュートを単一のIndex Pairのキャプチャアトリビュートに変換します。

  • Capture Attribute Unpack

    単一のIndex Pairのキャプチャアトリビュートを、ポイント単位のDetail配列アトリビュートに変換します。

  • Capture Correct

    キャプチャー領域とキャプチャーウェイトを調整します。

  • Capture Layer Paint

    キャプチャーアトリビュートを直接ジオメトリにペイントすることができます。

  • Capture Mirror

    対称モデルの片半分のキャプチャーアトリビュートをもう片方にコピーします。

  • Capture Override

    個々のポイント上にキャプチャーウェイトを上書きします。

  • Capture Region

    ポイントがボーンにキャプチャーされる範囲内でボリュームを作成することでCaptureとDeformに対応します。

  • Carve

    プリミティブからポイントや断面をスライス、カット、抽出します。

  • Channel

    CHOPからサンプルデータを読み込み、それをポイントポジションとPointアトリビュートに変換します。

  • Circle

    開閉の円弧、円、楕円を作成します。

  • Clay

    NURBSフェース/NURBSサーフェス上のポイントを直接引っ張ることでそれらを変形します。

  • Clean

    汚れたモデルをクリーンアップします。

  • Clip

    平面の片側のジオメトリを削除します。

  • Cloth Capture

    低解像度でシミュレーションしたClothオブジェクトをキャプチャーします。

  • Cloth Deform

    Cloth Capture SOPでキャプチャーしたジオメトリを変形します。

  • Cloud

    ソースジオメトリのボリューム表現を作成します。

  • Cloud Light

    Diffuseライトでボリュームを充たします。

  • Cloud Noise

    雲のようなノイズをFogボリュームに適用します。

  • Cluster

    ポジション(またはベクトルアトリビュート)に基づいたクラスタポイントへの低レベル機械言語。

  • Cluster Points

    ポジション(またはベクトルアトリビュート)に基づいたクラスタポイントへの高レベルノード。

  • Collision Source

    DOP衝突で使用するジオメトリとVDBのボリュームを作成します。

  • Color

    カラーアトリビュートをジオメトリに追加します。

  • Comb

    ペイントでサーフェスポイントの法線を調整します。

  • Connect Adjacent Pieces

    隣接する破片間にラインを作成します。

  • Connectivity

    繋がったプリミティブまたはポイントの各セットに対して固有の値でアトリビュートを作成します。

  • Control

    コントロールシェイプとして利用する単純なジオメトリを作成します。

  • Convert

    ジオメトリをあるジオメトリタイプから他のタイプに変換します。

  • Convert HeightField

    2D Heightフィールドを3D VDBボリューム、ポリゴンサーフェス、ポリゴンスープサーフェスに変換します。

  • Convert Line

    ジオメトリを線分に変換します。

  • Convert Meta

    メタボールジオメトリをポリゴン化します。

  • Convert Tets

    指向性の四面体メッシュサーフェスを生成します。

  • Convert VDB

    Sparse(疎らな)ボリュームを変換します。

  • Convert VDB Points

    Point CloudとVDB Points Primitiveを相互変換します。

  • Convert Volume

    ボリュームのアイソサーフェスをポリゴンサーフェスに変換します。

  • Convex Decomposition

    入力ジオメトリを、近似した凸セグメントに分割します。

  • Copy Stamp

    入力ジオメトリのコピーを複数作成します。またはジオメトリを2番目の入力のポイントにコピーします。

  • Copy and Transform

    ジオメトリをコピーして、それらのコピーにトランスフォームを適用します。

  • Copy to Points

    1番目の入力のジオメトリを2番目の入力のポイント上にコピーします。

  • Crease

    手動でポリゴンエッジからcreaseweightアトリビュートを追加/削除します。Subdivide SOPと組み合わせて使用します。

  • Creep

    サーフェス上の一部のジオメトリを変形/アニメーションします。

  • Crowd Source

    エージェントプリミティブの群衆を集めます。

  • Crowd Source

    Crowd Solverと一緒に使用される群衆エージェントを作成します。

  • Curve

    ポリゴン/NURBS/Bezier曲線を作成します。

  • Curveclay

    サーフェス上の曲線を編集することでスプラインサーフェスを変形します。

  • Curvesect

    2つ以上の曲線/フェース間の交線(または最小距離間の点)を検索します。

  • DOP I/O

    DOPシミュレーションからフィールドを取り込み、それをディスクに保存、そして再度読み込み直します。

  • DOP Import Fields

    DOPシミュレーションからスカラーとベクトルフィールドを取り込みます。

  • DOP Import Records

    DOPシミュレーションからオプションとレコードデータをPointアトリビュート付きでポイントに取り込みます。

  • DOP Network

  • Debris Source

    分離して破壊されたリジッドボディオブジェクトのDebris(瓦礫)に対してポイントエミッションソースを生成します。

  • Deformation Wrangle

    ジオメトリを変形させるVEXスニペットを実行します。

  • Delete

    要素番号、境界ボリューム、プリミティブ/ポイント/エッジの法線、Degeneracy(縮退)を基準に入力ジオメトリを削除します。

  • DeltaMush

    ポイント変形を平滑化(または"リラックス化")します。

  • Detangle

    ジオメトリを変形させた時に干渉の回避を試みます。

  • Dissolve

    入力ポリゴンジオメトリからエッジを削除して、共有エッジを持ったポリゴンを結合します。

  • Dissolve

    入力ジオメトリからポイント/プリミティブ/エッジを削除し、それによってできた穴を修復します。

  • Divide

    ポリゴンを分割、スムーズ、三角化します。

  • Dop Import

    DOPシミュレーションから抽出した情報に基づいたジオメトリを取り込み、トランスフォームします。

  • Draw Curve

    ビューポートでユーザー入力からカーブを作成します。

  • Draw Guides

  • Each

    For Each SOPの仕様に応じて入力ジオメトリを抜粋します。

  • Edge Collapse

    エッジとフェースを中点に折り畳みます。

  • Edge Cusp

    エッジの点を固有化し、ポイント法線を再計算することで、エッジをシャープにします。

  • Edge Divide

    ポリゴンのエッジ上にポイントを挿入し、任意で接続します。

  • Edge Flip

    ポリゴンのエッジの方向を反転します。

  • Edge Fracture

    ガイドカーブを使ってエッジ沿いにジオメトリをカットします。

  • Edge Transport

    エッジネットワークやカーブに沿ってアトリビュート値をコピーしたりオプションで修正します。

  • Edit

    ポイント/エッジ/フェースをインタラクティブに編集します。

  • Ends

    端点を開閉したり、塞ぎます。

  • Enumerate

    選択したポイント/プリミティブのアトリビュートの値を連番に設定します。

  • Error

    親アセット上で表示させることができるメッセージ、警告、エラーを生成します。

  • Exploded View

    中心から外側に向かってジオメトリを押し出して、展開ビューを作成します。

  • Exploded View

    中心からジオメトリを押し出して展開ビューを作成します。

  • Extract Centroid

    ジオメトリの各ピースの重心を計算します。

  • Extract Transform

    2つのジオメトリ間で最適なトランスフォームを計算します。

  • Extrude

    ジオメトリを法線に沿って押し出します。

  • Extrude Volume

    サーフェスジオメトリを押し出してボリュームを作成します。

  • FEM Visualization

  • FLIP Source

    FLIPシミュレーションのソースとなるサーフェスまたはdensity VDBを作成します。

  • Facet

    サーフェスのファセットの滑らかさを制御します。

  • Falloff

    滑らかな距離アトリビュートをジオメトリに追加します。

  • Filament Advect

    ポリゴンカーブを渦巻くフィラメントにします。

  • File

    ファイルの読み込み、書き込み、ジオメトリのディスクへキャッシュ化します。

  • File Cache

    ジオメトリシーケンスをディスクに書き出したり、ディスクから読み込みます。

  • File Merge

    ディスクからデータを読み込み、まとめます。

  • Fillet

    2本の曲線/サーフェス間を繋いだ滑らかなジオメトリを作成します。

  • Filmbox FBX ROP出力ドライバ

  • Find Shortest Path

    開始点から終了点までのサーフェスのエッジに沿った最短パスを検索します。

  • Fit

    スプライン曲線をポイントに、スプラインサーフェスをポイントのメッシュにフィットします。

  • Fluid Compress

    流体シミュレーションの出力を圧縮してディスクサイズを軽減します。

  • Font

    Type1、TrueType、OpenTypeのフォントから3Dテキストを作成します。

  • Force

    メタボールを使ってポイントやスプリングを引き寄せたり引き離します。

  • Fractal

    入力ジオメトリからボコボコの山のような分割を行ないます。

  • Fur

    サーフェス上に髪のような曲線を作成します。

  • Fuse

    ポイントを結合します。

  • Fuse

    ポイントを結合/分離(個別化)します。

  • Glue Cluster

    クラスタの値に応じてGlue Constraint Networkに強度を加えます。

  • Grain Source

    パーティクルベースのGrain(粒)シミュレーションのソースとして使用するパーティクルを生成します。

  • Graph Color

    隣接コンポーネントと被らないように各コンポーネントに固有の整数アトリビュートを割り当てます。

  • Grid

    平面を作成します。

  • Groom Blend

    2つのグルームのガイドとスキンをブレンドします。

  • Groom Fetch

    グルーミングオブジェクトからグルームデータを取得します。

  • Groom Pack

    グルームのコンポーネントをディスクに書き出すために、それらを名前付きパックプリミティブのセットにパックします。

  • Groom Switch

    2本のグルームストリームのすべてのコンポーネント間を切り替えます。

  • Groom Unpack

    パックしたグルームからグルームのコンポーネントをアンパックします。

  • Group

    色々な条件に応じてポイント/プリミティブ/エッジ/頂点のグループを作成します。

  • Group Combine

    ブーリアン演算に応じて、ポイント/プリミティブ/エッジのグループを組み合わせます。

  • Group Copy

    ポイント/プリミティブ番号に基づいて2つのジオメトリの断片間にグループをコピーします。

  • Group Delete

    パターンに応じて、ポイント/プリミティブ/エッジ/頂点のグループを削除します。

  • Group Expression

    VEXエクスプレッションを実行して、グループメンバーシップを修正します。

  • Group Paint

    ペイントでインタラクティブにグループを設定します。

  • Group Promote

    ポイント/プリミティブ/エッジ/頂点のグループをポイント/プリミティブ/エッジ/頂点のグループに変換します。

  • Group Range

    範囲指定でポイント/プリミティブをグループ化します。

  • Group Rename

    パターンに応じてグループの名前を変更します。

  • Group Transfer

    近接する2つのジオメトリの断片間にグループを転送します。

  • Guide Advect

    Velocityボリュームによってガイドポイントを移流させます。

  • Guide Collide With VDB

    ガイドカーブの衝突をVDB符号付き距離フィールドを使って計算します。

  • Guide Deform

    アニメーションスキンとオプションのガイドカーブを使ってジオメトリを変形させます。

  • Guide Groom

    ビューポート内でガイドカーブの直感的操作を可能にします。

  • Guide Group

    グルーミングツールで使用する標準のプリミティブグループを作成します。

  • Guide Initialize

    ヘアーガイドの初期方向を簡単に設定します。

  • Guide Mask

    他のグルーミング操作をするためのマスクアトリビュートを作成します。

  • Guide Partition

    Hair Generateで使用できる分け目を作成します。

  • Guide Skin Attribute Lookup

    ガイドカーブの根元ポイント下のスキンジオメトリアトリビュートを照会します。

  • Guide Tangent Space

    カーブ沿いに一貫した接線空間を構築します。

  • Guide Transfer

    ジオメトリ間でヘアーガイドを転送します。

  • Hair Card Generate

    密集したヘアーカーブを、そのグルームのスタイルと形状を維持しつつポリゴンカードに変換します。

  • Hair Clump

    ガイドカーブをClump(凝集)します。

  • Hair Generate

    サーフェス上またはポイントからヘアーを生成します。

  • Hair Growth Field

    ストロークプリミティブに基づいてVelocityフィールドを生成します。

  • HeightField

    Terrainツールと併用するための初期Height Fieldボリュームを生成します。

  • HeightField Blur

    TerrainのHeight Fieldまたはマスクをブラーします。

  • HeightField Clip

    Height値を特定の最小/最大値に制限します。

  • HeightField Copy Layer

    Height Fieldまたはマスクのコピーを作成します。

  • HeightField Crop

    大きなHeightボリュームから特定の幅/長さの正方形を抽出したり、Heightフィールドの境界のサイズ変更/移動をします。

  • HeightField Cutout by Object

    ジオメトリに基づいて地形上にカットアウト(切り抜き)を作成します。

  • HeightField Distort by Layer

    他のフィールドによってHeight Fieldを変位させます。

  • HeightField Distort by Noise

    ノイズパターンで入力ボリュームを移流させることで、ハードエッジを崩してバリエーションを加えます。

  • HeightField Draw Mask

    シェイプを描画して、Height Fieldツールのマスクを作成することができます。

  • HeightField Erode

    より現実的な地形を作成するために、時間軸(フレーム)にわたって融解侵食と流体侵食を計算します。

  • HeightField Erode

    より現実的な地形を作成するために、時間軸(フレーム)にわたって融解侵食と流体侵食を計算します。

  • HeightField Erode Hydro

    あるHeight Fieldから別のHeight Field上を滑る侵食を短時間でシミュレーションします。

  • HeightField Erode Precipitation

    Height Fieldに沿って水を分流させます。強度、変動性、降雨の位置を調整するためのコントロールが備わっています。

  • HeightField Erode Thermal

    短時間で地形の熱侵食の効果を計算します。

  • HeightField File

    ファイルまたはコンポジットノードから2D画像をHeight FieldまたはMaskにインポートします。

  • HeightField Flow Field

    入力のHeightレイヤーに応じて、流れレイヤーと流れ方向のレイヤーを生成します。

  • HeightField Isolate Layer

    マスクレイヤー上に他のレイヤーをコピーし、オプションでHeight Fieldを平坦化します。

  • HeightField Layer

    2つのHeight Fieldを合成します。

  • HeightField Layer Clear

    Height Fieldレイヤーのすべての値を固定値に設定します。

  • HeightField Layer Property

    Height Fieldボリュームに境界ボクセルポリシーを設定します。

  • HeightField Mask by Feature

    Heightレイヤーの異なる特徴部分に基づいてマスクを作成します。

  • HeightField Mask by Object

    他のジオメトリに基づいてマスクを作成します。

  • HeightField Mask by Occlusion

    入力地形の空洞/陥没の部分、例えば河床や谷の部分にマスクを生成します。

  • HeightField Noise

    Height Fieldに垂直ノイズを追加して、山と谷を作成します。

  • HeightField Output

    Height/マスクのレイヤーを画像としてディスクにエクスポートします。

  • HeightField Paint

    ストロークを使って、Heightまたはマスクのフィールドに値をペイントすることができます。

  • HeightField Patch

    あるHeightFieldの外観を他のHeightFieldに継ぎ当てます。

  • HeightField Pattern

    ランプ、段状、縞模様、Voronoiセル、他のパターンの形式でディスプレイスメントを追加します。

  • HeightField Project

    3DジオメトリをHeight Fieldに投影します。

  • HeightField Quick Shade

    テクスチャに接続できるマテリアルを別々のレイヤーに対して適用します。

  • HeightField Remap

    Height Fieldまたはマスクレイヤーの値を再マップします。

  • HeightField Resample

    Height Fieldの解像度を変更します。

  • HeightField Scatter

    Height Fieldの表面上にポイントをばら撒きます。

  • HeightField Scatter

    Height Fieldの表面上にポイントをばら撒きます。

  • HeightField Slump

    斜面を滑り落ちて麓に堆積する緩いマテリアルをシミュレーションします。

  • HeightField Terrace

    地形の勾配から段丘を作成します。

  • HeightField Tile Splice

    Height Fieldのタイルを接合します。

  • HeightField Tile Split

    Height Fieldのボリュームを縦横に分割します。

  • HeightField Transform

    Height Field固有のスケールとオフセット。

  • HeightField Visualize

    カスタムランプマテリアルを使って標高を可視化し、色を付けてマスクレイヤーを可視化します。

  • Hole

    サーフェスに穴を開けます。

  • Inflate

    1番目の入力のポイントが膨らむように変形します。

  • Instance

    ジオメトリをポイント上にインスタンス化します。

  • Intersection Analysis

    三角形/カーブメッシュ間、またはオプションの三角形/カーブ間の入力の交差した箇所にアトリビュート付きのポイントを作成します。

  • Intersection Stitch

    三角形サーフェスとカーブを1枚に繋がったメッシュに接合します。

  • Invoke Compiled Block

    参照したコンパイルブロックのオペレーションを使って、入力を処理します。

  • IsoOffset

    ジオメトリからオフセットサーフェスを作成します。

  • IsoSurface

    陰関数からアイソサーフェスを作成します。

  • Join

    一連のフェース/サーフェスを、アトリビュートを引き継いだ単一のプリミティブに繋げます。

  • Knife

    インタラクティブに描いた線でジオメトリを分割/削除/グループ化をします。

  • L-System

    ルールに基づいて再帰的に相似したジオメトリを作成します。

  • Lattice

    コントロールジオメトリを変形させることで、それに応じてジオメトリを変形します。

  • Lidar Import

    Lidarファイルを読み込み、そのデータからポイントクラウドをインポートします。

  • Line

    位置/方向/距離でポリゴン/NURBSラインを作成します。

  • MDD

    MDDファイルを使ってポイントをアニメーションさせます。

  • Magnet

    ジオメトリの他の断片を使ってジオメトリを引き寄せたり引き離して変形します。

  • Match Axis

    入力ジオメトリを指定した軸で整列します。

  • Match Size

    参照ジオメトリに応じてジオメトリのサイズを変更し、中央に配置します。

  • Match Topology

    入力ジオメトリのプリミティブ/ポイントの番号を参照ジオメトリと一致するように並べ替えます。

  • Material

    1つ以上のマテリアルをジオメトリに割り当てます。

  • Measure

    個々のエレメントまたは複数枚のジオメトリから面積、体積、曲率を測定し、その結果をアトリビュートに格納します。

  • Measure

    ポリゴンの体積、面積、周囲の長さを測定し、結果をアトリビュートに保存します。

  • Merge

    入力からジオメトリを結合します。

  • MetaGroups

    メタボールのグループを定義することで、それらが結合されても、別々のグループが別々のサーフェスとして処理されます。

  • Metaball

    メタボールとメタサーフェスを作成します。

  • Mirror

    ミラー平面を基準にジオメトリをコピーし対称化します。

  • Mountain

    フラクタルノイズに基づいて、ポイント法線に沿ってポイントを変位させます。

  • Mountain

    フラクタルノイズに基づいて法線方向にポイントを変位します。

  • Muscle Capture

    指定したプリミティブからの距離に基づいてキャプチャーウェイトをポイントに割り当てることによるMuscle Deformをサポートします。

  • Muscle Deform

    スキンを表現したサーフェスメッシュを変形させて、筋肉を表現したジオメトリを引き締めたり弛ませたりします。

  • Name

    ポイント/プリミティブにnameアトリビュートを作成することで、グループと同様に簡単にそれらのコンポーネントを参照することができます。

  • Normal

    サーフェス法線アトリビュートを計算します。

  • Null

    シーンで位置決めに利用するNullオブジェクトを作成します。レンダリングはされません。

  • Object Merge

    複数のソースのジオメトリを結合して、それらのソースのグループ化とトランスフォームの方法を定義することができます。

  • Object_musclerig@musclerigstrokebuilder

  • Object_riggedmuscle@musclestrokebuilder

    投影サーフェス上にストロークを描画できるようにすることで、MuscleまたはMuscle Rigの作成を補助します。

  • Ocean Evaluate

    Ocean Spectrumボリュームに基づいて入力ジオメトリを変形します。

  • Ocean Evaluate

    Ocean Spectrumボリュームに基づいて入力ジオメトリを変形します。

  • Ocean Foam

    パーティクルベースのFoam(泡沫)を生成します。

  • Ocean Source

    シミュレーションで使用するための海の"スペクトル"ボリュームからパーティクルとボリュームを生成します。

  • Ocean Source

    シミュレーションで使用するための海の"スペクトル"ボリュームからパーティクルとボリュームを生成します。

  • Ocean Spectrum

    海の波をシミュレーションするための情報を含んだボリュームを生成します。

  • Ocean Waves

    それぞれの波形を入力ポイントとそこから生成されたポイント上にインスタンス化します。

  • OpenCL

    ジオメトリに対してOpenCLカーネルを実行します。

  • Output

    サブネットワークの出力としてマークします。

  • Pack

    ジオメトリを組み込みプリミティブにパックします。

  • Pack Points

    ポイントをパックプリミティブのタイル化されたグリッドにパックします。

  • Packed Disk Edit

    パックディスクプリミティブの編集

  • Packed Edit

    パックプリミティブを編集します。

  • Paint

    ジオメトリにカラーや他のアトリビュートをペイントすることができます。

  • Paint Color Volume

    描画したカーブに基づいてカラーボリュームを作成します。

  • Paint Fog Volume

    描画したカーブに基づいてFogボリュームを作成します。

  • Paint SDF Volume

    描画したカーブに基づいてSDFボリュームを作成します。

  • Particle Fluid Surface

    パーティクル流体シミュレーションのパーティクルまわりにサーフェスを生成します。

  • Particle Fluid Tank

    タンクを満たしたひとまとまりの通常のポイントを作成します。

  • Partition

    ポイントとプリミティブをユーザーのルールに基づいてグループに格納します。

  • Peak

    プリミティブ/ポイント/エッジ/ブレークポイントを法線方向に動かします。

  • Planar Patch

    平面ポリゴンパッチを作成します。

  • Planar Patch from Curves

    2Dカーブ網を三角形で埋めます。

  • Planar Pleat

    平坦なジオメトリをひだ状に変形させます。

  • Platonic Solids

    凸状で頂点とフェースすべてがまったく同じ形式の多面体である5つのプラトン立体と、サッカーボール、ティーポットのどれかを作成します。

  • Point

    手動でPointアトリビュートを追加・編集します。

  • Point Cloud Iso

    入力ポイントからアイソサーフェスを構築します。

  • Point Deform

    ポイントクラウドに基づいてジオメトリを変形します。

  • Point Generate

    任意で入力ジオメトリのポイントポジションに基づいて新しくポイントを作成します。

  • Point Jitter

    ポイントをランダムな方向に動かします。

  • Point Relax

    お互いに指定した半径領域と重ならないようにポイントを動かします。

  • Point Replicate

    入力ポイントまわりにポイントクラウドを生成します。

  • Point Velocity

    ジオメトリのポイントに対してVelocityを計算して制御します。

  • Points from Volume

    ボリュームを満たすひとまとまりの通常のポイントを作成します。

  • Poly Bridge

    ブリッジの形状に対するコントロールを使って、SourceエッジループとDestinationエッジループの間に平坦またはチューブ状のポリゴンサーフェスを作成します。

  • Poly Expand 2D

    平面ポリゴンのグラフに対して、オフセットしたポリゴンジオメトリを作成します。

  • Poly Extrude

    ポリゴンのフェースやエッジを押し出します。

  • PolyBevel

    エッジやコーナーに沿って真っ直ぐ、丸い、または独自の面取りを作成します。

  • PolyBevel

    ポイントやエッジに面取りを作成します。

  • PolyCut

    アトリビュートが閾値を超えている箇所でカーブを分割します。

  • PolyDoctor

    例えばClothシミュレーションで無効なポリゴンジオメトリを修正します。

  • PolyExtrude

    ポリゴンのフェースとエッジを押し出します。

  • PolyFill

    ポリゴンパッチで穴を埋めます。

  • PolyFrame

    ポイントや頂点に対して座標フレームアトリビュートを作成します。

  • PolyLoft

    既存ポイントを使ってポリゴンを新しく作成します。

  • PolyPatch

    プリミティブから滑らかなポリゴンパッチを作成します。

  • PolyPath

    ポリゴンカーブのトポロジーをクリーンアップします。

  • PolyReduce

    形を保持しようとしつつポリゴンの数を減らします。このノードは、ポリゴン削減時に、形状、アトリビュート、テクスチャ、四角形トポロジを維持します。

  • PolySoup

    たくさんのポリゴンをもっと効率化させるためにポリゴンを単一プリミティブに結合します。

  • PolySpline

    スプライン曲線をポリゴン/ハルにフィットさせて、スプラインをポリゴン近似にして出力します。

  • PolySplit

    既存ポリゴンを複数の新しいポリゴンに分割します。

  • PolySplit

    既存ポリゴンを新しい複数ポリゴンに分割します。

  • PolyStitch

    隙間を埋めながらポリゴンサーフェスを縫い合わせます。

  • PolyWire

    ポリラインから滑らかに曲がって交差したレンダリング可能なポリゴンチューブを作成します。

  • Pose Scope

    チャンネルパスやピックスクリプトをジオメトリに割り当てます。

  • Pose-Space Deform

    駆動側の値に基づいてポーズ形状間を補間します。

  • Pose-Space Deform Combine

    Pose-Space Deformの結果と静止ジオメトリを合成します。

  • Pose-Space Edit

    ポーズ空間変形用のパックジオメトリ編集。

  • Pose-Space Edit Configure

    Pose-Space Edit SOPで使用する共通アトリビュートを作成します。

  • Primitive

    プリミティブ/Primitiveアトリビュート/プロファイル曲線を編集します。

  • Primitive Split

    Primitiveアトリビュートを受け取り、そのアトリビュートに指定されたトレランスよりも大きいプリミティブのポイントを分割します。

  • Profile

    プロファイル曲線を抽出、操作します。

  • Project

    サーフェス上にプロファイル曲線を作成します。

  • Pyro Source

    PyroやSmokeのシミュレーションのソースとなるポイントを作成します。

  • Python

    Python Snippetを実行して、入力のジオメトリを修正します。

  • RBD Cluster

    粉砕ピースまたは拘束を大きなクラスタにまとめます。

  • RBD Constraint Properties

    リジッドボディ拘束を意味したアトリビュートを作成します。

  • RBD Constraints From Curves

    ビューポート内で描画したカーブからリジッドボディ拘束ジオメトリを作成します。

  • RBD Constraints From Lines

    ビューポート内でインタラクティブに描画したラインからリジッドボディ拘束ジオメトリを作成します。

  • RBD Constraints From Rules

    ルールと条件のセットからリジッドボディ拘束ジオメトリを作成します。

  • RBD Interior Detail

    粉砕ジオメトリの内側サーフェス上にディテールを追加します。

  • RBD Material Fracture

    材質タイプに基づいて入力ジオメトリを粉砕します。

  • RBD Material Fracture

    材質タイプに基づいて入力ジオメトリを粉砕します。

  • RBD Pack

    RBDジオメトリ、拘束、プロキシジオメトリを単一ジオメトリにパックします。

  • RBD Paint

    ストロークを使ってジオメトリまたは拘束に対して値をペイントします。

  • RBD Unpack

    RBDセットアップを3つの出力にアンパックします。

  • RMan Shader

    RenderManシェーダをフェースグループに割り当てます。

  • ROP Geometry Output

    SOP/DOP Networkからジオメトリファイルを生成します。

  • Rails

    2つのガイドレール間で断面を伸縮させてサーフェスを作成します。

  • Ray

    サーフェスをもう片方のサーフェスに投影します。

  • Refine

    形を変えないで曲線/サーフェスのポイント/CVの数を増やします。

  • Reguide

    新しくガイドをばら撒いて、既存ガイドのプロパティを補間します。

  • Remesh

    入力サーフェスの形状を"高品質な"(ほぼ等辺の)三角形を使って再作成します。

  • Repack

    ジオメトリを埋め込まれたプリミティブとして再パックします。

  • Resample

    1つ以上の曲線/サーフェスを均一長さのセグメントでサンプリングし直します。

  • Rest Position

    ソリッドテクスチャの並びをジオメトリに設定することで、サーフェスが変形してもテクスチャの並びはそのサーフェス上に乗ります。

  • Retime

    時間依存の入力ジオメトリの時間を変更します。

  • Reverse

    フェースの頂点順を逆順または周回させます。

  • Revolve

    中心軸で曲線を回転させてサーフェスを作成します。

  • Rewire Vertices

    頂点をアトリビュートで指定した別々のポイントに再接続します。

  • Ripple

    指定した方向に沿ってポイントを動かすことで波形を生成します。

  • Scatter

    サーフェス上に/ボリューム内に新しいポイントをランダムにばら撒きます。

  • Script

    クックされる時にスクリプトを実行します。

  • Sculpt

    ブラシでインタラクティブにサーフェスの形状を変えます。

  • Sequence Blend

    3D形状のシーケンスからジオメトリとアトリビュートを補間しながらモーフィングを行ないます。

  • Sequence Blend

    形状間で3次元モーフィングをして、ポイントポジション、カラーなどを補間します。

  • Shape Diff

    同じトポロジーを持つ2つのジオメトリ間の変形後または変形前の差分を計算します。

  • Shrinkwrap

    入力ジオメトリの凸状のハルを計算し、そのポリゴンを法線方向に沿って内側に動かします。

  • Shrinkwrap

    入力ジオメトリの凸状のハルを受け取り、そのポリゴンを法線方向に沿って内側に動かします。

  • Skin

    複数の曲線間にスキンサーフェスを作成します。

  • Sky

    ボリュームクラウドで満たされた空を作成します。

  • Smooth

    ポリゴン、メッシュ、曲線をポイントの数を増やさないで滑らか(または"リラックス")にします。

  • Smooth

    ポリゴン、メッシュ、曲線をポイントの数を増やさないで滑らかにします。

  • Soft Peak

    選択したポイントとそこからスムースロールオフの範囲のポイントを法線方向に動かします。

  • Soft Transform

    選択したポイントとそこからスムースロールオフの範囲のポイントを動かします。

  • Solid Conform

    可能な限り繋がったメッシュに適合するように四面体メッシュを作成します。

  • Solid Embed

    繋がったメッシュを覆う四面体メッシュを作成します。

  • Solid Fracture

    有限要素による破壊に使用することができる四面体メッシュのパーティションを作成します。

  • Solver

    入力ジオメトリに対して前のフレームの ネットワークの出力を現行フレームのネットワークの入力にしながら、SOPネットワークを繰り返し処理します。

  • Sort

    色々な方法(ランダムを含む)でポイント/プリミティブを並べ替えます。

  • Sphere

    球または卵型サーフェスを作成します。

  • Split

    プリミティブやポイントを2つのストリームに分岐させます。

  • Spray Paint

    サーフェス上にランダムにポイントを吹き付けます。

  • Sprite

    ポイントに対するスプライト表示を設定するSOPノード。

  • Starburst

    ポリゴンフェース上にポイントをインセット(内側に挿入)します。

  • Stash

    このノード内の入力ジオメトリをコマンドでキャッシュ化し、それをノードの出力として使用します。

  • Stitch

    2つのカーブ/サーフェスを縫い合わせて滑らかにします。

  • Stroke

    インタラクティブなアセットを構築するための低レベルツール。

  • Subdivide

    ポリゴンをより滑らかに、より高解像度のポリゴンに細分化します。

  • Subnetwork

    複数のノードをまとめた単一ノードを作成します。

  • Super Quad

    アイソ2次関数サーフェスを作成します。

  • Surfsect

    NURBS/Bezierサーフェス間の交差に対して曲線を作成します。

  • Sweep

    背骨曲線に断面を沿わせてサーフェスを作成します。

  • Switch

    エクスプレッションやキーフレームアニメーションに基づいてネットワークの分岐を切り替えます。

  • TOP SOP

    入力ジオメトリをTOPサブネットに送信して、そこから出力されたジオメトリを取得します。

  • Table Import

    CSVファイルを読み込み、一行毎にポイントを作成します。

  • Test Geometry: Crag

    テストジオメトリとして利用可能な岩のキャラクタを作成します。

  • Test Geometry: Pig Head

    テストジオメトリとして使用可能な豚の頭を作成します。

  • Test Geometry: Rubber Toy

    テストジオメトリとして使用可能なゴムのおもちゃを作成します。

  • Test Geometry: Shader Ball

    テストシェーダに使用することができるシェーダボールを作成します。

  • Test Geometry: Squab

    テストジオメトリとして使用可能なイカ蟹を作成します。

  • Test Geometry: Tommy

    テストジオメトリとして使用可能な兵士を作成します。

  • Test Simulation: Crowd Transition

    アニメーションクリップ間のトランジションをテストするための簡単な群衆シミュレーションを備えています。

  • Test Simulation: Ragdoll

    ラグドールの挙動をテストするためのシンプルなBulletシミュレーションを備えています。

  • Tet Partition

    指定した四面体メッシュを、指定したポリゴンメッシュで分離された四面体のグループに区分けします。

  • Tetrahedralize

    ポイントをドロネー四面体で繋げます。

  • TimeShift

    入力を異なる時間に処理します。

  • Toon Shader Attributes

    Toon Color ShaderおよびToon Outline Shaderで使用されるアトリビュートを設定します。

  • TopoBuild

    既存のジオメトリに自動的にスナップさせて少ない数の四角形メッシュをインタラクティブに描くことができます。

  • Torus

    トーラス(ドーナツ)状のサーフェスを作成します。

  • Trace

    画像ファイルから曲線をトレースします。

  • Trail

    ポイントから軌跡を作成します。

  • Transform

    変換行列を使って"オブジェクト空間"でソースジオメトリをトランスフォームします。

  • Transform Axis

    指定した軸に合わせて入力ジオメトリをトランスフォームします。

  • Transform By Attribute

    入力ジオメトリをPointアトリビュートによってトランスフォームします。

  • Transform Pieces

    テンプレートジオメトリ上のトランスフォーメーションアトリビュートに応じて入力ジオメトリをトランスフォームします。

  • Tri Bezier

    三角Bezierサーフェスを作成します。

  • TriDivide

    色々な方法で三角形メッシュを精密化します。

  • Triangulate 2D

    ポイントが良い三角形になるように繋げます。

  • Trim

    プロファイル曲線でスプラインサーフェスをトリムしたり、以前の状態にトリム解除します。

  • Tube

    開/閉チューブ、円錐、ピラミッドを作成します。

  • UV Autoseam

    UV空間でポリゴンモデルを平坦化するのに提案されるシーム(継ぎ目)を表現したエッジグループを生成します。

  • UV Brush

    ペイントでUVビューポートのテクスチャ座標を調整します。

  • UV Edit

    テクスチャビューでインタラクティブにUVを編集します。

  • UV Flatten

    3Dジオメトリのテクスチャ空間に平坦化されたピースを作成します。

  • UV Flatten

    3Dジオメトリのテクスチャ空間に平坦化されたピースを作成します。

  • UV Fuse

    UVを結合します。

  • UV Layout

    UV島を効率的に制限領域内に詰め込みます。

  • UV Pelt

    テクスチャ領域の端側に引っ張ることでUVを緩めます。

  • UV Project

    UVをある方向でサーフェス上に投影します。

  • UV Quick Shade

    テクスチャシェーダとして画像ファイルをサーフェスに割り当てます。

  • UV Texture

    テクスチャとバンプマッピング用にUV座標をジオメトリに割り当てます。

  • UV Transform

    ソースジオメトリのUVテクスチャ座標を変形します。

  • UV Transform

    ソースジオメトリのUVテクスチャ座標を変形します。

  • UV Unwrap

    UVを合理的に平坦化、重複なしのグループに分離します。

  • Unix

    外部プログラムを使ってジオメトリを処理します。

  • Unpack

    パックプリミティブを展開します。

  • Unpack Points

    パックプリミティブからポイントをアンパックします。

  • VDB

    1つ以上の空っぽ/均一なVDBボリュームプリミティブを作成します。

  • VDB Activate

    より高度な処理をするためにVDBのボクセル領域を活動化します。

  • VDB Activate SDF

    VDBボリュームプリミティブに記録された符号付き距離フィールドを拡張/収縮します。

  • VDB Advect

    入力ジオメトリ内のVDBをVDB Velocityフィールドに沿って動かします。

  • VDB Advect Points

    入力ジオメトリ内のポイントをVDB Velocityフィールドに沿って動かします。

  • VDB Analysis

    勾配や曲率などのVDBボリュームの解析プロパティを計算します。

  • VDB Clip

    境界ボックスや他のVDBをマスクにしてVDBボリュームプリミティブを切り取ります。

  • VDB Combine

    色々な方法で2つの整列したVDBボリュームの値を結合します。

  • VDB Diagnostics

    VDBの不良値をテストして修復します。

  • VDB Fracture

    レベルセットVDBボリュームプリミティブを複数の破片に分割します。

  • VDB LOD

    VDBからLOD Pyramidを構築します。

  • VDB Morph SDF

    ソースとターゲットのSDF VDB間をブレンドします。

  • VDB Occlusion Mask

    VDBプリミティブに対してカメラから見て影となる部分にボクセルのマスクを作成します。

  • VDB Points Delete

    VDB Pointsプリミティブ内部のポイントを削除します。

  • VDB Points Group

    VDB Points Primitiveから内部グループを作成します。

  • VDB Potential Flow

    VDB障害物周辺の定常状態の気流を計算します。

  • VDB Project Non-Divergent

    Vector VDBからDivergence(発散)を除去します。

  • VDB Renormalize SDF

    VDBボリュームプリミティブに保存されているSDF(符号付き距離フィールド)を修復します。

  • VDB Resample

    VDBボリュームプリミティブを再サンプリングして新しい方向とボクセルサイズのVDBボリュームプリミティブにします。

  • VDB Reshape SDF

    VDBボリュームプリミティブ内のSDF(符号付き距離フィールド)の形状を変更します。

  • VDB Segment by Connectivity

    SDF VDBを繋がったコンポーネントに分割します。

  • VDB Smooth

    VDBボリュームプリミティブの値を平滑化します。

  • VDB Smooth SDF

    VDBボリュームプリミティブ内のSDF値を平滑化します。

  • VDB Topology to SDF

    他のVDBのアクティブセットに基づいてSDF VDBを作成します。

  • VDB Vector Merge

    3つのスカラーVDBを1つのベクトルVDBに結合します。

  • VDB Vector Split

    ベクトルVDBプリミティブを3つのスカラーVDBプリミティブに分けます。

  • VDB Visualize Tree

    VDBボリュームをその構造を可視化するジオメトリに置換します。

  • VDB from Particle Fluid

    符号付き距離フィールド(SDF)VDBボリュームを生成して、パーティクル流体シミュレーションのパーティクルセットのサーフェスを表現します。

  • VDB from Particles

    ポイントクラウド/PointアトリビュートをVDBボリュームプリミティブに変換します。

  • VDB from Polygons

    ポリゴンサーフェス/サーフェスアトリビュートをVDBボリュームプリミティブに変換します。

  • VDB to Spheres

    VDBボリュームを最適なサイズの球で埋めます。

  • Vellum Configure Grain

    Vellum Grain拘束用ジオメトリを設定します。

  • Vellum Constraints

    Vellum Solver用ジオメトリに対して拘束を設定します。

  • Vellum Drape

    キャラクタに布地がまとわりつくようにVellum Solverをセットアップします。

  • Vellum I/O

    Vellumシミュレーションをパックしてディスクに保存し、それを読み直します。

  • Vellum Pack

    Vellumジオメトリと拘束を単一ジオメトリにパックします。

  • Vellum Post-Process

    一般的なポスト処理効果をVellum Solverの結果に適用します。

  • Vellum Rest Blend

    現在の拘束のrest値と、外部ジオメトリから計算された静止状態をブレンドします。

  • Vellum Solver

    Vellumダイナミクスシミュレーションを実行します。

  • Vellum Unpack

    Vellumシミュレーションを2つの出力にアンパックします。

  • Verify BSDF

    必要なインターフェースに準拠しているかBSDFを検証します。

  • Vertex

    手動で頂点(ポイントではなく)にアトリビュートを追加/編集します。

  • Vertex Split

    Vertexアトリビュートを受け取り、そのアトリビュートのトレランスよりも大きい頂点のポイントを分割します。

  • Visibility

    3DビューアとUVエディタでプリミティブを表示/非表示にします。

  • Visualize

    ジオメトリネットワーク内の色々なノードを可視化することができます。

  • Volume

    ボリュームプリミティブを作成します。

  • Volume Analysis

    ボリュームの解析プロパティを計算します。

  • Volume Arrival Time

    ソースポイントからボクセルまでの速度を定義したトラベルタイムを計算します。

  • Volume Blur

    ボリュームのボクセルをぼかします。

  • Volume Bound

    ボクセルデータの境界を設定します。

  • Volume Break

    SDF(符号付き距離フィールド)ボリュームを使ってポリゴンオブジェクトをカットします。

  • Volume Compress

    ボリュームプリミティブを再圧縮します。

  • Volume Convolve 3×3×3

    ボリュームを3×3×3カーネルで畳み込みます。

  • Volume FFT

    ボリュームの高速フーリエ変換を計算します。

  • Volume Feather

    ボリュームのエッジをぼかします。

  • Volume Merge

    たくさんのボリュームを1つのボリュームに平坦化します。

  • Volume Mix

    ボリュームプリミティブのスカラーフィールドを結合します。

  • Volume Optical Flow

    2つの"画像"ボリューム間のモーションをディスプレイスメントベクトルに変換します。

  • Volume Patch

    あるボリュームの外観を他のボリュームの領域に継ぎ当てます。

  • Volume Ramp

    Rampに応じてボリュームを再マッピングします。

  • Volume Rasterize

    ラスター化してボリュームにします。

  • Volume Rasterize Attributes

    PointアトリビュートをサンプリングしてVDBを生成します。

  • Volume Rasterize Curve

    カーブをボリュームに変換します。

  • Volume Rasterize Hair

    レンダリング向けにファーやヘアーをボリュームに変換します。

  • Volume Rasterize Particles

    ポイントクラウドをボリュームに変換します。

  • Volume Rasterize Points

    ポイントクラウドをボリュームに変換します。

  • Volume Reduce

    ボリューム値を単一値に減らします。

  • Volume Resample

    ボリュームのボクセルを新しい解像度にサンプリングし直します。

  • Volume Resize

    ボクセルを変更せずにボリュームの境界サイズを変更します。

  • Volume SDF

    ボリュームのアイソ等高線からSDF(符号付き距離フィールド)を生成します。

  • Volume Slice

    ボリュームから2D断面を抽出します。

  • Volume Splice

    重複したボリュームプリミティブを接合します。

  • Volume Stamp

    ポイント上にインスタンス化したボリュームを単一のターゲットボリュームにスタンプ(入れ込み)します。

  • Volume Surface

    正三角形メッシュでボリューム階層を最適化してサーフェス化します。

  • Volume Trail

    Velocityボリュームからポイントの軌跡を計算します。

  • Volume VOP

    ボリュームプリミティブに対してCVEXを実行します。

  • Volume Velocity

    Velocityボリュームを計算します。

  • Volume Velocity from Curves

    カーブの接線を使ってVolume Velocityフィールドを生成します。

  • Volume Velocity from Surface

    サーフェスジオメトリ内にVelocityフィールドを生成します。

  • Volume Visualization

    複数ボリュームの可視化に関するアトリビュートを調整します。

  • Volume Wrangle

    VEX Snippetを実行して、ボリュームのボクセル値を修正します。

  • Volume from Attribute

    Pointアトリビュートからボリュームのボクセルを設定します。

  • Voronoi Fracture

    入力セルポイントまわりの空間でボロノイ分割を実行して入力ジオメトリを粉砕します。

  • Voronoi Fracture

    入力セルポイントまわりの空間でボロノイ分割を実行して入力ジオメトリを破壊します。

  • Voronoi Fracture Points

    Voronoi Fracture SOPで使用する入力ポイントを生成します。

  • Voronoi Split

    ポリラインで定義された切断線に応じて、ジオメトリを小さい破片に分割します。

  • Vortex Force Attributes

    Vortex Force DOPに必要なPointアトリビュートを作成します。

  • Whitewater Source

    Whitewaterシミュレーションのソースとして使用するボリュームを生成します。

  • Whitewater Source

    白く泡立った水のシミュレーションのソースとして使用する放出パーティクルとボリュームを生成します。

  • Winding Number

    照会ポイントにおいてサーフェスの一般化回転数を計算します。

  • Wire Blend

    曲線の長さを維持しながら曲線形状間をモーフィングします。

  • Wire Capture

    サーフェスをワイヤーにキャプチャーすることで、ワイヤーを編集するとサーフェスが変形します。

  • Wire Deform

    Wire Captureノードを通った曲線にキャプチャーされたジオメトリを変形します。

  • Wire Transfer

    曲線の形状を他の曲線に転送します。

  • Wireframe

    ポリラインからレンダリング可能なポリゴンチューブを作成します。

  • glTF ROP出力ドライバ