Houdini 17.5 リファレンス

メニュー

メインメニュー内のそれぞれの項目について説明します。

On this page

File

ファイルダイアログリファレンスを参照してください。

New

現行シーンをクリアして新しいシーンを開始します。

Open

ディスクから.hipファイルをロードします。

Open Recent files

File メニューが最近開いた.hipファイルをリストします。このリストから.hipファイルを選択すれば、迅速にそのファイルを再読み込みすることができます。

Save

現行シーンをディスクに保存します。

Save As

現行シーンを新規ファイルに保存します。

Save as Binary

現行シーンを新規バイナリシーンファイルに保存します。 詳細は、テキストファイルを参照してください。

Save as Text

現行シーンを新規プレーンテキストシーンファイルに保存します。 詳細は、テキストファイルを参照してください。

New Project

標準化されたディレクトリ構造をセットアップして、そのプロジェクトディレクトリを$JOB環境変数に設定します。 詳細は、プロジェクト管理を参照してください。

Set Project

$JOB環境変数を他のプロジェクトディレクトリに変更します。 詳細は、プロジェクト管理を参照してください。

Merge

他の.hipファイルからデータを現行シーンにインポートします。

Show Changes

現行シーンと最後に保存したファイルとの違いを表示します。

New Asset

新しい空っぽのデジタルアセットを作成します。

Import

このサブメニューには、異なるファイルタイプをインポートするためのメニュー項目が含まれています。

Geometry

.bgeoファイルなどのジオメトリファイルをインポートします。 HoudiniのIOライブラリでサポートされている形式のファイルを読み込むことができます。 Houdiniは、そのファイルをインポートするFileノードを含んだオブジェクトノードを作成します。

Image

画像をHoudiniコンポジター(COPs)へインポートします。 Houdiniは、そのファイルをインポートするFileノードをデフォルトのコンポジットネットワーク内に作成します。

Collada

Collada交換ファイルをインポートします。 Houdiniは、Colladaファイル内のオブジェクト毎にオブジェクトノードを作成します。 Colladaインポートオプションを参照してください。

Filmbox FBX

FBXファイルをインポートします。 Houdiniは、FBXファイル内のオブジェクト毎にオブジェクトノードを作成します。 Filmboxインポートオプションを参照してください。

Alembic Scene

Alembicシーンファイルをインポートします。 Houdiniは、Alembicノード毎にオブジェクトノードを作成したり、Alembicジオメトリを1個のHoudiniオブジェクトにインポートすることができます。 AlembicAlembicインポートオプションを参照してください。

Soundtrack

現行シーン内でアニメーションと一緒に再生可能な音声ファイルをインポートします。

Houdini Digital Asset

ディスク上の.hdaファイルからデジタルアセットを現行のHoudiniセッションにロードします。

Export

このサブメニューには、Houdiniのデータを異なるファイルタイプにエクスポートするためのメニュー項目が含まれています。

Alembic

シーンデータをAlembicシーンファイルにエクスポートします。 AlembicAlembicエクスポートオプションを参照してください。

Filmbox FBX

シーンデータをFBXファイルにエクスポートします。 Filmboxエクスポートオプションを参照してください。

Run Script

PythonまたはHScriptのファイルを選択すると、それがPythonシェルまたはHScript Textportにその内容を入力するのと同じ方法で実行されます。

Quit Application

Houdiniを終了します。

Edit

Undo

以前のユーザーアクションを戻します。

undo用に確保するメモリ量の設定は、 Edit ▸ Preferences の上部のポップアップメニューから Miscellaneous を選択します。

Redo

"undo"したアクションを繰り返します。

Undo History

ユーザーアクションの履歴("undo stack")を表示したウィンドウが開きます。そのリストからundoするアクションをクリックします。

Cut

現行選択をクリップボードにコピーして削除します。

Copy

現行選択をクリップボードにコピーします。

Paste

クリップボードの現行内容を現行選択に挿入します。

Preferences

このサブメニューは、Houdini Preferencesウィンドウの特定のページにジャンプすることができます。

General User Interface Preferences

PreferencesウィンドウでGeneral UIページを開きます。

Network Editor Preferences

PreferencesウィンドウでNetwork Editorページを開きます。

3D Viewports Preferences

Preferencesウィンドウで3D Viewportsページを開きます。

Shelf Preferences

PreferencesウィンドウでShelfページを開きます。

Animation Preferences

PreferencesウィンドウでAnimationページを開きます。

Rendering Preferences

PreferencesウィンドウでRenderingページを開きます。

Handles Preferences

PreferencesウィンドウでHandlesページを開きます。

Interactive Tools Preferences

PreferencesウィンドウでInteractive Toolsページを開きます。

Objects and Geometry

PreferencesウィンドウでObjects and Geometryページを開きます。

Motion and Audio

PreferencesウィンドウでMotion and Audioページを開きます。

Compositing

PreferencesウィンドウでCompositingページを開きます。

Scripting

PreferencesウィンドウでScriptingページを開きます。

Desktops and Toolbars

PreferencesウィンドウでDesktops and Toolbarsページを開きます。

Save and Load

PreferencesウィンドウでSave and Loadページを開きます。

Hip File

PreferencesウィンドウでHip Fileページを開きます。

Warning Dialogs

PreferencesウィンドウでWarning Dialogsページを開きます。

Notifications

PreferencesウィンドウでNotificationsページを開きます。

Performance Monitor

PreferencesウィンドウでPerformance Monitorページを開きます。

External Tools

PreferencesウィンドウでExternal Toolsページを開きます。

Miscellaneous

PreferencesウィンドウでMiscellaneousページを開きます。

Hotkeys

Hotkey Editorを開きます。 これは、Houdiniの色々なアクションに割り当てられているホットキーを編集することができます。

Color Settings

Color Settingsウィンドウを開きます。 これは、UIカラースキームなどのカラー設定を変更することができます。

Aliases and Variables

Aliases and Variablesウィンドウを開きます。 これは、Houdiniの環境変数をインタラクティブに編集することができます。

Compositing Settings

Compositing Settingウィンドウを開きます。 これは、コンポジットプロジェクトのデフォルトを設定することができます。

Clear Compositing Cache

現在コンポジットキャッシュで使われているメモリを開放すれば、コンポジット処理が高速化されます。

コンポジットキャッシュは、特に複数フレームのコンポジット作業で巨大になります。もし、メモリが足りなければ、このコマンドを使ってメモリを開放してください。

Set Keyframe

選択されているオブジェクトに対して現行フレームでキーフレームを追加または保存します。

Objects

このサブメニューのチェックボックス項目は、特定のオブジェクトアニメーション設定を簡単に変更することができます。

Always Highlight Object Selection in Viewer

選択したオブジェクトがビューポート内でハイライトします(黄色で描画)。オブジェクトをペイントするときや、テクスチャを見るときに目障りであれば、このオプションをオフにします。

Bone Kinematic Override

None

ボーンのキネマのデフォルトを上書きしません。

IK Rest Pose

ボーンがポーズをした時のボーンの位置を見ます(つまり、最後に編集したボーンの状態)。

Capture Pose

キャプチャーフレームにおけるボーンの位置を見ます。

Keep Position when Parenting

Never

ワールド空間の位置を保持しません。オブジェクトは新しい親を基準に配置されます。

Always

オブジェクトが親子化されても、オブジェクトは現在のワールド空間の位置と方向を維持します。

Use Object Flag

オブジェクトのKeep Position When Parentingパラメータの値を使います。

通常は、手足を親子化する前に"Keep Position when Parenting"を"Always"に設定します。

オブジェクトをワールド空間の位置に保持させるには、Houdiniは子のオブジェクトの変形順、移動、回転、スケールを変更する必要があります。 もし、それらの値にアニメーションが設定されていた場合は、その設定では望ましくないので、"Keep Position When Parenting"は何もしないほうがよいです。

Stereo Eye

この項目は、ステレオリグでどのサブカメラを使うのか決めます。詳細はステレオカメラリグを参照してください。

Stereo

ステレオカメラリグ視点の時にステレオカメラを使用します。

Left

ステレオカメラリグ視点の時に左目カメラを使用します。

Right

ステレオカメラリグ視点の時に右目カメラを使用します。

Center

ステレオカメラリグ視点の時に中央カメラを使用します。

Live Parameter Display during Playback

ライブパラメータ更新を有効または無効にします。 これが有効な時、Houdiniは、アニメーションを再生している時に現行値でパラメータエディタ内のパラメータを更新します。 重いシーンでは、再生を高速化するためにこれを無効にした方が良いでしょう。

Intercept Mode

"Intercept Mode"を有効または無効にします。Intercept Modeが有効になっていると、すべてのKeyPressがKeyboard CHOPに転送されます。 これによって、KeyPressでチャンネルデータを生成することができます。

Automatically Add Parameter to Current Take

"Auto Take"モードを有効または無効にします。 Auto Takeモードが有効になっていると、テイク内のすべてのパラメータのロックが解除されて、パラメータへの変更が自動的に現行テイクに追加されます。 テイクを参照してください。

Auto Save

"Auto Save"モードを有効または無効にします。 Auto Saveモードが有効になっていると、Houdiniは一定間隔(デフォルトは1分ですが、Save and Load Optionsでその間隔を変更することができます)でシーンをディスクファイルに自動的に保存します。

Houdiniを起動する度にAuto Saveモードは無効になります。Auto Saveモードにしたい場合は、セッションの度に明示的にAuto Saveモードを有効にする必要があります。

Render

Create Render Node

このサブメニュー内の項目は、レンダーネットワークにジャンプすることなく、レンダーノードを簡単に作成/編集することができます。

Mantra

Raytracingエンジンを使用するように設定されたMantraレンダーノードを作成します。

Mantra - PBR

Physically Based Renderingエンジンを使用するように設定されたMantraレンダーノードを作成します。

RenderMan

RenderManレンダーノードを作成します。

RenderMan - RIS

RISを使用するように設定されたRenderManレンダーノードを作成します。

Alfred

Alfredレンダーノードを作成します。

Other Output Nodes サブメニュー内の項目を使って、他のレンダーノードを作成することができます。

Composite

コンポジットネットワークから画像を生成するCompositeレンダーノードを作成します。

Geometry

シーンからジオメトリを生成するGeometryレンダーノードを作成します。

Channel

CHOPネットワークからチャンネルデータファイルを生成するChannelレンダーノードを作成します。

Dynamics

シミュレーションネットワークからキャッシュ化されたシミュレーション状態ファイルを生成するDynamicsレンダーノードを作成します。

Edit Render Node

このサブメニューは、デフォルトのレンダーネットワーク内のすべてのレンダーノードをリストします。 パラメータを編集したいノードを選択すると、フローティングウィンドウが開きます。

Render

このサブメニューは、デフォルトのレンダーネットワーク内のすべてのレンダーノードをリストします。 レンダリングしたいノードを選択すると、そのノードのレンダリングが開始されます。

Preview in MPlay

このサブメニューは、デフォルトのレンダーネットワーク内のすべてのレンダーノードをリストします。 レンダリングしたいノードを選択すると、そのノードがMPlayウィンドウでレンダリングされます。

Scheduler

フローティングウィンドウでRender Managerを開きます。 このリストは、現在アクティブなバックグラウンドレンダリングすべてを表示します。 ジョブを停止またはキャンセルすることができ、 Clear Completed Jobs が無効になっていれば、完了したジョブの履歴を見ることができます。

Update Textures

ディスクからキャッシュ化されたテクスチャを再読み込みします。

Cloud Properties

TBD.

Pre-flight Scene

TBD.

MPlay

このサブメニュー内の項目は、MPlay画像ビューアのインスタンスを開きます。

Load Disk Files

ファイルブラウザでファイルを選択してMPlayウィンドウを開きます。

Listen for Renders

インタラクティブなレンダーすべてをMPlayウィンドウに直接開きます。

Listen for Flipbooks

フリップブック(2D, 3D)すべてをMPlayウィンドウに直接開きます。

Takes

詳細は、テイクを参照してください。

New Take

現行テイクを継承した新しいテイクを開始します。

Auto Takes

"Auto Take"モードを有効または無効にします。これは、 Edit ▸ Automatically Add Parameter to Current Take と同じです。

Assets

New Digital Asset From Selection

選択したサブネットノードからデジタルアセットを作成します。 これは、サブネットノードを右クリックして Create Digital Asset を選択することと同じです。

Unlock Asset

このサブメニューは、ロックされているユーザーアセットすべてをリストします。 編集したいアセットを選択すると、そのアセットのロックが解除されます。 これは、アセットを右クリックして Allow Editing of Contents を選択することと同じです。

Lock Asset

このサブメニューは、ロック解除されているユーザーアセットすべてをリストします。 編集させたくないアセットを選択すると、そのアセットがロックされます。 これは、アセットを右クリックして Match Current Definition を選択することと同じです。

Save Asset

このサブメニューは、ロック解除されているユーザーアセットすべてをリストします。 アセットを選択すると、そのロック解除されているアセットに加えた変更がディスク上のノードの定義に保存されます。 これは、アセットを右クリックして Save Node Type を選択することと同じです。

Install Asset Library

ディスク上のライブラリファイルからアセットを現在のシーンファイルにインストールします。 これを使用することで、Houdini検索パス上にないファイルから"一回限りの"シーン固有のアセットをインポートすることができます。

Asset Manager

Asset Managerウィンドウを開きます。これは、 Windows ▸ Asset Manager と同じです。

Refresh Asset Libraries

利用可能なアセットライブラリとそれらの内容のリストを再読み込みします。 これは、Houdiniを起動してから例えば外部のアセット管理システムによって追加または変更のあったファイルを取得したい場合に役立ちます。

Create Black Boxed Asset from Selection

選択したアセットノードをロック解除や編集ができない"ブラックボックス"のアセットに変換します。 このブラックボックスのアセットは、別名の新しいアセットタイプになります。

Orbolt Asset Store

ブラウザでOrboltアセットストアーを開きます。

Orbolt Asset Browser

Orboltアセットストアーからダウンロードしたアセットをブラウズすることができるペインまたはウィンドウを表示します。

Upload to Orbolt Asset Store

選択したアセットをOrbltアセットストアーにアップロードする処理を開始します。

Other Asset Tools

このサブメニューには、アセットを扱うための追加項目が含まれています。

Encapsulate Asset

Compile and Embed Material

Embed Internal Assets

Desktop

このメニューでは、"デスクトップ"(保存されたペインレイアウト)を選択することができます。 Houdiniには、いくつかのタスクに特化したレイアウトが用意されています。デフォルトのデスクトップは、多目的レイアウトの"Build"です。 Desktop ▸ Save Current Desktop As を使用することで、独自のレイアウトを新しいカスタムデスクトップとして保存することもできます。

詳細は、ペインレイアウトを参照してください。

New Desktop

ペインレイアウトをシーンビューアタブの付いた単一ペインに"リセット"します。

Save Current Desktop

現行レイアウトの変更を保存します。これは、デスクトップの現行名を維持します。

現行レイアウトを新しい名前のデスクトップとして保存したい場合は、代わりに Save Current Desktop As を使用します。

Save Current Desktop As

現行レイアウトを新しい名前で保存します。その名前が Desktop メニューに表示され、その保存したレイアウトを呼び出すことができます。

Save All Desktops

すべてのレイアウトの変更を保存します。複数のレイアウトを修正して、すべての変更を維持したい場合には、これを使用します。

Reload Current Desktop

保存した定義をディスクから再読み込みすることで、現行ペインレイアウトをリセットします。

これは、保存されていない変更を破棄したい場合や、Houdiniを起動してからデスクトップファイルが変更された時にその変更を反映させたい場合に役立ちます。

Desktops Manager

保存したレイアウトを複製、名前の変更、削除などの操作をすることができるDesktop Managerを開きます。

Reset Main Menu to Top

メニューバーをペイン内に移動させていた場合、これは、メニューバーをメインウィンドウの上部に戻します。

(ペインメニューの Pane Interface ▸ Move Main Menus Here 項目を使用することで、メニューをペインに移動させることができます。)

Mac OSでは、メニューバーは常にメインスクリーンの上部にあるので、これは何の効果もありません。

Reset Shelf to Top

シェルフをペイン内に移動させていた場合、これは、シェルフをメインウィンドウの上部に戻します。

(ペインメニューの Pane Interface ▸ Move Shelf Here 項目を使用することで、シェルフをペインに移動させることができます。)

Reset Playbar to Bottom

再生バーをペイン内に移動させていた場合、これは、再生バーをメインウィンドウの下部に戻します。

(ペインメニューの Pane Interface ▸ Move Playbar Here 項目を使用することで、再生バーをペインに移動させることができます。)

Reset Status Bar to Bottom

ステータスラインをペイン内に移動させていた場合、これは、ステータスラインをメインウィンドウの下部に戻します。

(ペインメニューの Pane Interface ▸ Move Status Bar Here 項目を使用することで、ステータスラインをペインに移動させることができます。)

Radial

このメニューは、カスタムRadialメニューキーを押した時に開くRadialメニューを選択することができます。 Houdiniには、いくつかのタスクに特化したRadialメニューが用意されています。 Radialメニューエディタを使って独自のRadialメニューを作成し、Hotkeyエディタでそれらのメニューをキーに割り当てることもできます。

詳細は、RadialメニューHotkeyエディタを参照してください。

Create New

新しい空っぽのRadialメニューを作成し、それをRadialメニューエディタで開きます。

Edit Current

"現行の"RadialメニューをRadialメニューエディタで開きます。

Pin Radial Menu

Desktop メニューでパネルレイアウトを変更した時の現行Radialメニューの変更をロックまたはロック解除します。

Windows

Keep Floating Windows on Top

フローティングウィンドウをメインウィンドウの前面に常に表示させるかどうか、または、フローティングウィンドウが現行ウィンドウでない時に背後に移動させるかどうかを切り替えます。

New Floating Panel

新しいウィンドウを独自のペインレイアウトで開きます。これは、特に複数のモニタ上にHoudini UIを追加する時に役立ちます。

ペインレイアウトを編集する方法を参照してください。

Animation Editor

Animation Editorウィンドウを開きます。 このウィンドウでは、アニメーションパラメータやHoudiniがキーフレーム間の遷移を補間する方法を確認したり編集することができます。

Hscript Textport

Hscript Textportウィンドウを開きます。 このウィンドウでは、HScriptコマンドをタイプして、その結果をプリントすることができます。

Python Shell

Pythonシェルウィンドウを開きます。

Python Source Editor

hou.sessionモジュールの内容を編集することができるウィンドウを開きます。 このモジュールは、シーン固有のPythonコードを記述するための場所です。

Python Panel Editor

Python Pane Editorウィンドウを開きます。 このウィンドウでは、Pythonで定義されたカスタムペインタイプを複製、編集、名前の変更をすることができます。

Bundle List

Bundle Listウィンドウを開きます。 このウィンドウでは、現行シーン内のすべてのバンドルが表示されます。

Take List

Take Listウィンドウを開きます。 このウィンドウでは、テイクの切り替えや編集をすることができます。

Parameter Spreadsheet

Parameter Spreadsheetウィンドウを開きます。 このウィンドウでは、複数のノードに対して複数の値を一度に編集することができます。

Tree View

Tree Viewウィンドウを開きます。 このウィンドウでは、シーン内のすべてのノードのリストを階層で表示します。

Houdini Engine Debugger

Houdini Engine Debuggerウィンドウを開きます。 このウィンドウでは、Houdini Engine Debuggerの開始と停止をすることができます。 このフローティングウィンドウを閉じても、サーバーはアクティブなままになります。

Asset Manager

Asset Managerウィンドウを開きます。 このウィンドウでは、デジタルアセットライブラリの編集、アンロード、削除をすることができます。

Gallery Manager

Gallery Managerウィンドウを開きます。 このウィンドウでは、どのノードタイプのギャラリーエントリーも閲覧/編集することができます。

Persistent Handle Editor

Persistent Handleウィンドウを開きます。

Material Palette

Material Paletteウィンドウを開きます。 このウィンドウでは、Galleryからマテリアルの作成/割り当てをすることができます。

Code Viewer

Code Viewerウィンドウを開きます。 このウィンドウでは、VOPノード内部のVEXコードを閲覧することができます。

このウィンドウ上にVOPノードをドロップしたり、ノード選択ダイアログからノードを選択することで、そのノード内部のVEXコードを閲覧することができます。 これは、ノードを右クリックして View Code を選択することと同じです。

Performance Monitor

Performance Monitorウィンドウを開きます。 このウィンドウでは、クック時間を記録して、その結果を表示するので、シーン内の遅い部分を特定することができます。

Audio Panel

Audio Panelウィンドウを開きます。 このウィンドウでは、Houdiniの音声出力を制御することができます。

Cache Manager

Cache Managerウィンドウを開きます。 このウィンドウでは、キャッシュサイズの設定、キャッシュ使用量の確認、キャッシュのクリアをすることができます。

Shell

新しくシステムコマンドラインウィンドウを開きます。

Autorigs

Auto Rigsビルダーウィンドウを開きます。

Character Picker

Character Pickerウィンドウを開きます。

Pose Library

Pose Libraryウィンドウを開きます。

Pose-Space Deform

Pose-Space Deformビルダーウィンドウを開きます。

Help

Start Here

ブラウザでHoudiniのチュートリアルページを開きます。

Contents

組み込みブラウザでHoudiniのオンラインヘルプを開きます。

Example Files

Houdiniのオンラインヘルプを開いて、サンプルファイルのリストを表示します。

Sidefx.com

ブラウザでsidefx.comのウェブサイトを開きます。

Online Tutorials

ブラウザでHoudiniのチュートリアルページを開きます。

Houdini Forum

ブラウザでHoudiniのフォーラムを開きます。

Online Support

ブラウザでHoudiniのサポートページを開きます。

Updates

ブラウザでHoudiniのダウンロードページを開きます。

Tooltip Help

Houdini UI上にマウスカーソルを置いた時にツールチップを表示するかどうかを切り替えます。

Open "Start Here" Pane at Startup

Houdiniを起動した時に学習リソースへのリンクを含んだウィンドウを表示するかどうかを切り替えます。

About Houdini

起動しているHoudiniのバージョンを知ることができます。

リファレンス

ユーザーインターフェース

  • メニュー

    メインメニュー内のそれぞれの項目について説明します。

  • ビューア

    ビューアペインタイプ。

  • ペイン

    色々なペインのオプションを説明します。

  • ウィンドウ

    色々なユーザーインターフェースウィンドウのオプションを説明します。

プログラミング

  • エクスプレッション関数

    エクスプレッション関数は、パラメータの値を計算することができます。

  • エクスプレッションクックブック

    エクスプレッションを記述して色々なエフェクトを表現するためのTipsとテクニック。

  • Pythonスクリプト

    PythonとHoudini Object Modelを使用してHoudiniのスクリプトを記述する方法。

  • VEX

    VEXはシェーダの記述などのHoudiniのほとんどの場所で使われているハイパフォーマンスなエクスプレッション言語です。

  • HScriptコマンド

    HScriptはHoudiniのレガシースクリプト言語です。

コマンドライン

導師レベル

プラグインのインストール

  • Houdiniパッケージ

    プラグイン、ツール、アドオンが異なる環境変数定義ファイルを複数作成して、それらを組み合わせる方法。