request: explicitly reference python 2.7 in OS X

   5324   6   2
User Avatar
Member
99 posts
Joined: March 2009
Offline
I use Python 3.3 as my default python install in OS X for use with multithreaded Automator actions and this breaks Houdini installation. It took me a while to figure out the problem so I'm wondering if you could make an explicit reference to /usr/bin/python2.7 instead of just /usr/bin/python , which is where I think the problem is.
User Avatar
Member
36 posts
Joined: Oct. 2011
Offline
you could install macport in your mac, and use
sudo port select –set python pythonXX (MacPorts 2.x)
sudo python_select pythonXX (MacPorts 1.x)
to set the python version explicitly.

http://superuser.com/questions/35256/how-can-i-change-the-default-python-version-on-snow-leopard#35288 [superuser.com]
User Avatar
Staff
1096 posts
Joined: July 2005
Offline
Hello,

Houdini does not support Python 2.7 so you're stuck with using 2.6 or 2.5.

You can install older Python versions as suggested by hanton or download them straight from the Python website:
http://www.python.org/download/releases/2.6/ [python.org]

Cheers,
Rob
User Avatar
Staff
1096 posts
Joined: July 2005
Offline
Actually, just to clarify, what's breaking because of Python 3.3?

Is it the Houdini installer? Or is it Houdini itself?

–Rob
User Avatar
Member
4172 posts
Joined: June 2012
Offline
Does setting any of these 3 environmental variables help?

HOUDINI_PYTHON_VERSION, HOUDINI_PYTHON_LIB, HOUDINI_PYTHON_BIN
User Avatar
Staff
1096 posts
Joined: July 2005
Offline
MartybNz
Does setting any of these 3 environmental variables help?

HOUDINI_PYTHON_VERSION, HOUDINI_PYTHON_LIB, HOUDINI_PYTHON_BIN

Houdini on OSX respects $HOUDINI_PYTHON_VERSION and $HOUDINI_PYTHON_LIB so you should be able to set either HOUDINI_PYTHON_VERSION=2.6 or HOUDINI_PYTHON_LIB=/System/Library/Frameworks/Python.framework/Versions/2.6/Python to force Houdini to use a particular Python version.

Note though that Python 2.7 is still not supported by Houdini.

Cheers,
Rob
User Avatar
Member
99 posts
Joined: March 2009
Offline
rvinluan
Actually, just to clarify, what's breaking because of Python 3.3?

Is it the Houdini installer? Or is it Houdini itself?

–Rob

sorry - late returning to this. The installer breaks, not Houdini.
  • Quick Links