Tesla with Houdini 12 functionality

   6182   15   1
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
I have recently purchased a Tesla K10, in the belief that it will dramatically speed up Pyro and fluid simulations.

I have 3 questions:

1. Do you need a Tesla AND a Quadro as asking around about how to get the Tesla to work with Houdini has suggested, or can it work alone to speed up sims?

2. Does it help speed up other dynamics or just Pyro and fluid?

3. If it is possible to use just the Tesla, how do I implement this?

Yours,

A keen noob,

5DN.

PS: although I know if this is probably obvious, I have another, not very good Nvidia card that runs my monitor.
User Avatar
Member
4189 posts
Joined: June 2012
Offline
Not specific to the Tesla but may be of use;

1. Houdini currently uses 1 card for OpenCL

2. OpenCL is enabled for specific nodes. Searching the documentation you get below, but may not be comprehensive.

Gas OpenCL dynamics node
Gas Stick on Collision dynamics node
Gas Disturb Field CL dynamics node
Gas Advect CL dynamics node
Gas Project Non Divergent Multigrid dynamics node
Gas Combustion dynamics node
Smoke Solver dynamics node
Pyro Solver dynamics node

3. You can choose your OpenCL device with the environment variable
HOUDINI_OCL_DEVICENUMBER
HOUDINI_OCL_VENDOR
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
MartybNz
3. You can choose your OpenCL device with the environment variable
HOUDINI_OCL_DEVICENUMBER
HOUDINI_OCL_VENDOR

Understood the rest but this is beyond me as a noob… searched help to no avail. Could you link me to some documentation about how to do this or post here if not too much trouble.

Thanks.

PS: i noticed you've helped me a few time. thanks. i was wondering if as a night owl you being on the other side of the world is a bonus for your help!?
User Avatar
Member
4189 posts
Joined: June 2012
Offline
In the Houdini terminal/command line tools you can find out information on all the available variables:

typing ‘hconfig -H’

Gives a descriptive environment variables. This one is probably the most significant:

HOUDINI_OCL_DEVICENUMBER
In the case of multiple OpenCL devices existing of the type specified by
HOUDINI_OCL_DEVICETYPE, this variable selects which of these devices to
use for OpenCL processing. For example, with a computer with more than
one GPU this allows selection of a GPU other than the default for OpenCL.

So you would set it to either 0 or 1 I believe. On OsX you put this into the Houdini.env file as.

HOUDINI_OCL_DEVICENUMBER = 1

Then in Houdini go to help/about Houdini, scroll down. It should say which device is being used for OpenCL if I recoil correctly- OsX doesn't yet support OpenCl so I get ‘OpenCL is not supported for this system’

Hope that helps.
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
I'd tried your advice and loads of alternate methods I can think of to no avail.

I get error message:

OpenCL Exception: No OpenCL platform found. (-32)

Tried putting:

HOUDINI_OCL_DEVICENUMBER = x

into Houdini.env file where i've tried 0-4 as x

Same error message always.

I'm beginning to worry my Tesla may not be working properly

It does say its fine in Windows device manager though… does this mean its definitely ok?

I also have tried using the nVidia control panel to disable the attempted use of CUDA on my Geforce 210 and still the same message.

It says there's a Tesla there though so that cheered me up.

I did install a bunch of other crap on my computer a few days ago to try and test the Tesla (Visual Studio, somebenchmark stuff,etc.) and wondered if any of that could have messed up my system. I'm trying to clean it out now.

Thanks in advance for any more help

Nick.
User Avatar
Member
4189 posts
Joined: June 2012
Offline
Bummer - without a Telsa here to test with can't help sorry.

Those options worked on Linux and one AMD card one GeForce card.
User Avatar
Staff
817 posts
Joined: July 2006
Offline
5DN
I'd tried your advice and loads of alternate methods I can think of to no avail.

I get error message:

OpenCL Exception: No OpenCL platform found. (-32)


Hmm, you get this error even when no environment variables are set? It could be a driver problem, but by default the Nvidia drivers should include an OpenCL driver. Your regular Nvidia video card should at least show up in the About Houdini | Details box as an OpenCL device.

Have you tried any other OpenCL-based software like LuxMark?
http://www.luxrender.net/wiki/LuxMark [luxrender.net]
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
johner
5DN
I'd tried your advice and loads of alternate methods I can think of to no avail.

I get error message:

OpenCL Exception: No OpenCL platform found. (-32)


Hmm, you get this error even when no environment variables are set? It could be a driver problem, but by default the Nvidia drivers should include an OpenCL driver. Your regular Nvidia video card should at least show up in the About Houdini | Details box as an OpenCL device.

Have you tried any other OpenCL-based software like LuxMark?
http://www.luxrender.net/wiki/LuxMark [luxrender.net]

have not tried that software.

if there are no default variables its automatically OpenCLs the Geforce 210….

any ideas?
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
I've decided that the damned this is probably definitely broken, was when I got it, AND the seller knew this. Opened a case on ebay to get my money back.

Thanks for the help though guys.

User Avatar
Staff
5182 posts
Joined: July 2005
Offline
Did you check the Windows Device Manager to see if it's being recognized, or has an issue (yellow (!) icon on the label). I'm assuming that you have the aux power connectors plugged in and have a power supply that's large enough to power your system with the Tesla K10 in it.

Edit: also make sure the Tesla driver installed correctly.
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
twod
Did you check the Windows Device Manager to see if it's being recognized, or has an issue (yellow (!) icon on the label). I'm assuming that you have the aux power connectors plugged in and have a power supply that's large enough to power your system with the Tesla K10 in it.

No yellow icon in device manager.
I had one 8-pin power connected. Some documentation said I only needed that.
Do I need to connect the 6-pin too?
I have an 800W PSU, which a computer specialist said was enough.
What has led me to believe its broken is two missing gold bits on the PCI slot…..
i'll upload photos…..
and there is a photo of something that i couldn't discover what it was….

thanks…

nick

Attachments:
whatsthistesla.jpg (150.8 KB)
teslamissinggold2.jpg (321.1 KB)
teslamissinggold1.jpg (294.4 KB)

User Avatar
Staff
5182 posts
Joined: July 2005
Offline
I just checked a Quadro of mine and it seems to have the same short pins. So I don't think it's damaged.

Try connecting the 6pin too, the K10 is basically a GEForce 690 which requires 2 8pin's, and it couldn't hurt. Your power support is definitely ok.
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
plugged it back in.
Device manger says its there and fine.
Nvidia panel says it there.

houdini and now luxmark deny its existance….

aarggghhh…

User Avatar
Member
4189 posts
Joined: June 2012
Offline
Maybe try installing Linux. It might work there?
User Avatar
Member
152 posts
Joined: Jan. 2014
Offline
Wheres the place to download? Which version? Where do get drivers?

Gunna start reading documentation tomorrow but thought you guy's advice would obviously be a MASSIVE help.
User Avatar
Member
4189 posts
Joined: June 2012
Offline
Try Unduntu 12.04:
http://www.ubuntu.com/download/desktop [ubuntu.com]

Nvidia drivers - use the Linux option!
http://www.nvidia.com/Download/index.aspx?lang=en [nvidia.com]

That worked for a GeForce - should be fine to test with for Telsa I'm guessing.

And of course Houdini on Linux! Installation faq:
http://www.sidefx.com/index.php?option=com_content&task=view&id=1207&Itemid=273 [sidefx.com]
  • Quick Links