Mantra Shader SSS and True Displacement

   3729   5   1
User Avatar
Member
508 posts
Joined: July 2005
Offline
Hello guys,

after working on the shading for a simple character, and being happy with it, I'm now banging my head against True Displacement when using Multi SSS.

I nailed the look for the guy, nice “puppet plastic” SSS, but when I enable True displacement the SSS doesn't work anymore.
I tried writing the SSS pc before and then reading it, and I tried the defaul “create PC at render time” …

using H13 latest build, default Mantra huber shader.

anybody has some insight regarding this?

many thanks in advance.
JcN
VisualCortexLab Ltd :: www.visualcortexlab.com
User Avatar
Member
872 posts
Joined: April 2008
Offline
Try to enable inside the shader in the sss node try to change the model to “Full ray tracing” to see if helps.
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
508 posts
Joined: July 2005
Offline
oh nice! thank you! that fixed the issue by setting it to “ray trace”.


thanks a million
JcN
VisualCortexLab Ltd :: www.visualcortexlab.com
User Avatar
Member
508 posts
Joined: July 2005
Offline
Hello again,

yeah the trick did solve the problem, now I can render both .. however render times jumped up sky high :\

have you got any ideas on how to contain render times using full ray tracing for SSS+Displacement?

thanks a lot in advance already!
JcN
VisualCortexLab Ltd :: www.visualcortexlab.com
User Avatar
Member
872 posts
Joined: April 2008
Offline
You could try to lower the samplig in the SSS and try also to play with min and max ray sampling in mantra, but it is strange for it to happen how high is your displacement?
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
508 posts
Joined: July 2005
Offline
Thanks I will try it. I already lowered the SSS samples, but I will also try the Mantra settings now!


displacement is very small, 0.01 to 0.03 max.
JcN
VisualCortexLab Ltd :: www.visualcortexlab.com
  • Quick Links