Slow viewport performance on MacOS Yosemite

   2571   2   1
User Avatar
5 posts
Hello there,

I just started learning Houdini apprentice on a 2014 Macbook Pro 13 inch.

I can tumble in the viewport fine but if I create any geometry, the performance is dropping significantly, even if it's just a cube.
Speed is getting better if I zoom out so it seems fill rate related..

I'm pasting some system info here:

Platform: darwin-x86_64-clang5.1-MacOSX10.9
Operating System: Mac OS X Version 10.10.2 (Build 14C109)
Number of Cores: 4
Physical Memory: 16.00 GB
Number of Screens: 1
Screen 0: 1680 x 1050 at 0,0
Work Area 0: 1650 x 1027 at 30,0

OpenGL Vendor: Intel Inc.
OpenGL Renderer: Intel Iris OpenGL Engine
OpenGL Version: 4.1 INTEL-10.2.46
OpenGL Shading Language: 4.10
Detected: Intel GMA Consumer (Mac version)
Unknown VRAM
Unknown driver version

upported Extensions not in OpenGL 3.2 (Version):
GL_ARB_explicit_attrib_location (3.3)
GL_ARB_gpu_shader5 (4.0)
GL_ARB_gpu_shader_fp64 (4.0)
GL_ARB_instanced_arrays (3.3)
GL_ARB_occlusion_query2 (3.3)
GL_ARB_sample_shading (4.0)
GL_ARB_separate_shader_objects (4.1)
GL_ARB_shader_bit_encoding (3.3)
GL_ARB_texture_buffer_object_rgb32 (4.0)
GL_ARB_texture_swizzle (3.3)
GL_ARB_timer_query (3.3)
GL_ARB_transform_feedback3 (4.0)
GL_ARB_vertex_attrib_64bit (4.1)

Unsupported OpenGL Extensions used by Houdini:
GL_ARB_base_instance (4.2)
GL_ARB_buffer_storage (4.4)
GL_ARB_multi_bind (4.4)
GL_KHR_debug (4.3)

I have run the mac software update and all seems good. Also I can run other 3D-softwares fine on the system.

Has anyone experienced something similar?

Any help would be really appreciated,

User Avatar
1793 posts
Joined: June 2008
It is your Intel graphics card. They suck. Unfortunately there is nothing you can do other than sell that mac book now while it has some value. Mac laptops and Houdini are kind of a low end solution.

You should be able to do simple tutorial learning stuff on your laptop but beyond that you might want something better.

You might get better performance by uninstalling Houdini R14 and installing Houdini R13. They changed viewport code between releases. Also your info indicates you are running 10.9 clang version on osx 10.10. try uninstalling Houdini R14 10.9 version and install the 10.10 version instead. It might be more optimized for your OSX.
Using Houdini Indie

Windows 7 32GB AMD FX8370 @ 4.1Ghz
nVidia 1070GTX 8BG RAM. Driver: 397.31
User Avatar
5 posts
Thanks for the reply!

Well, I can display millions of polygons at 30 fps in any other app and here a cube is bringing houdini to a crawl so I'm sure it's something else

Good call with the version - so I went back to the download page and both options
10.9 and 10.10 in the dropdown produce a download file called:

I tried it in both Chrome and Safari with the same result.

Weird! Any ideas? Is there another page to download specific builds?
  • Quick Links