Search - User list
Full Version: How To export simulations from Houdini to C4d
Root » Houdini Engine for Cinema 4D » How To export simulations from Houdini to C4d
Abdel Lahrichi
hello, im learning houdini, i created a sand sim and I want to export it to cinema 4d, How can i export it or where can i find a good tutorial on exporting. Thanks!

PS : Im in R17+C4dtoa
Hi Adbel,
can you be a bit more specific?
Do you just want to export the final sim, or create a Houdini Asset the calculates the sand simulation inside C4D?

For the former, just use Alembic. For the latter… it depends.
How many particles are you generating?

Abdel Lahrichi
Abdel Lahrichi
Hi Again,

i export my digital asset from houdini to C4d. and its works. i see particles. i want to know how to render them with C4dtoa ?

when i put an arnold Tag on digital asset it does not recognize particles like in x particles or thinking particles.

I'm sorry for my noob questions. thank you for help.
Can you see the particles in C4D?
Go to the Thinking Particle Settings and see what groups you have available and how many particles you have.
Create an “Arnold TP Group” object and make sure the “All” TP group is set.
Make sure you create the Arnold TP Group AFTER seeing particles in your viewport.
Add a light and render.

If you can't see ANY Thinking Particles in your C4D scene, make sure you have activated the “ID” parameter in Houdini. To do that, go to Houdini and in the simulation SOP select the “flip solver” and in the “Particle Motion” tab, “Behaviour” tab, activate the “Add ID Attribute”.
Abdel Lahrichi
…when i put an arnold Tag on digital asset it does not recognize particles like in x particles or thinking particles.

You don't need to add any tags…
Abdel Lahrichi
I see particles and i did what you told me to do. Its work Fine. Thank you.

Last question please : how can i keep the initial particles colors comes from houdini? because when i put colors on my tp group (C4d) i lost the color variation. it become all same color. i did a screenshot to see it.

see the link : []

Thank you sir
You have to export the color channel in the Arnold TP Group:
(Second image)

Use ‘color’ as the Attribute in a user_data_rgb shader, and put that as a color input for the diffuse
(first image)
Abdel Lahrichi
Thank you, Thank you , Thank you NOSEMAN ! you saved my life
My pleasure.
Please consider posting some test renders here.
I would love to see what users are creating with the Houdini Engine.


I got a question related to this.

I have done a sand simulation too, I exported a .sim cache in houdini and I did the digital asset so I can open it in c4d, which it runs.

The only problem that I have, is that I have two rigid bodies (the ground plane and a static object that interacts with the sand), but in the digital assets it recognized it as one simple object, so if I want the ground invisible, the collider object turns invisible too.

Is there a way to separate in the digital asset the ground plane to the static object?

I don't know if this is related to the C4D plugin.

Let's see if this works in Houdini first.
Can you create an asset that reads .sim data inside Houdini?
Please do it in an empty Houdini Document, NOT part of the overall simulation asset.
I saved a .sim sequence, but couldn't read it inside Houdini, so I wouldn't expect it to work inside C4D.
Can you please create an asset for me or explain: How to read .sim data inside Houdini?

ok… EDIT:
I managed to read the .sim file in Houdini.
It seems that it's some sort of weird Houdini Bug or limitation.
First of all you need to activate “Flip Solver - Particle Motion” Add id Attribute.
If you load the .sim cache, you will see that the id's are messed up and show -1.

What you need to do is override the id with $PT integer (Attribute Create).

That should allow you to import it properly in C4D.

I'm putting together a test right now and will post soon…
Tell me if you solve it anyway.
Attached asset.
So, the bottom line is that, if for any reason you can't see particles in C4D, it's probably because the “id” parameter is missing or messed up.

Thank you!!

Sorry about the edit of the post!

It works! yeah!
Marta J Mota
Is there a way to separate in the digital asset the ground plane to the static object?

This needs to happen inside the asset. After you import the .sim and add the ID attribute, you need to find a way to specify what is geo 1 and what geo 2 (r.g. floor and sphere).
Once you do that, create a new Geo SOP for each geo and import each object separately. Don't forget to delete the Geo from the original import SOP.
I don't know Houdini well enough to do this for you I'm afraid.
thank you.

I found an alternative way to do it, maybe there is a better way but it works.

I made another asset just for the static object I want to show. In this way, I load two digital assets in c4d, one of the whole simulation and another one for the collider object. So when I turn off the ground and the object that came together with the simulation, the other asset read only the object I wanna show.
hi again!

I have got another question. I added to the sand simulation the upres to have more particles and I want to bring it to c4d using the houdini engine.

Does houdini add the upres at the same time it calculates the simulation? or I had to do the cache of the sim and then add the upres?

If it's the first case, where do I have to put the file node to cache the sim? In the upres or in the autodopnetwork? And which format do I have to choose (.sim or .bgeo)?

Hi Marta,
this is a specific Houdini question, I'm afraid I don't know the answer.
Feel free to post on the Houdini side of the forum, but post your findings after, as I'm sure other users would be interested to know as well.

ok. Thank you very much anyway!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB