Can't snap pivot on my own object

   3429   9   0
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Hello,

I have a grid and I want to snap the pivot's transform tool to one of its points, but I can only snap it on points of others objects (cf. screenshot).

Is there normal ? Is there a workaround ?
Thanks.

Attachments:
snap_01.hiplc (64.1 KB)
snap_01.jpg (152.5 KB)

User Avatar
Member
4189 posts
Joined: June 2012
Offline
Snapping here for fine both the pivot and handle detachment.

OsX, Nvidia & H15.0.277
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
I'm really confuse, I try it again today and it work well.
I'm sure I'm not crazy, yesterday it doesn't work, probably a driver bug that need a relaunch of the program/computer.

Anyway, thank you for your time MartybNz.
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Finally I understand how to reproduce this bug.
It happens after a move with a middle click increment

step by step :
- select one object (here the plane)
- move it with a middle click increment
- and now, move handle detachment (same thing with pivot) with a point snap and you can see it can only snap to the other object but not on itself.

Can you confirm this ?
Thanks.
User Avatar
Member
1755 posts
Joined: March 2014
Offline
julca
Can you confirm this ?

No. What version of Houdini are you trying?
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Hi,
The last stable 15 indie version : 15.0.244.16
User Avatar
Member
1755 posts
Joined: March 2014
Offline
I see. I'm on 15.0.276 and I can't reproduce what you're saying. Maybe you should try this version (or a newer one) and see if you still encounter this problem.
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
Same thing with the last 15.0.279 version.
It's really just after a translation with the middle clic increment.

If, just after my middle clic translation, I move manually my object, this problem disappear, and handle detachment can be snapped correcly on itself.

I will submit a bug.
Thanks for your time.
User Avatar
Member
219 posts
Joined: Oct. 2015
Offline
For info :
Bug submitted and fixed in Houdini 15.0.283 !

Just to say that I really like their responsiveness and professionalism.
User Avatar
Member
89 posts
Joined: April 2017
Offline
I have the same issue with Houdini 18.5.532
Snapping is not working on the same object (with point snap) but ok with other objects.
Edited by jomaro - April 15, 2021 20:57:13
  • Quick Links