ParticleFLuidSurface node

   1526   7   2
User Avatar
Member
78 posts
Joined: Dec. 2013
Offline
Hello,

Anyone has any problem of refreshing mesh with the new ParticleFLuidSurface node in H15 ? It seems that everytime I change the Droplet scale it will never refresh again, whatever I try.

thx
User Avatar
Member
223 posts
Joined: April 2014
Offline
Yes, I am having this trouble as well. The node will stop refreshing no matter what settings I change. I'll even adjust what frame I'm on and it will not update. It seems to happen more often with bounding box enabled.
User Avatar
Member
1743 posts
Joined: March 2012
Offline
Could you provide a HIP file that reproduces this? I did a quick test and couldn't seem to reproduce the issue as described. Also, what platform are you on, what graphics card/driver are you using, and what build number of Houdini is it? (e.g. Houdini 15.0.234) If you decide to submit a bug [sidefx.com], please also include the information from the text box that shows up when you turn on “Show Details” in Help > About Houdini.
Neil Dickson - Writing code for fun and profit since… 2005? Wow, I'm getting old.
https://www.youtube.com/user/NeilGDickson/videos [www.youtube.com]
User Avatar
Member
223 posts
Joined: April 2014
Offline
I submitted a bug report (SESI #32220) along with a project file/cache (just added via email), and the “Show Details” info.

The difficulty is that I can’t seem to recreate it when I want to (isn't that the case with all bugs? haha). It just sort of happens or it doesn’t. So I also included a screencast in the report that demonstrates the symptoms.

Screencast:
https://www.dropbox.com/s/kcz3u2uclelt4un/FluidSurfaceNode_Refresh.flv?dl=0 [dropbox.com]
User Avatar
Member
14 posts
Joined: Jan. 2009
Offline
Any updates on this? I'm running into the same problem.

It seems if your Influence Scale is smaller or equal to your Droplet Scale the VDB from particles node inside the network throws an error. Once it errors other switches start throwing warnings and the vdb surfacer never snaps out of it.

I have to lay down a new particlefluidsurface node and make sure my Influence Scale is set to 2-3x's my Droplet scale.

This seems to be working, I'll reply to this thread if it breaks again.
User Avatar
Member
223 posts
Joined: April 2014
Offline
Yes, and I should have updated this.

Right click on the node –> “Allow Editing of Contents”.
Right click on the node again –> “Match Current Definition”

It should reset things for you. The SideFx Tech people said it has to do with interupting the cooking process while filters are enabled.
User Avatar
Staff
684 posts
Joined: July 2006
Offline
Quick update: this issue has been fixed in the latest daily build:

Houdini Journal
Wednesday, February 3, 2016
Houdini 15.0.376: Fix refresh problems when interrupting the cooking of various VDB filtering nodes. This also fixes the refresh problems of the Particle Fluid Surface SOP, which internally used these VDB nodes.

Please submit a bug if you see any other refresh problems.
Edited by - Feb. 4, 2016 13:38:57
User Avatar
Member
223 posts
Joined: April 2014
Offline
Thank you!
  • Quick Links