New Polyextrude and normals

   1544   4   0
User Avatar
Member
219 posts
Joined: June 2009
Offline
It seems that the new Polyextrude node ignores any normals that you create explicitly. For example, see attached file.

I create some point normals, and then use Polyextrude to extrude using “Extrusion Mode = Point Normals”. However, the resulting extrusion ignores the point normals I created.

Is this behaviour correct?

Attachments:
test_polyextrude.hipnc (55.3 KB)

Patrick
User Avatar
Member
1754 posts
Joined: June 2008
Offline
It probably is correct. If you select the PolyExtrude node and scroll down to the bottom you will discover that the node is Adding Vertex Normals to the result and removing point normals. Turn this off if you just want to keep point normals from the input geometry.
Using Houdini Indie

Windows 7 32GB AMD FX8370 @ 4.0Ghz
nVidia 1070GTX 8BG RAM. Driver: 358.87
User Avatar
Member
1284 posts
Joined: Sept. 2015
Offline
I think he's right (phj), unless there is something else one must do, it looks like you can't extrude along a user defined normal.

Ticking off what Enivob says doesn't work.

Attachments:
Set Normals.hiplc (69.4 KB)

User Avatar
Member
3481 posts
Joined: July 2007
Offline
Just change the parameter next to Extrusion Mode Point Normal from Precompute to Existing, or if you have other attribute than N you want to use then to Attribute and specify it

cause Precompute will, ehm, precompute it's own normal
Tomas Slancik
FX Supervisor
Method Studios, NY
User Avatar
Member
1284 posts
Joined: Sept. 2015
Offline
Hmm…I swore I tried that…thanks for the reminder.
  • Quick Links