Applying custom parameters to expressions in copy stamp

   1677   3   0
User Avatar
Member
3 posts
Joined: March 2017
Offline
Hi,

I am playing around with the various options within the transform tool, and find myself wanting to reference values within the node from elsewhere (i.e a null node with custom float parameter).

Right now, the y.axis transform is: fit01(rand(stamp(“../box1/copy1”, “copy”, 0)+435), -3.5, 3.5)

Pretty self-explanatory expression, transforming a box ‘x’ amount of times (determined by copy stamp) along the x-axis between -3.5 and 3.5.

My question is: how can I use a value from a float parameter in a null node and insert it in the place of ‘-3.5’ and ‘3.5’? Technically I can just change the values within the transform node itself, but for visual clarity I want to be able to input these values within a cleaner interface/ a slider.

I figured it would be something around the lines of:

fit01(rand(stamp(“../box1/copy1”, “copy”, 0)+435), -ch(“../Null1/Parameter1/”), (“../Null1/Parameter2/”)


But this does not seem to work.

Cheers
User Avatar
Member
39 posts
Joined: July 2013
Offline
Looks pretty close. I would recommend removing the minus sign on you first channel reference, you can always put that in when you put your minimum value into Parameter1. The second channel reference needs the ch in front of it. You also need to make sure that you have enough closed brackets at the end for each expression you use, it looks like you need one more to close your fit expression.
Edited by Sean Rowe - May 2, 2017 19:42:38
User Avatar
Member
346 posts
Joined: Feb. 2012
Offline
did you try to close you expression you are missing a “)”


fit01(rand(stamp(../box1/copy1, copy, 0)+435), ch(../Null1/Parameter1/), (../Null1/Parameter2/))

post your .hip
User Avatar
Member
3 posts
Joined: March 2017
Offline
sepu
did you try to close you expression you are missing a “)”


fit01(rand(stamp(../box1/copy1, copy, 0)+435), ch(../Null1/Parameter1/), (../Null1/Parameter2/))

post your .hip

Even after closing expression and making adjustments mentioned above, it still doesn't seem to want to work?

fit01(rand(stamp(../box1/copy1, copy, 0)+435), ch(../null1/paramater_1/), ch(../null1/parameter_2/))

Attached .hip file

Attachments:
Copy Stamp Tests.hipnc (59.8 KB)

  • Quick Links