Search - User list
Full Version: Texture Sheets tool missing features in Houdini 16
Root » Houdini for Realtime » Texture Sheets tool missing features in Houdini 16
I suppose this topic is directed mostly at Mike and Luiz but anyone who might have info on this is welcome to comment.

So, I thought of trying out the Game Development Toolset today. Super Excellent stuff guys - great work.
Anyways, to try out the tools, I ran the latest version from the repo (16.5), in Houdini 16.5 Apprentice at home. Sure watermarks and all that but everything seems to works just as expected (at least all the stuff I tried out).

So I come to the studio and fire up our FX version of Houdini 16, only to find out that features seem to be missing from the toolset when running in H16. Namely the “RGB lights rig”, “Emission Layer” and “Normals ‘blending’” features.

Now, I see in Mike's demo video ( [] ) that he's using H16 (705), exactly the same we're running at the office, and he has all the features that were available in the 16.5 demo I ran. Even though the repo has been updated multiple times since that video was released, somehow those features have not found their way into the H16 version of the tools …or even worse been removed.
…and yes I tried nearly all the branches of the repo - older versions even.

Can anyone confirm this is the case. …or am I missing something here?

Hi there,

Did you grab one of the releases from the github repo? Those features should be in there. []

Hello Mike,

Yes I tried all of those …none would show “full” features in H16.

Without looking too deep into it, it appears as if there's a ‘version check’ when launching the tool that determines which tool/script to run depending on the Houdini release (could totally be talking out of my A$$ right now …it's just a theory as I have …as I'm really only deriving that from the fact that I see two “texture_sheet” versions/folders in the “OTL” folder. :p

thanks for the help.

When you put down a texture sheet node can you click the info icon and tell me what path the hda is using?

It should be at the bottom of the window that opens.

The other option is to download the development branch and place the hda folders in your user otl folder.
So, H16.5 node info says:

[my path to the GameDevToolset]/otls/rop_texture_sheets_2.hda?gamedev:river/rop_texture_sheets::2.0

H16 node info says:

[my path to the GameDevToolset]/otls/rop_texture_sheets.hda?Driver/rop_texture_sheets

soooo …not running the same thing, it appears.
If you download the latest from the development branch you should be getting rop_texture_sheets::2.0
If you're not then it's possible your otl scan path is set incorrectly and it's not picking up the latest nodes.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB