Unity build error with HOUDINI_INSTALL_PATH

   3388   3   2
User Avatar
Member
19 posts
Joined: Oct. 2013
Offline
Hello
I have a build error in Unity that i cannot solve.
I have Houdini Indie 16.5.439 installed and licensed on macOS 10.13.4. Unity Version 2017.4.2f2. The scene only consists of a standard cube and the Houdini Engine Asset loaded. (other scenes don't work either)
The Houdini installation is not found, as it seems.
Maybe someone can help (if my explanation is not too complicated ), this is the error in console:

Assets/Plugins/HoudiniEngineUnity/Scripts/Core/HEU_Platform.cs(124,34): error CS0117: `HoudiniEngineUnity.HEU_HoudiniVersion' does not contain a definition for `HOUDINI_INSTALL_PATH'

but the C# file does have information on that, it asks for that in HEU_HoudiniVersion.cs
HAPIPath = HEU_HoudiniVersion.HOUDINI_INSTALL_PATH;
the HEU_HoudiniVersion.cs file points to the right Version:
public const string HOUDINI_VERSION_STRING = “16.5.439”;
public const string HOUDINI_INSTALL_PATH = “/Applications/Houdini/Houdini” + HOUDINI_VERSION_STRING + “/Frameworks/Houdini.framework/Versions/Current”;

plugin info window says:
Required Houdini Version: 16.5.439
Required Houdini Engine Version: 3.1.13

Unable to detect Houdini Engine installation.
License Type Acquired: Unknown

Failure possibly due to:

PATH:
/Applications/Houdini/Houdini16.5.439/Frameworks/Houdini.framework/Versions/Current/Resources/bin
/usr/bin
/bin
/usr/sbin
/sbin

what is strange for me, if i apply the “new Curve Asset” command it works, the scene works, and after that the plugin info looks good, but the compile errors are still the same.

this is how the plugin info looks like:

Required Houdini Version: 16.5.439
Required Houdini Engine Version: 3.1.13

Installed Houdini Version: 16.5.439
Installed Houdini Engine Version: 3.1.13

Houdini Binaries Path: /Applications/Houdini/Houdini16.5.439/Frameworks/Houdini.framework/Versions/Current/Resources/bin
Unity Plugin Version: 2

Session ID: 105553135862464
Session Type: HAPI_SESSION_THRIFT
Process ID: 6021
Pipe name: hapi

License Type Acquired: Houdini Engine Indie
PATH:
/Applications/Houdini/Houdini16.5.439/Frameworks/Houdini.framework/Versions/Current/Resources/bin
User Avatar
Member
571 posts
Joined: May 2017
Offline
This was a bug on macOS with HOUDINI_INSTALL_PATH not being defined for Unity run-time, or in this case, when trying to build the project. Should be fixed in tomorrow's build.
User Avatar
Member
19 posts
Joined: Oct. 2013
Offline
now it works, thank you very much
User Avatar
Member
7 posts
Joined: Dec. 2018
Offline
This is still broken on Windows machines (as far as I can tell), when you go to produce a Mac build from a Windows machine. Your #ifdef setup is assuming that one producing a Mac build means one is developing on a Mac, I think.

EDIT:

I haven't done a full test of functionality (and I'm going to toggle back to PC the second I'm done producing this build), but it seems the fix is HEU_Defines.cs, ln 321:

#if UNITY_EDITOR_OSX || UNITY_STANDALONE_OSX

Needs to instead be:

#if UNITY_EDITOR_OSX || (UNITY_STANDALONE_OSX && !UNITY_EDITOR_WIN)

… though now I'm wondering if this has to do with using Houdini engine runtime, presuming that's even an option. I haven't looked into it. The above fix allows it to compile, and should work fine if I only interact with Houdini in-editor, but would presumably break something if you do indeed support runtime interactions with the library.

Anywho! That's what got me going again in the trivial case, anyways.
Edited by glassbottommeg - Aug. 26, 2020 19:15:08
  • Quick Links