HDA Geo not visible in Unreal Mesh Distance Field

   245   2   2
User Avatar
Member
22 posts
Joined: Nov. 2007
Offline
Hey guys,

I am working with Unreal 4.19 and Houdini Engine. I am trying to use dynamic lighting using mesh distance fields and am finding that houdini hda meshes don't show up in Unreal's mesh fields. This happens even when I bake the geo in unreal and place it in the scene from the content browser.

In Unreal, I tried setting the “Distance Field Resolution” to 1 on the hda actor and baked geometry, but it didn't help. On the baked geo I also tried checking on “Generate Mesh Distance Field” but that didn't help either.

I included the simple Box.hdalc for testing and a gif showing me placing a regular unreal box and then the hda and toggling on and off “Viewport>Show>Visualize>Mesh Distance Fields”

Funny enough, while first placing the hda, the houdini logo mesh shows up in the Mesh Distance Field before cooking to the box.

I am wondering if there is just a setting I am missing somewhere, or if this is a bug I should report.

-bk

Attachments:
Box.hdalc (23.9 KB)
meshfields.gif (9.6 MB)

User Avatar
Member
7 posts
Joined: Oct. 2016
Offline
You have to set “Distance Field Resolution Scale” in the asset to something and than Recook Asset.
User Avatar
Member
22 posts
Joined: Nov. 2007
Offline
Thanks mark0s! Yeah I figured that out. I am gonna see if I can set it as a uproperty so I don't have to place and then recook it each time. Puts an unnecessary steps in the workflow.

Strangely when I baked the geo it stayed in the wrong state despite changing the "Distance Field Resolution Scale” to a proper value. But yeah, changing the value and recooking definitely fixes it.

Thanks again!
  • Quick Links