Search - User list
Full Version: HDA Geo not visible in Unreal Mesh Distance Field
Root » Houdini Engine for Unreal » HDA Geo not visible in Unreal Mesh Distance Field
Hey guys,

I am working with Unreal 4.19 and Houdini Engine. I am trying to use dynamic lighting using mesh distance fields and am finding that houdini hda meshes don't show up in Unreal's mesh fields. This happens even when I bake the geo in unreal and place it in the scene from the content browser.

In Unreal, I tried setting the “Distance Field Resolution” to 1 on the hda actor and baked geometry, but it didn't help. On the baked geo I also tried checking on “Generate Mesh Distance Field” but that didn't help either.

I included the simple Box.hdalc for testing and a gif showing me placing a regular unreal box and then the hda and toggling on and off “Viewport>Show>Visualize>Mesh Distance Fields”

Funny enough, while first placing the hda, the houdini logo mesh shows up in the Mesh Distance Field before cooking to the box.

I am wondering if there is just a setting I am missing somewhere, or if this is a bug I should report.

You have to set “Distance Field Resolution Scale” in the asset to something and than Recook Asset.
Thanks mark0s! Yeah I figured that out. I am gonna see if I can set it as a uproperty so I don't have to place and then recook it each time. Puts an unnecessary steps in the workflow.

Strangely when I baked the geo it stayed in the wrong state despite changing the "Distance Field Resolution Scaleā€ to a proper value. But yeah, changing the value and recooking definitely fixes it.

Thanks again!
Dealing with this issue right now.
Found I can set this Detail attribute to set the property:
@unreal_uproperty_GeneratedDistanceFieldResolutionScale = 1;

Weirdly, won't process this when first placing HDA. Change a param or force recook and it works as intended with Mesh Distance Fields updating.
@Ien Yeah that resembles some of the behavior I was seeing. It made me wonder why the initial cook on placement seemed to behave differently than subsequent cooks. It's been a while since I dealt with the issue, since that project ended and I have been doing raytracing on my current one.
@len: are you using version1 or version2 of the plugin ?
We're on version 1
Considering the jump to version 2 but “alpha” is a scary word.
@dpernuit: Ok, we've made the jump to v2 but now that detail attribute doesn't seem to work any more.
@dpernuit: Ok, we've made the jump to v2 but now that detail attribute doesn't seem to work any more.
We are using v2 of the plug-in and it is not working for us as well. Were you able to find a solution?

Just to clarify, we are trying to set the Distance Field Resolution Scale in the LOD 0 details.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB