COP Render Node missing extra planes?

   63   1   0
User Avatar
Member
5 posts
Joined: May 2018
Offline
I want to use the COP Render node as the basis for my COP network… but doing so requires that I can extract unique image planes beyond C and A. If, for example, I enable “Shading Depth” in the “Images > Extra Image Planes” section of the Mantra ROP node then I can flip to the new image plane in the Render View but the COP Render node and Composite View, the plane is missing. The docs say that “All variables on Mantra’s Deep Raster page are also rendered.” however I can't find a “Deep Raster” page in the ROP Mantra node. There's a “Deep Output” tab, but playing with the settings in it doesn't give me any new planes either. I'm fairly certain I could work around this if I manually saved a render to disk and loaded that into my COP network… but I really really don't want to have to manually save a render every time I want to update my COP network.

Is there a trick I'm missing here? Or am I out of luck?

Thanks!
User Avatar
Member
5 posts
Joined: May 2018
Offline
I figured it out… it seems that “Determine Planes from Driver” doesn't actually pull out the extra image planes. I believe this to be a bug and I'll be reporting it, but until then if you uncheck this box and manually fill in the planes that you setup in the ROP node by filling them in the Custom Planes field… the problem is solved. For example, if you want the Normals, the custom plane would be N{r,g,b}
  • Quick Links