Terrain Mesh Rop issues

   2750   4   0
User Avatar
Member
176 posts
Joined: April 2009
Offline
Hi,
I'm having a bit of trouble with the Terrain Mesh Rop, maybe someone can help me here.
With Adaptive density i get “holes” in my mesh. Where there is two faces from different resolution next to eachother, the smaller ones get detached from the bigger ones. This is best explained with an image:




Furthermore, exporting results in errors. I can only save the resulting geo manually, but the export button results in: OperationFailed: The attempted operation failed.
Error while cooking.

Could this be a H17 vs H16.5 issue? I'm using 17.0352

Cheers,
Rudi
Edited by RudiNieuwenhuis - Oct. 22, 2018 09:20:06

Attachments:
screenshot.jpg (31.4 KB)

User Avatar
Staff
197 posts
Joined: July 2015
Offline
Hi,

That's not supposed to happen. Could you tell me what version of the toolset you are using?

Paul
Paul Ambrosiussen
Technical Artist, Freelance
twitter.com/ambrosiussen_p
User Avatar
Member
176 posts
Joined: April 2009
Offline
Ambrosiussen
Hi,

Could you tell me what version of the toolset you are using?

Paul
Sorry, was away for a couple of days. This was in H17 with 1.64.

Cheers,
Rudi

Just tested with 1.66, same problem.

The problem seems to be in “attribwrangle23” where the NeedsTriangulation is set.
Prims that are adjacent to smaller prims (from a higher subdiv) do not necessarily have more then 4 primpoints so they don't get triangulated.
Hope this helps.

Update, tried in 16.5.571, works as expected, so it is a H17 only issue.
Edited by RudiNieuwenhuis - Oct. 30, 2018 10:17:08
RobW
Member
146 posts
Joined: March 2014
Offline
Running into the similar issues here.

Just trying to walk myself through the workflow&nodes, but I cannot export a FBX mesh, or render textures for that matter.

Getting an error on FBX export:
hou.ObjNode of type geo at /obj/terrain_valley/sop_terrain_segment_rop1/OUT_GEO/TerrainExport/Segment_1, hou.ObjNode of type geo at /obj/terrain_valley/sop_terrain_segment_rop1/OUT_GEO/TerrainExport/Segment_2, hou.ObjNode of type geo at /obj/terrain_valley/sop_terrain_segment_rop1/OUT_GEO/TerrainExport/Segment_3, hou.ObjNode of type geo at /obj/terrain_valley/sop_terrain_segment_rop1/OUT_GEO/TerrainExport/Segment_4.

Edit: just realized I cannot export FBX in Apprentice….

And no error on texture baking, just the baking popup showing it is rendering something.

Houdini 17.0.381 (Apprentice) & GameTools v.1.72

Basic test:
Open Houdini, get a basic terrain from the shelf, add both the terrain_segment and terrain_texture node. Try to export render some textures.

Edit: There seems to be a restriction on the renderable size of textures in Apprentice. Not sure what size I can render though…
Edited by RobW - Nov. 13, 2018 12:42:48
Apprentice Attribute / Houdini 17.0.381 / GTX 970 - driver 411.63
User Avatar
Staff
197 posts
Joined: July 2015
Offline
RudiNieuwenhuis
Ambrosiussen
Hi,

Could you tell me what version of the toolset you are using?

Paul
Sorry, was away for a couple of days. This was in H17 with 1.64.

Cheers,
Rudi

Just tested with 1.66, same problem.

The problem seems to be in “attribwrangle23” where the NeedsTriangulation is set.
Prims that are adjacent to smaller prims (from a higher subdiv) do not necessarily have more then 4 primpoints so they don't get triangulated.
Hope this helps.

Update, tried in 16.5.571, works as expected, so it is a H17 only issue.


Hi,

I was able to reproduce the issue with Terrain Segment ROP and have submitted a fix.
It will be fixed in build 1.84 and newer.

Paul
Edited by Ambrosiussen - Nov. 21, 2018 16:44:14
Paul Ambrosiussen
Technical Artist, Freelance
twitter.com/ambrosiussen_p
  • Quick Links