The Alpha attribute doesn't work when export as fbx file

   167   2   0
User Avatar
Member
10 posts
Joined: Feb. 2018
Offline
So let's create a simple scene, a box with Cd and Alpha attributes with some randomization.

It's works well so far, so I export the geo as fbx to other application(Unity3d or C4D) but the Alpha attribute doesn't works.
I re-import the geo with the file node, and I find the strange attribute named "Alpha2“ holds correct alpha value. And the ”Alpha" attribute gets the wrong value.

Is it a bug or something else I don't know?
I get the same result in H17 and H16.5

I attached the simple scene if you want to test.
Edited by EricSheng - Oct. 25, 2018 23:04:05

Attachments:
HoudiniTest_Screenshot01.png (511.6 KB)
HoudiniAlphaTest.hip (112.0 KB)
HoudiniTest_Screenshot02.png (596.9 KB)

User Avatar
Member
10 posts
Joined: Feb. 2018
Offline
So I find the problem. I export the fbx file as ASCII, and I find the Color attribute somehow be compressed.

And the Alpha attribute become User Data, which should be in the a channel of color.
It's quite annoy.
Edited by EricSheng - Oct. 25, 2018 22:58:56

Attachments:
HoudiniTest_Screenshot03.png (553.1 KB)

User Avatar
Staff
265 posts
Joined: Sept. 2016
Offline
Hi,

This should be fixed in tomorrow's daily build.

Alpha values exported with the Cd attributes were not properly taken into account when indexing the colors, which caused the “compression”. The second Alpha was caused by the alpha attribute being exported as a user attribute.
  • Quick Links