Smoke Retime flickering

   5524   4   6
User Avatar
Member
12 posts
Joined: Sept. 2016
Online
I tried retiming a smoke sim i had and a lot of flickering is happening. As if the frames that are being interpolated get blurred out over time and then sharp again. I tried every option there is. It's unusable
Volume advected, 0.02, cubic interpolation, speed 0.5

This happens even in new scene with default billowy smoke preset.

Attached is a simple scene as an example.

Any ideas?
Edited by romanus - Nov. 14, 2018 13:36:08

Attachments:
retime_flicker.hip (811.1 KB)

User Avatar
Staff
153 posts
Joined: Sept. 2017
Offline
A certain level of blurring is expected and unavoidable in general unfortunately. Note that the amount of blurring depends on voxel size, and thus should be less noticeable at higher resolutions.

Half frame offsets are in a sense the most difficult to interpolate (the minimum distance between input frames is maximized right in the middle). So your settings are giving the retimer a really difficult job here–it constantly switches between the “nicest” (integer frame) and “worst” (half frame) volumes. If you change your start frame to 1.25 instead, then you'll get a fairly consistent level of blurring throughout (since it'll compute frames 1.25, 1.75, 2.25, etc.), and the flickering should be eliminated.

Another point to keep in mind is that the viewport may occasionally lie to you about your volume's look (as in, you'll get quite a different result when you go out to render the frame). You can increase texture size limits and use HDR to avoid this.

I hope this gives you a better picture on caveats of volume retiming. Let us know if you run into any other issues!
User Avatar
Member
12 posts
Joined: Sept. 2016
Online
Thanks for the explanation. However even when starting at 1.25 it flickers a lot more.

For curiosity i tried input the density field instead of the velocity, and it worked, i just had to check interpolate velocity field, which in this case is the density one. Even with low res sims works “fine”. At least for my case it's good enough.

edit: I tried messing with the input timestep. So if i have a speed of 0.25, i'll do 1/$FPS/4, with integer frames off. It seems to work this way, even with low res sims.
Edited by romanus - Nov. 15, 2018 12:46:02
User Avatar
Member
101 posts
Joined: May 2006
Offline
Very helpful, just fixed up a shot I am working on with this.
Thanks Omarz.

Richard.


omarz
…Half frame offsets are in a sense the most difficult to interpolate (the minimum distance between input frames is maximized right in the middle). So your settings are giving the retimer a really difficult job here–it constantly switches between the “nicest” (integer frame) and “worst” (half frame) volumes. If you change your start frame to 1.25 instead, then you'll get a fairly consistent level of blurring throughout (since it'll compute frames 1.25, 1.75, 2.25, etc.), and the flickering should be eliminated.

User Avatar
Member
36 posts
Joined: Aug. 2006
Offline
I recently ran into one where my timescale was different on my solver, but it didnt actually mult the velocity by that amount, so I just had to mult the velocity to match post sim and pre retime to get rid of the strobing.
This worked with density, but I am still getting issues when doing a pyro render, so I am trying to figure out what is happening there. Temperature seems to be blending properly as well
  • Quick Links