Houdini 17.0 on Windows throwing "OpenCL Exception: clCreateProgramWithSource (-34)" error [SOLVED]

   14092   9   5
User Avatar
Member
9 posts
Joined: Dec. 2013
Offline
Hello,

I'm sharing it here since I had a pain in the bottom with solving this one half of the morning.

Basically whenever I ran Vellum sim on my Windows 8.1 laptop I got an error “OpenCL Exception: clCreateProgramWithSource (-34)” in Houdini Console and the sim did not run. I googled for an answer and found similar problems OpenCL related. My Houdini help showed “No Configured OpenCL Device”. I tried setting multiple env variables like HOUDINI_OCL_DEVICENUMBER=1 (0 -too),
HOUDINI_OCL_VENDOR=“Intel(R) Corporation”, HOUDINI_OCL_VENDOR=“NVIDIA Corporation” , HOUDINI_OCL_DEVICETYPE=CPU etc.

Ok - to the point - my solution was:
1. Edit the settings file "C:\Users\\Documents\houdini17.0\houdini.env“
2. Add this line anywhere ”HOUDINI_OCL_DEVICETYPE=GPU“.

DONE! So simple, yet very frustrating when you don't know it.

ps. For newer Houdini users - easy way to test if things work is to use Houdini Command Line Tools and run command ”hgpuinfo -c“. If it lists your device it means it works. If it throws something like: ”Could not create OpenCL device of type (HOUDINI_OCL_DEVICETYPE): GPU (…)" means it won't work.

Cheers,
Beny
User Avatar
Member
1 posts
Joined: Aug. 2017
Offline
Thank you, thank you, thank you!
User Avatar
Member
1 posts
Joined: May 2018
Offline
Thank you! This fixed it for me in version 17.5.425.
User Avatar
Member
1 posts
Joined: Dec. 2019
Offline
Thank you sooo much. This fixed the error in 18.0.499
User Avatar
Member
1 posts
Joined: July 2020
Offline
非常感谢。这修复了18.0.499中的错误
User Avatar
Member
9 posts
Joined: Dec. 2013
Offline
One more thing - when you had everything working and suddenly node like “Attribute Blur” SOP (or any other OTL using OpenCL SOP inside) throws similar error for you, I noticed that in most cases when you restart Houdini the error goes away. If not, try the above solution.
User Avatar
Member
6 posts
Joined: June 2018
Offline
Hello, just writing to say thank you! I was stuck and probably would have spent half the morning figuring this out too if it weren't for this. Thank you so much for sharing your solution! You're awesome.
User Avatar
Member
7273 posts
Joined: July 2005
Offline
I've been just changing this in the main preferences these days. From the main menu, Edit > Preferences > Miscellaneous > OpenCL Device.
User Avatar
Member
41 posts
Joined: April 2017
Offline
Thank you sooo much! Houdini 19.0.622
User Avatar
Member
1 posts
Joined: May 2022
Offline
Thank you - Houdini 19.5.303 - also helped
(mystery for me is that it worked yesterday, but this morning a wanted to edit project and openCL Expection appiered) - Thanks man
  • Quick Links