Navigation delay in viewport

   154   3   1
User Avatar
Member
3 posts
Joined: Feb. 2019
Offline
I am experiencing a delay in the viewport when navigating. The delay occurs when there is geo in the viewport and I “start to navigate”, when I start to rotate, pan or zoom. The delay is about 100-200 milliseconds (Maybe more if there is more geo).

There is no delay as long as I “navigate motion”, but if lift the mouse button or stops for half a second and then start to move again, the delay will appear again.

I noticed that the delay disappears if the performance monitor is running.

At the office today I could replicate the same issue, On my office computer I have an older version of Houdini (16.5) and the same happens here. I tried to run both versions at the same time, and found that If I turn on the performance monitor in the Houdini 16.5 there is no delay in Houdini 17.

I have installed Redshift and Octane, Megascans and qlib, but I tried to remove all entries from my env file, and the delay was still there.

I have tried to export the geo as obj and importing it to Maya, and the viewport is 100% smooth. I then imported the geo in Houdini to remove the possibility of lag from nodes in SOP, but the delay is still there.
User Avatar
Member
3 posts
Joined: Feb. 2019
Offline
So I updated my graphics driver, but nothing happened, but I noticed that when I had “Nvidia Control Panel” open and the Nvidia preview logo where visible, the lag in the viewport disappeared again.

I then tried to add Houdini to the “Program settings” and changed “Power management mode” to “Prefer maximum performance”, and now the viewport is running smooth.

Is this a known issue, or is it just my setup that have some conflicts?
User Avatar
Staff
4482 posts
Joined: July 2005
Offline
It sounds like it was downclocking your GPU during a period of inactivity, and it took a bit of time to power it up again. Unlike games, Houdini only redraws the viewport when it needs to, so it might have seemed inactive to the GPU. The performance monitor would cause more frequent refreshes which would likely prevent the GPU from going inactive.

Is it a laptop? Those tend to be more power-optimized, which might explain the aggressive power-throttling.
User Avatar
Member
3 posts
Joined: Feb. 2019
Offline
My office computer has 2x geforce 1080ti, but it seems possible that they would downclock under inactivity. I'll check if that is the case tomorrow.
  • Quick Links