GameDev Terrain Texture ROP Won't Export

   165   1   0
User Avatar
Member
1 posts
Joined: Feb. 2019
Offline
Hello!

I've been following the Game Dev Terrain Tool tutorial (https://www.sidefx.com/tutorials/game-tools-terrain-tools/) to try and export a normal map, heightfield map, and lowpoly mesh from my heightfield.

Although I've followed the tutorial pretty much identically, the sop_terrain_texture_rop is not exporting any textures. The bake texure/render window does briefly open, but no file is actually outputed to my intended directory. I tried multiple directory paths, and multiple file types. Is there any additional setup needed, not shown in the tutorial, to get this to work? I additionally tried exporting the cavity and occlusion map with the same results, nothing exports. The first half of the tutorial - exporting a sop_terrain_segment_rop DID work, it's just the textures that are failing.

Any insight into this would be greatly appreciated. I'm using Houdini FX 17.0.416
User Avatar
Member
19 posts
Joined: Sept. 2017
Offline
I am trying to go through this tutorial and having the same exact problem – nothing is exported and no error is reported.

https://www.artstation.com/khael/blog/wrdA/introduction-to-procedural-terrain-12-houdini-amp-ue4 [www.artstation.com]

I dug into the SOP and saw that there was an error in the ROP net. It was using $TEMP/BlahBlah.exr to store some intermediary images and on OSX you aren't allowed to write there without root permissions (I think). So I changed $TEMP to $HIP and it started baking.
  • Quick Links