Bugged?.. Cooking takes FOREVER on very simple scene.

   2342   3   0
User Avatar
Member
12 posts
Joined: May 2015
Offline
Okay, i've been trying to get something going for the past 2 hours but it's just not working. I've setup some wedging, which works correctly. But whenever I run the rop output driver it just takes absolutely FOREVER to cook. I've attached a very simple example scene with 5 wedges of a shattered sphere falling. Runs in realtime if I run this directly, but takes 2 full minutes PER FRAME when running through tops.
Can anybody point me out what the hell is going on or what i'm doing wrong?…

Attachments:
topstest_v001.hiplc (400.0 KB)

www.timvanhelsdingen.com
User Avatar
Staff
386 posts
Joined: Aug. 2017
Offline
I noticed a couple of things in your .hip file:

Because it's a simulation, you will want to turn on “All Frames in One Batch” under the ROP Fetch tab of the ROP Geometry node. Without this enabled, it is rerunning the simulation each time up to the frame that is being cooked. So the cook time for each frame will get progressively longer because it will have to resimulate the previous frames. “All Frames in One Batch” ensures that all frames are done in a single batch, and there is no additional overhead.

I would also disable “Cache Simulation” on the DOP network since it's not necessary because the sim is being run out of process and the files are being written to disk. For this sim, it's less important because it's very lightweight but if you're running multiple concurrent heavy duty sims, you might eat up all your RAM quickly.

One other thing – although you should definitely enable “All Frames in One Batch” for a simulation, it was no where near 2 minutes per frame for me when running the ROP geometry with the original settings. What kind of machine specs are you running with?
Edited by BrookeA - March 27, 2019 14:10:02
User Avatar
Member
12 posts
Joined: May 2015
Offline
BrandonA
I noticed a couple of things in your .hip file:

Because it's a simulation, you will want to turn on “All Frames in One Batch” under the ROP Fetch tab of the ROP Geometry node. Without this enabled, it is rerunning the simulation each time up to the frame that is being cooked. So the cook time for each frame will get progressively longer because it will have to resimulate the previous frames. “All Frames in One Batch” ensures that all frames are done in a single batch, and there is no additional overhead.

I would also disable “Cache Simulation” on the DOP network since it's not necessary because the sim is being run out of process and the files are being written to disk. For this sim, it's less important because it's very lightweight but if you're running multiple concurrent heavy duty sims, you might eat up all your RAM quickly.

One other thing – although you should definitely enable “All Frames in One Batch” for a simulation, it was no where near 2 minutes per frame for me when running the ROP geometry with the original settings. What kind of machine specs are you running with?

Hey brandon,
Thanks for your reply. I think i've tracked down the issue. So the “All Frames in One batch” indeed stops it from re-simming the entire thing, but the other problem was that apparently loading in network paths inside houdini.env severely slows down the startup time of TOPs (I had all my presets and OTL's on a network drive), even more then normal houdini startup time. Moving all my otl's and presets away from a network location and to my local drive has reduced startup time for TOPs from 2 minutes to about 35s. Still more then a clean install but at least this is workable.
Thanks!
Edited by Tim van Helsdingen - March 27, 2019 15:23:29
www.timvanhelsdingen.com
User Avatar
Staff
386 posts
Joined: Aug. 2017
Offline
What kind of startup times do you have with that environment when you're just starting up Houdini normally?
  • Quick Links