Fedora Core 5

   7176   3   2
User Avatar
Member
1 posts
Joined: March 2006
Offline
Hello, I installed today Houdini 8.1 at a Fedora Core 5 Linux. The first problem was the installation script, which stopped at installation with an error message. To correct this change in both installation scripts, houdini.install and sesinetd.install, the "tar xf“ against ”tar –wildcards -xf“ with a text editor. Now the installation should run without an error message.
Next problem was the SELinux extension of FC5. When you start Houdini you get an error message ”cannot restore segment prot after reloc: Permission denied". To solve this you can first disable the SELinux extension with system-config-securitylevel, which you start as root from console and click at the second tab of the gui at which you can disable it, or second change the security context of the library files as following:
# cd /opt/hfsX.X.XXX (Your Houdini base install directory)
# chcon -h -R system_ubject_r:textrel_shlib_t ./dsolib/
# chcon -R system_ubject_r:textrel_shlib_t ./houdini/dso/
# chcon system_ubject_r:textrel_shlib_t ./mozilla/*.so ./mozilla/*.a
Now Houdini should start with no error messages in the terminal. If you disable the SELinux extension and enable it again, the SELinux is relabeling the whole file system at system boot and you have to do the last step with chcon again.
Regards Marc
User Avatar
Member
507 posts
Joined: July 2005
Offline
I'm using FC5 since its out… and FC4 first… and i never had to do all those things.. everything was fine “out of the box”.

cheers.
JcN
VisualCortexLab Ltd :: www.visualcortexlab.com
User Avatar
Member
1387 posts
Joined: July 2005
Offline
EDIT: sorry, after writting something here I read first post again and realized I have no idea to solve the problem…

Sy
User Avatar
Member
507 posts
Joined: July 2005
Offline
oh.. i didnt got it was a help request btw … there were no question marks… anyway … I must add that my FC5 installations comes with SELinux disabled during setup … cause I read ATI drivers also got stucked/problematic during installation if SELinux is enabled… so It might be that my setup works out of the box… just cause SELinux is off… dunno.

cheers
JcN
VisualCortexLab Ltd :: www.visualcortexlab.com
  • Quick Links