Search - User list
Full Version: Houdini Engine stopped working : HAPI_RESULT_FAILURE
Root » Houdini Engine for Unity » Houdini Engine stopped working : HAPI_RESULT_FAILURE
After using for a while and without any issues Houdini Engine + Unity, Houdini Engine suddently stopped working.

Here is the error message I get :

I verified the presence of this .dll file, and everything seems to be normal.

Here is what I get when opening the Installation Info dialog :

And here is the session information (everything is still the default settings):

I verified my firewall settings and houdini is not being blocked.
This issue shows up even in an empty Unity project, with only the Houdini engine files added.

Any idea of what have could gone wrong?
It is exactly what happens to me. I have same issue. My houdini version 17.5.229.
All I tried was failed and It is still stacked.

in my guess,
1. PATH ? ( I setted Assets>import package> custom package, click ‘HoudiniEngineUnity.unitypackage’ )
2. License ? (my houdini core works well.)
3. Non-commercial and commercial version?(Was The path to the free version and the paid version twisted? )

But, these are just my guess.

How can I fix it correctly?
fantasticpotato: From the last screenshot, it looks like it created an in-process session which shouldn't ever happen as it has been deprecated and disabled. Could you try closing all the sessions via HoudiniEngine->Session->Close All Sessions. Then manually create a new session via HoudiniEngine->Session->Create->Pipe Session.

There haven't been any changes on the plugin side to cause these issues, that I could find. Could you try with the latest daily build? I just tested with 17.5.243 (today's build) and it works fine.
Thank you for your reply, seelan.

After installing the latest version(17.5.243), I tried to run it as it did, but I get the following error:

I had this error in the previous run, and I checked the libHAPIL.dll file every time. This file did not have any problems.
I tried closing all the session and create a new session, too. but, It still doesn't work.
What does your License Manager show?
Did you have free version installed before, and still have it?

Please provide more info on your setup.
Yeah, It was installed free version. but, It was deleted for now.
and, here is it
It might be that the Houdini Engine session is picking up the wrong license instead of Core or Engine license? Please set one of the following environment values, restart Unity, and try again:
HAPI_LICENSE_MODE = engine_only
HAPI_LICENSE_MODE = houdini_escape_only
I think it is picking up the right license. (attached image)

If you reinstall Windows, can I get out of all this hell?

Is there any last solution for me?
Your License Manager will show which license is acquired when you launch Houdini, or creating the session with Houdini Engine in Unity. But it looks like either the license isn't being acquired, or perhaps a technical issue with creating the Houdini Engine session.

Note that for your license setup, you have both an Engine and Core license on the same machine which is wasted since Core supersedes the Engine. Are you able to remove all but the Core license and try it?

Please send me the license diagnostic info from the machine you are trying to launch the plugin, so that we can validate the license. I believe you have a ticket already, so you can just send through that if you wish.

If possible, could you try with the Houdini Engine for Unreal plugin? Might help narrow down where the issue is plugin specific or more to do with license.
I sent you with message about license diagnostic.
and, I doesn't work remove all but the core license and try it. (attached image.)
also, I tried it in Unreal before, but it did not work.
Hi there,

I just want to follow up with this thread as I just received the same error.

If you are finding this for the first time and have the same errors. What fixed it for me was simply logging in manually to the License Administrator and allowing the connection through Windows Firewall. For full details, read on.

I have been using this workflow over the past week and it was working fine (more or less). This time, It first occurred when trying to load an HDA by dropping it into the scene.

I'm on Unity version 2019.1.141f and Houdini 18.0.348.

Mine was also a Free licence upgraded to Indie. I will also note that Unity itself does not crash. After the error occurs dragging the HDA into the scene is just totally unresponsive. Resetting Unity provided the same error message.

The panel message appeared. I got the same panel by going to HoudiniEngine > Installation Info. I also attached the Plugin Settings which I haven't really touched from the defaults (I don't think at least). I also included the SessionInfo from HoudiniEngine > Session > SessionInfo.

Following the thread, I checked the file you recommended and it appeared to be there.

HoudiniEngine > Session > Reconnect to session gave the the message “No existing session.”

HoudiniEngine > Session > Restart Session gave me the same message “No existing session.” however the pop-up box had the title : “Reinitializing Session” instead of “Reconnecting to session”.

I also attached my License Admin window, which for anyone else following along who is also a beginner can be found in the start Menu or by Searching in Windows for “License Administration ####.#.###” is (the folder was > C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Houdini 18.0.348\Administrative Tools). I was looking for it in the menu in Unity and Houdini so I just wanted to note it.

At this point, i realized I was not logged in to the License Admin window and logged myself in with email. At this point Unity connected and it seemed to be working. I was able to create the asset like usual. I finished the asset and figured I would just report the bug anyways because the errors and discussion didn't really make this obvious. I tried HoudiniEngine > Session > Restart Session and it showed all the previous errors and stopped working again. I got a windows Firewall popup for (I think) it was hapi but I didn't grab it. It had definitely worked before the Firewall Popup had disabled it again so it seems like that might be disconnecting the session.

It seems like weirdness with Windows Firewall spontaneously blocking the license refresh periodically. I just wanted to post this anyways in case anyone else came across any of the errors and was as confused as I was. Hopefully it helps.

I've attached all the noted files below.

Thanks for you time.

* also, the image attachment process is a little weird. In order to attach multiple images, I had to attach and Submit one at a time. In addition, it both attached and also put the markup tag into the text so the images would appear twice unless I deleted it. I'm not sure if I am the only one having problems but I found it a bit confusing.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB