PDG ffmpeg encode example fails without printing errors

   874   2   1
User Avatar
103 posts
Joined: July 2010
I am trying to get this example to work:
https://www.sidefx.com/docs/houdini/nodes/top/ffmpegencodevideo.html [www.sidefx.com]

I saved the hip file, then cooked the top node.
The opengl renders complete successfully.
But the ffmpegencodevideo1 node fails.
I tried explicitly entering the path to ffmpeg in the ffmpegbin parameter on the ffmpegencodevideo1 node.
That didn't help.
I tried setting the PDG_FFMPEG variable.
That didn't help either.
What's frustrating is that the ffmpegencodevideo1 node does not print to the terminal what the error is.

What am i missing?
Image Not Found
Edited by syntheticperson - May 17, 2019 12:58:19

ffmpeg.v01.hiplc (382.8 KB)

User Avatar
354 posts
Joined: Aug. 2017
Hi – if you double click the failed work item and click “Show Log” you should be able to get information about why it failed. Can you post the log here?
User Avatar
103 posts
Joined: July 2010
Hi Brandon,
thanks for showing me how to view the logs of a work item.
It helped me track down the problem.

Here is the error log for the ffmpegencode1 TOP node:

ffmpeg version 2.6.2 Copyright © 2000-2015 the FFmpeg developers
built with Apple LLVM version 6.1.0 (clang-602.0.49) (based on LLVM 3.6.0svn)
configuration: –prefix=/usr/local/Cellar/ffmpeg/2.6.2 –enable-shared –enable-pthreads –enable-gpl –enable-version3 –enable-hardcoded-tables –enable-avresample –cc=clang –host-cflags= –host-ldflags= –enable-libx264 –enable-libmp3lame –enable-libvo-aacenc –enable-libxvid –enable-vda
libavutil 54. 20.100 / 54. 20.100
libavcodec 56. 26.100 / 56. 26.100
libavformat 56. 25.101 / 56. 25.101
libavdevice 56. 4.100 / 56. 4.100
libavfilter 5. 11.102 / 5. 11.102
libavresample 2. 1. 0 / 2. 1. 0
libswscale 3. 1.101 / 3. 1.101
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 3.100 / 53. 3.100
Unrecognized option ‘apply_trc’.
Error splitting the argument list: Option not found
Executing command: “/usr/local/bin/ffmpeg” -y -r 12/1 -f concat -safe 0 -apply_trc iec61966_2_1 -i “/tmp/houdini_temp/ffmpeg.v01/pdgtemp/2894/ffmpegencodevideo10_framelist.txt” -c:v libx264 -vf “fps=12,format=yuv420p” -movflags faststart “/Users/jeroenlapre/Documents/viz/projects/dev/houdini/pdg/videos/ffmpegencodevideo10.mp4”

The version of ffpmeg I'm using doesn't recognise the option apply_trc

I enabled the FFmpeg command field, and changed it from:

{ffmpeg} -y -r {frames_per_sec}/1 -f concat -safe 0 -apply_trc iec61966_2_1 -i “{frame_list_file}” -c:v libx264 -vf “fps={frames_per_sec},format=yuv420p” -movflags faststart “{output_file}”


{ffmpeg} -y -r {frames_per_sec}/1 -f concat -safe 0 -i “{frame_list_file}” -c:v libx264 -vf “fps={frames_per_sec},format=yuv420p” -movflags faststart “{output_file}”

And now it works!

Much thanks.
  • Quick Links