Calculating Simulation slow down significantly if cache ram size increased too high

   3400   4   2
User Avatar
Member
20 posts
Joined: July 2019
Offline
Hi, I apologize if this post ended up in the wrong place on the forum. I wasn't sure where to post it.

I am doing a large scene with a large environment with high poly count 150M voxels for the proxy volume is used for FLIP collision detection. I noticed that if I enabled 50G of ram in the cache for the dopnet, it slows down significantly after an hour into calculating the sim. I am saving checkpoints, so I restarted the sim with 20G set for the dopnet and it runs a lot faster.

I suspect that the dopnet is using all the RAM to calculate and then buffers it all for the viewport and my computer thus finally runs out of RAM and starts using paging.

Is this possible? Or is it something else?

I am doing a file cache “save to disk” as well so I thought that locks up the entire Houdini, but I have noticed after I interrupt the saving task, the viewport is indeed loaded up with the sim, because I have enough points in the sim to notice the disk loading into the viewport.
User Avatar
Member
36 posts
Joined: July 2013
Offline
Hey,
yes even when rendering the file cache houdini still caches the sim in the background, its basically nothing else then pressing play in the timeline and watching the sim.

Even when you run it in batch or hython.
Thus it is always important to set the Cache Size appropriate.
In this case, when you don't care about viewport interaction, I would set the Cache Size to just a bit larger then 2 of the largest frames need.
Because you have no benefit at all if Houdini has the last 100 Frames in memory if your just saving them out anyways.
Hence there is more RAM available for the CPU's to work on the current frame.

When running SOP chains or Sims or whatever remotely in Batch or Hython (i.e. on a Farm) it is also mostly clever to bypass all Cache SOPs if any where used.
Being very handy in a interactive session, they can drastically reduce performance when saving out stuff.
User Avatar
Member
36 posts
Joined: July 2013
Offline
PS.
I would only use Checkpoints if your SIM runs unstable on your setup.
If your rather sure it goes through all the way, I would disable it.
Because writing the Checkpoints can take quite a bit of time for very massive SIMs, as it not only saves the output geo but the whole SIM state.
So this definitely causes some overhead.
User Avatar
Member
20 posts
Joined: July 2019
Offline
I enable checkpoints for every 25 frames or so, because it has helped in recovery from crashes or just when my PC runs out of ram. The overhead speed from checkpoints isn't too bad, but the size of the checkpoint files is what kills me. I remember using checkpoints the first time and it filled my ssd before the render completed.
User Avatar
Member
36 posts
Joined: July 2013
Offline
Yep, that can happen (-;
  • Quick Links