Houdini Engine for Unreal - Version 2

   93155   186   46
User Avatar
Member
6 posts
Joined: Aug. 2017
Offline
Colby Winfield
xycy9
I don't know why the houdini engine V-2 can't work in UE5. Could any guys can help me?
I'm also having trouble installing the Houdini Engine plugin in UE5. Did you manage to get it working?
You need to have Houdini version 18.5.633 installed. Then use the GitHub version of Houdini Engine V2 for 18.5.633. It worked for me but please follow instructions found here:

https://github.com/sideeffects/HoudiniEngineForUnreal-v2/tree/Houdini18.5-5.00 [github.com]

Copied and pasted the message below:

Houdini Engine for Unreal - Version 2.0.3

Update 3 of the V2 Plugin.
The plug-in is now linked to Houdini 18.5.633 / HAPI 3.6.3.

Documentation for version 2.0 of the plug-in is available:
https://www.sidefx.com/docs/unreal/ [www.sidefx.com]

Binaries are currently available for UE4.26, UE4.25, UE4.24.

Note: These are manual builds of the plugin, which can sometimes cause issues with windows defender/antivirus.
Also, if the plugin fails to start the Houdini Engine session, you may have to enable a custom Houdini location in the plugin settings and point it to Houdini 18.5.633's bin directory.

Installation:

Extract and Copy the "HoudiniEngine" folder to:

the "UE4.XX\Engine\Plugins\Runtime" folder for an engine installation.
the "UEPROJECT\Plugins" folder for a project installation (the project is recommended for the UE5 version of the plugin)


I hope this works for you brother.
User Avatar
Member
31 posts
Joined: June 2017
Offline
AeroAstroArts
Colby Winfield
xycy9
I don't know why the houdini engine V-2 can't work in UE5. Could any guys can help me?
I'm also having trouble installing the Houdini Engine plugin in UE5. Did you manage to get it working?
You need to have Houdini version 18.5.633 installed. Then use the GitHub version of Houdini Engine V2 for 18.5.633. It worked for me but please follow instructions found here:

https://github.com/sideeffects/HoudiniEngineForUnreal-v2/tree/Houdini18.5-5.00 [github.com]

Copied and pasted the message below:

Houdini Engine for Unreal - Version 2.0.3

Update 3 of the V2 Plugin.
The plug-in is now linked to Houdini 18.5.633 / HAPI 3.6.3.

Documentation for version 2.0 of the plug-in is available:
https://www.sidefx.com/docs/unreal/ [www.sidefx.com]

Binaries are currently available for UE4.26, UE4.25, UE4.24.

Note: These are manual builds of the plugin, which can sometimes cause issues with windows defender/antivirus.
Also, if the plugin fails to start the Houdini Engine session, you may have to enable a custom Houdini location in the plugin settings and point it to Houdini 18.5.633's bin directory.

Installation:

Extract and Copy the "HoudiniEngine" folder to:

the "UE4.XX\Engine\Plugins\Runtime" folder for an engine installation.
the "UEPROJECT\Plugins" folder for a project installation (the project is recommended for the UE5 version of the plugin)


I hope this works for you brother.

This worked to the T for me. Thank you!

no more hand placing lights for my scene! MWUAHUWHUahuawhuahuahUWHauhashaaaa
User Avatar
Member
6 posts
Joined: Aug. 2017
Offline
commedieu
AeroAstroArts
Colby Winfield
xycy9
I don't know why the houdini engine V-2 can't work in UE5. Could any guys can help me?
I'm also having trouble installing the Houdini Engine plugin in UE5. Did you manage to get it working?
You need to have Houdini version 18.5.633 installed. Then use the GitHub version of Houdini Engine V2 for 18.5.633. It worked for me but please follow instructions found here:

https://github.com/sideeffects/HoudiniEngineForUnreal-v2/tree/Houdini18.5-5.00 [github.com]

Copied and pasted the message below:

Houdini Engine for Unreal - Version 2.0.3

Update 3 of the V2 Plugin.
The plug-in is now linked to Houdini 18.5.633 / HAPI 3.6.3.

Documentation for version 2.0 of the plug-in is available:
https://www.sidefx.com/docs/unreal/ [www.sidefx.com]

Binaries are currently available for UE4.26, UE4.25, UE4.24.

Note: These are manual builds of the plugin, which can sometimes cause issues with windows defender/antivirus.
Also, if the plugin fails to start the Houdini Engine session, you may have to enable a custom Houdini location in the plugin settings and point it to Houdini 18.5.633's bin directory.

Installation:

Extract and Copy the "HoudiniEngine" folder to:

the "UE4.XX\Engine\Plugins\Runtime" folder for an engine installation.
the "UEPROJECT\Plugins" folder for a project installation (the project is recommended for the UE5 version of the plugin)


I hope this works for you brother.

This worked to the T for me. Thank you!

no more hand placing lights for my scene! MWUAHUWHUahuawhuahuahUWHauhashaaaa

Glad to help hopefully it can be added to the launcher to make it more accessable to users.
User Avatar
Member
6 posts
Joined: Aug. 2017
Offline
Hi there admins, just curious after watching the presentations for Houdini 19 here [www.youtube.com], if there will be either a github or in launcher option for Houdini Engine V2 for Unreal Engine 5 Early Access for Houdini 19?

Thanks in advance!!!
Edited by AeroAstroArts - Oct. 14, 2021 23:28:34
User Avatar
Member
28 posts
Joined: April 2016
Offline
In HDA with multiple instances, the same instance is automatically integrated into one actor.
Is it possible to separate them individually?
User Avatar
Member
26 posts
Joined: May 2013
Offline
xopowoo
In HDA with multiple instances, the same instance is automatically integrated into one actor.
Is it possible to separate them individually?

Yes you can using a split instance attribute.

In my video here I show how it can be used:

https://youtu.be/-noDmzShkRM?t=3022 [youtu.be]
User Avatar
Member
8 posts
Joined: May 2017
Offline
Quick Question.
Recently, Epic Games released Unreal Modeling for UE5.
Can we use in-engine modeling for HDA input? or have a plan to make it?
TRex92
Member
31 posts
Joined: Dec. 2012
Offline
I'm also interested in the UE5 version of the Houdini Engine plugin. Is there a time frame for when it will be available?
User Avatar
Member
1 posts
Joined: April 2018
Offline
Few bugs and problems I found Please help and let me know if there is a workaround. Attaching HDA for reference.

I am using
Houdini 19.0.383
UE: 4.27.1


  1. while creating HDA if we make the transform group/folder invisible UE crashes instantly when we try to put the HDA in viewport TypePropertyes> Transform FOlder. This is adding unnecessary clutter in Unreal engine with 2x transform options which makes things confusing
  2. The new curve node does not work when we put it as an editable node input. I opened one of my old HDA from H18 and it works. If you unlock the attached HDA you will see the old node in there just connect and rename to user_curve and it will work.
  3. I beleve since the new curve node is sort of HDA some how some thing is not getting passed and it does not work. I tried to put a add node and name that to user_curve and no luck. I also tried to put int value unreal_output+curve =1 and it still does not work

Hope some one can help and if this is a problem then maybe dev's can look into it? I have found few other bugs with Hair and fur and Mantra renderer but that will be a seperate post.

Thank you for your help
Sajeel

Attachments:
Vti_simpleinstancer.hdalc (96.5 KB)

User Avatar
Member
3 posts
Joined: March 2018
Offline
AeroAstroArts
Hi there admins, just curious after watching the presentations for Houdini 19 here [www.youtube.com], if there will be either a github or in launcher option for Houdini Engine V2 for Unreal Engine 5 Early Access for Houdini 19?

Thanks in advance!!!

I hope this happens soon.

I'm new to this, but as far as I can tell, it is not as of today, 11/29/21, possible to install any version of Houdini Engine Plugin for UE5 until bumped from 19.0.449 to 19.0.451.

The steps recommended above for 18.5.633 (superceded by 18.5.759) did not work for me with the Houdini 18.5.759 py3 that is on Launcher, so I hope I'm not missing something (I was successfully able to install the Launcher plugin for UE 4.26 and 4.27, but have never been able to install a GitHub Houdini plugin, I assume because it is 449)

Maybe in the next week or two there will be a 451, I hope.
User Avatar
Member
36 posts
Joined: Jan. 2017
Offline
I think what you want is already up on Github here.

https://github.com/sideeffects/HoudiniEngineForUnreal/ [github.com]

the latest release works with ue4.26 / UE4.27 / UE5EA2 and Houdini 19.0.383.



Pete
User Avatar
Staff
524 posts
Joined: Sept. 2016
Offline
Hi,

We only support the latest two officially released versions of Unreal, currently 4.27 / 26.
Those are the versions that ship with Houdini, either via the installer / launcher.

We do offer source code for UE5-EA2 on our git repositories.

H19.0 sources are back on the original git repo, that is updated automatically/daily when a change is made to the plugin:
https://github.com/sideeffects/HoudiniEngineForUnreal [github.com]

H18.5 source code is on the v2 specific repository, that we're not updating anymore.
https://github.com/sideeffects/HoudiniEngineForUnreal-v2 [github.com]

Those repos also have binaries for production builds, so if you want the UE5-EA2 binaries for H19.0, they're available here:
https://github.com/sideeffects/HoudiniEngineForUnreal/releases/tag/v2.0.5 [github.com]

We will update those binaries when a production build for H19.0 is released.

For UE5 and HN19.0 daily builds, the only solution is to build the plugin from source.
User Avatar
Member
3 posts
Joined: March 2018
Offline
dpernuit
Those repos also have binaries for production builds, so if you want the UE5-EA2 binaries for H19.0, they're available here:
https://github.com/sideeffects/HoudiniEngineForUnreal/releases/tag/v2.0.5 [github.com]

Ohh, ok, I think that was my missing piece. I had noticed what I was working with lacked binaries, but wasn't sure why. I'll give it go with 383 then. Many thanks!
User Avatar
Member
2 posts
Joined: Nov. 2020
Offline
Transformer handles work well on an hda in Houdini (H19.0.456) but I cannot see them in the viewport in UE4. Tested with UE4.25.4 (MAC) and UE4.27.2 (WIN). Is there a trick?





Image Not Found
Edited by ffroh - Dec. 9, 2021 11:43:53

Attachments:
test.hda (16.5 KB)
TransformerHandleTest_H19.0.456.gif (2.7 MB)
TransformerHandleTest_UE4.25.4 MAC.jpg (709.1 KB)
TransformerHandleTest_UE4.27.2 WIN.jpg (356.7 KB)

User Avatar
Member
4 posts
Joined: Feb. 2007
Offline
Hello,

I'm testing out the latest houdini engine (H19) with UE5 Early access 2. I'm really just using it as a means of importing .bgeo files at the moment, just dragging and dropping bgeos from windows into the UE5 content browser. All is working as expected which is great, however, when i drag a simple bgeo mesh in, UE5 always seems to create a blueprint actor in the content browser as well as the static mesh - is there a way to disable the BP creation? I'm curious to know why that happens by default. Cheers!
Sandy Sutherland

www.lippykid.com
@lippykid
User Avatar
Member
18 posts
Joined: March 2015
Offline
I don’t know of a way to disable it, but it does it because a bgeo file can contain more data than just a static mesh. For instance if you import a bgeo with packed primitive data, importing the bgeo will create a static mesh that contains the packed mesh data and the blueprint will create a instanced static mesh for all the packed primitive points.
Edited by Matt Vitalone - Dec. 13, 2021 21:56:02
User Avatar
Member
4 posts
Joined: Feb. 2007
Offline
Ah cool thanks Matt, I guess that makes sense. It's trivial to delete the created BPs after the fact of course.
Sandy Sutherland

www.lippykid.com
@lippykid
User Avatar
Member
1 posts
Joined: Nov. 2019
Offline
Hi everyone, I need help....

I'm using HOUDINI FX 18.5.633 and UE5.

I can't install Houdini Engine for UE5. I've installed Houdini FX 18.5.633 and I tried to install different version of Houdini Engine but it doesn't work.
I followed the procedure describe everywhere (copy the plugin inside Houdini folder and copy the same inside UE5/Plugin/Runtime but, when I check inside Houdini it seams working but as I point the path folder in UE5 and install, the path I pointed on disappear with this message.....the program is installed in a protection folder and required admin permission.
At the same time, I see the Houdini Engine in UE5 but as I try to connect the session or create a new session or sync...failed.....
PLEASE HELP ME!
WHERE'S THE PROBLEM? what I'm doing wrong? see pictures below

I've downloaded:

HoudiniEngineForUnreal-v2-Houdini18.5-5.00
HoudiniEngine-v2.0.5-H18.5.759-UE5.00EA2

Thanksssss
Edited by superuas - Feb. 9, 2022 19:51:08

Attachments:
IMG_20220210_012754.jpg (118.4 KB)
IMG_20220210_012807.jpg (120.9 KB)

TRex92
Member
31 posts
Joined: Dec. 2012
Offline
Does anyone know how to set the autobake property on a houdini asset component to be on by default in unreal. I tried setting i@unreal_uproperty_autobake = 1; I also tried just using i@AutoBake and i@Auto_Bake to 1, but that doesn't seem to work either.

For anyone else that is interested I found the solution is:

To set Autobake on by default:
i@unreal_uproperty_bBakeAfterNextCook = 1;

To set replace previous bake on by default:
i@unreal_uproperty_bReplacePreviousBake = 1;

Will the docs be getting an update to include some of these names for parameters on the Houdini asset?
Edited by TRex92 - March 17, 2022 16:42:16
User Avatar
Member
206 posts
Joined: Sept. 2012
Offline
Am i alone to experiment issues in Unreal when using Tab folder menu for a more compact UI?
Using latest engine build and houdini 19.05366 build.

Is there something special to know which could help please?

Cheers

vince*
Vincent Thomas   (VFX and Art since 1998)
Senior Env and Lighting  artist & Houdini generalist & Creative Concepts
http://fr.linkedin.com/in/vincentthomas [fr.linkedin.com]
  • Quick Links