Heightfield File

   134   4   0
User Avatar
Member
3 posts
Joined: June 2019
Offline
Hi all,

Using a Heightfield File node

I input a GeoTIFF and then use match size node with an .obj

This creates should creates an accurately sized Heightfield for me to work with.

When I try run this step in Unity via the Houdini Engine, an empty object is created with the HEU_GEO Sync (Script) on it.

The File Path is correct.

Under Sync / Unload, I have:

Log: ERROR: Unable to generate terrain data from volume parts.

Could anyone please help?

Attachments:
HFFail_final.jpg (141.7 KB)

User Avatar
Staff
472 posts
Joined: May 2017
Offline
There is probably another error line above the one you posted which logs the actual error. It looks like either you aren't using a square size (same width and length), or its not a valid heightfield. Is the output node's info panel showing valid heightfield properties? Please post a screenshot of it.
Edited by seelan - Oct. 21, 2019 17:16:37
User Avatar
Member
3 posts
Joined: June 2019
Offline
Hi seelan,

Thanks for your reply.

seelan
There is probably another error line above the one you posted which logs the actual error.

Where would I find this line above? I dont seem to be able to find another place where there are errors showing for this.

seelan
It looks like either you aren't using a square size (same width and length)

Does the incoming heightfield need to be a 100% square ? at the moment, it is off by a few units.

seelan
Is the output node's info panel showing valid heightfield properties?

I believe it is - It has all 18 Attrs that a freshly created Heightfield has, please see the attached snip for more detail.

Attachments:
HFFail_new.jpg (706.6 KB)

User Avatar
Staff
472 posts
Joined: May 2017
Offline
Looks like it is using a 740x733 sized heightfield which Unity doesn't support. It needs to be a power of 2 + 1 size. Please see https://www.sidefx.com/docs/unity/_terrain.html#Terrain_Size [www.sidefx.com]
User Avatar
Member
3 posts
Joined: June 2019
Offline
Hi seelan,

Thanks for the reply again - I didnt realize that the masks need to be to the power of 2 + 1 - after I saw your last message, I did my best to try to “squarize” the terrain without scaling it (I cropped it down)

I now see that the GeoTIFF that I am using was not square and is at super low resolution, which I am sure has been my problem since the beginning.

I'll see if I can get a bigger and square one and will provide feedback

Thanks again <3
  • Quick Links