Trouble setting up a package when is contain "Perforce"

   200   5   2
User Avatar
Member
2 posts
Joined: Feb. 2017
Offline
I'm trying to setup an Houdini package and I'm getting this weird error.

When including the word “Perforce”, I get the following error on Houdini startup:
= = = Houdini Package log = = =
Processing ‘C:/Users/gsq_jvbrie/Documents/houdini17.5/packages/GBXToolset.json’
ERROR: Interpreter: unknown identifier in F:/Perforce

My package .json file looks like:
{
“env”: [
{
“MYTEST”: “F:/Perforce”
},
],
“path”: “$MYTEST/AddOns/Houdini17.5/GBXToolset”

}

Interestingly, if I replace Perforce by any other folder name, I have absolutely no issue.

Anybody have a clue what's happening here?
User Avatar
Member
2877 posts
Joined: Sept. 2011
Offline
The letter sequence ‘for’ breaks the package system. I reported this when creating a renderman pacakge since the folder name is ‘rendermanFORhoudini’.

I heard this was fixed though. Either rename the folder to avoid the word ‘for’ or update to a new version of Houdini.
User Avatar
Member
2 posts
Joined: Feb. 2017
Offline
What a weird bug!

I'll try again as soon as I can update my version.

Thanks for your help!
User Avatar
Member
2 posts
Joined: Aug. 2010
Offline
I'm having a similar issue while switching from houdini.env to packages, but only for optix (I have at least 10 others with same path working ok)

I have an optix.json in ~/packages with the following

{ "env" : [ { "HOUDINI_NVIDIA_OPTIX_DSO_PATH":"/central/sw/houdini/plugins/optix/lin/" } ] }

I tried shortning the path
from
/central/sw/houdini/plugins/optix/linux
to
/central/sw/optix/lin/

Still get the issue where is adds
:&
into the path

Houdini DSO error on ‘/central/sw/optix/lin/:&/liboptix.so’
/central/sw/optix/lin/:&/liboptix.so: cannot open shared object file: No such file or directory


works fine if I stick it in the houdini.env file

Houdini 17.5.391 on Centos7
User Avatar
Member
2877 posts
Joined: Sept. 2011
Offline
Strange. Perhaps another substitution gone wrong.

This is what my config looks like and it works as expected:

{
    "enable": true,
    "env":
    [
        {
            "var": "HOUDINI_NVIDIA_OPTIX_DSO_PATH",
            "value": "C:/USERS/PUBLIC/DOCUME~1/optix"
        }
    ]
}
User Avatar
Member
2 posts
Joined: Aug. 2010
Offline
Thanks for that, I like the layout of your json.

It still adds the ‘:&’ to the end of the value in centos7, doesn't have this problem in Windows though.

I've created a bug report, it's not an issue as the documentation states to add it to the env file and that's what I'm doing for now.
  • Quick Links