Optix DSO error when switching to Karma

   1640   6   0
User Avatar
Member
374 posts
Joined: Nov. 2010
Offline
H18.0.287, Optix Denoser installed, Path entry is in the .env file and checked.
Whenever I switch to Karma the first time (no matter if Optix is enabled or not) I'm getting DSO errors for all the dlls in the Houdini dso/karma library. After that Karma renders fine.
Optix runs without issues in 17.5.

What am I missing? Is there anything else I need to configure?
Edited by OneBigTree - Dec. 19, 2019 14:35:37

Attachments:
Annotation 2019-12-19 202651.jpg (128.5 KB)

User Avatar
Member
1898 posts
Joined: Sept. 2015
Offline
Maybe try a daily build like 323.
User Avatar
Member
6435 posts
Joined: Sept. 2011
Online
make sure you haven't set HOUDINI_DSO_ERROR > 0 in your env. Setting it to zero (default) will supress the messages.
User Avatar
Member
374 posts
Joined: Nov. 2010
Offline
jsmack
make sure you haven't set HOUDINI_DSO_ERROR > 0 in your env. Setting it to zero (default) will suppress the messages.
But if it doesn't load properly suppressing the messages won't change that, would it? I usually have it a 2.
User Avatar
Member
374 posts
Joined: Nov. 2010
Offline
BabaJ
Maybe try a daily build like 323.
Same issue with 323.
User Avatar
Member
6435 posts
Joined: Sept. 2011
Online
OneBigTree
jsmack
make sure you haven't set HOUDINI_DSO_ERROR > 0 in your env. Setting it to zero (default) will suppress the messages.
But if it doesn't load properly suppressing the messages won't change that, would it? I usually have it a 2.

It loads properly. The messages are erroneous and can be ignored.
User Avatar
Staff
2496 posts
Joined: July 2005
Offline
The DSO warnings are a known bug. Typically, the HOUDINI_DSO_ERROR variable is set when debugging, but should probably be left at 0 unless something is going wrong.

We will try to address the issue in a future build of Houdini/Karma.
  • Quick Links