Issue with Hairshader

   931   3   2
User Avatar
Member
9 posts
Joined: Dec. 2018
Offline
Hi.

I am experiencing issues with Open GL rendering of hair using the Hairshader. I can not see specularity/ reflections in the viewport. I checked HQ lighting including reflections and when testing the principle shader I am able to produce reflections in the viewport. Not sure if I overlooked something or if the hairshader material has a problem.

Please advise.
User Avatar
Member
1 posts
Joined: June 2020
Offline
Hi


Did you ever find a solution to this?


I'm having exactly the same issue. Apply the default hair shader to the hairgen, specular comes through in mantra renders fine but viewport ‘High Quality Lighting’ seems like it's only diffuse shading.

OGL Hair>'Specular shift' gives some response to the anisotropic highlight but seems entirely linked to diffuse and not a separate specular (e.g. set OGL Hair diffuse intensity to 0 everything is black).


I am new to houdini so I might be missing a display setting or something.

I was expecting the shader out of the box to read a little more like the xgen one. Everything else about the groom workflow and tools is awesome!
User Avatar
Member
9 posts
Joined: Dec. 2018
Offline
This issue has been confirmed by sidefx as bug #103773 on March 13, 2020. But I assume it does not have the highest priority.
User Avatar
Member
53 posts
Joined: Sept. 2018
Offline
Any news on that subject? The hair in the viewport is still diffuse and it makes the grooming process much more difficult.
  • Quick Links