Search - User list
Full Version: HAPI RESULT FAILURE all around
Root » Houdini Engine for Unity » HAPI RESULT FAILURE all around
TiRi2501
Every time I start up Unity I need to mess around with the session for 15-30 minutes until I can get my engine to build something. I'm saying “mess around” because there is no obvious consistency in the way I eventually get it to work.
Usually I close all running instances of Houdini, close and reopen the session a bunch of times, restart Unity and usually it just eventually works.
This is incredibly frustrating and wasting a lot of time.

So: Does anyone experience the same issue or are there any best practices that will allow Houdini engine to run?
Here are the errors I am getting:
seelan
Do you use Unity Collab or other similar auto-synchronized file system? There is an issue with Unity Collab where the plugin stores session data in a file called heu_session.txt in the Uniy project root folder, which gets synchronized with other machines and causes issues when the plugin tries to use the session data. Ignore this file if so: https://docs.unity3d.com/Manual/UnityCollaborateIgnoreFiles.html [docs.unity3d.com]

Otherwise, delete that file whenever you have issues. You can also try closing all sessions from HoudiniEngine > Session > Close All Sessions menu.

If you are still having problems, can you describe your setup? Anything out of the ordinary?
TiRi2501
I had my project in a Google Drive since it was a prototype. I moved it to a git repo yesterday and excluded the heu_session.txt, yet the problem persists.

I'm on the steam version of Houdini, and I usually end up closing the session, closing all instances of Houdini, deleting the file, restarting unity, starting a new session and reconnecting, but that usually doesn't fix the problem and the HAPI Result Failure persists, so I have to do it a bunch of times over.

Eventually, Unity works for a second and says “Created Pipe session…” and it works fine, but it seems very random and costs 20 minutes every time I open up the project
seelan
Do you have other Houdini Engine plugins running such as Unreal / Maya / Max plugin?

Does this only happen with the Steam version? You'll need to have Steam running always I believe, since it's providing the license.

I'll test it out a bit on my machine but please provide more info so we can narrow down the issue. Thanks.
TiRi2501
I have no other plugins running, only the standalone application which I also have to close before i can get it to work.
Unfortunately I only have the steam version, so I can't test it with the standalone. Steam is running when the problem appears.

Usually I also have the same steam account running on my work PC. That one uses a license-manager licensed full commercial version of Houdini, so there should be no interaction from that with Steam. I'm trying to figure out if that could be the cause of the problem by shutting down steam on the other pc.

Is there any other information I could give you to try and find the problem?
seelan
I wonder if the heu_session.txt file is still being overwritten somehow. Can you check the timestamp on it when you get the problem? Or its contents.

That file is used to keep session info between code domain reloads (code compiles/refresh). If that gets overwritten or becomes incorrect, then it doesn't know anything about the current session.

Can you try using socket based session? To do so, from Unity menu: Houdini Engine > Session > Create > Socket Session.

If that fails, try increasing the session timeout from the plugin settings. To do so, in Unity menu: Houdini Engine > Plugin Settings > Session > Session Timeout (set to 10000)
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Powered by DjangoBB