getting HDA error, reference node outside subnet

   3015   3   1
User Avatar
Member
306 posts
Joined: May 2016
Offline
I keep getting an error when I try to create an HDA. I have attached error and node tree where error is coming from. I highlighted crate_body and its material ref. has me stumped. I know answer will be something simple but it gets by me.

Attachments:
HDA error.png (42.8 KB)
node tree.png (107.8 KB)

User Avatar
Member
200 posts
Joined: March 2018
Offline
Seems you are trying to create a HDA whereas you used absolute references which is not a clever choice!
You should address all of Material parameters as a relative reference not absolute reference as the error suggest you.
To fix this when you select the material path from second icon at the front of Material parameter just check Export Relative Path.
Also as Nicolas Longchamps said you should also pack your materials inside your asset.
Edited by N-G - April 1, 2020 21:18:13
User Avatar
Member
37 posts
Joined: Aug. 2015
Offline
Even with relative paths the materials would still be outside of the HDA, no? If you are referencing materials you need to pack them into the HDA in a material network, and use relative paths to the materials in there. That, or expose the path to the materials as parameters.
Edited by Nicolas Longchamps - April 1, 2020 21:16:04
User Avatar
Member
306 posts
Joined: May 2016
Offline
Thank you both for the response. I will change my nodes to reflect your answers. Again, thank you for the help
  • Quick Links