Ocean and Karma

   3482   9   2
User Avatar
Member
7 posts
Joined: Feb. 2019
Online
Hello there,

I'm trying to port an ocean from mantra to karma for testing purposes. I can't seem to get the displacement from the spectrum working.
I simply copied the shader over so there might be some more things to do for it to work.

Any ideas ?

Thanks !
Steven
User Avatar
Staff
332 posts
Joined: Sept. 2016
Offline
Hi. Do you have an example hip file?
User Avatar
Member
7 posts
Joined: Feb. 2019
Online
Hello Sir,

Yep here it is :

https://drive.google.com/file/d/1lKhwaxxjKwC1ajYFy9BkFEbo8Elz5Zl7/view?usp=sharing [drive.google.com]

Thanks,
Steven
User Avatar
Staff
332 posts
Joined: Sept. 2016
Offline
Hi. The problem you're seeing is due to animated file path in the material. You need to enable “Allow Shader Parameter Animation” toggle in the material library LOP.
User Avatar
Member
70 posts
Joined: Oct. 2020
Offline
dlee
Hi. The problem you're seeing is due to animated file path in the material. You need to enable "Allow Shader Parameter Animation" toggle in the material library LOP.

Doing an Ocean rendering with Karma but the displacement kept "sliding" with no wave animations for the entirety of my 240 frames render. I used the "scene import materials" LOP to get all materials.

I now did it using the good ol' "material network" LOP set to import all shaders from /mat/ and I enabled the “Allow Shader Parameter Animation” and its now working!

Thanks.
https://www.youtube.com/channel/UC4NQi8wpYUbR9wLolfHrZVA [www.youtube.com]
User Avatar
Member
95 posts
Joined: Sept. 2017
Offline
Does XPU support oceans workflow? Or does mesh need be baked out?
User Avatar
Member
70 posts
Joined: Oct. 2020
Offline
nicholasralabate
Does XPU support oceans workflow? Or does mesh need be baked out?
Oceans are VEX so probably needs to be baked out! I wont recommend it tho since XPU is pretty much very pre Alpha.
https://www.youtube.com/channel/UC4NQi8wpYUbR9wLolfHrZVA [www.youtube.com]
User Avatar
Member
1 posts
Joined: Aug. 2021
Offline
I'm getting the same exact thing here with Karma, no animation of the displacement...except with all of the correct boxes ticked including "allow shader parameter animation"

Seems like there is no rhyme or reason to why the ocean "freezes" on me, one render works..change absolutely nothing then it is frozen again.
User Avatar
Member
70 posts
Joined: Oct. 2020
Offline
if you are using scene import, then dont use it. Import the scene using sop import or "file sequence". use "material network" or "import materials" LOPs instead of scene import (materials).

I did this and my problems went away.
https://www.youtube.com/channel/UC4NQi8wpYUbR9wLolfHrZVA [www.youtube.com]
User Avatar
Member
205 posts
Joined: July 2007
Offline
I did free tutorials on Karma Water FX render
So everything from Mantra we transfer to Karma, you also have example scene files. So maybe this can help

video]https://www.youtube.com/watch?v=NN0SbcReOek [www.youtube.com]
WEB
http://www.igorfx.com/ [igorfx.com]

Vimeo
https://vimeo.com/igorzanic [vimeo.com]
  • Quick Links