FFmpeg problem, doesn't find the cooked item.

   3213   7   3
User Avatar
Member
13 posts
Joined: May 2019
Offline
Hi there,

im doing my first tutorial with TOPs/OpenGL and i've encountered a problem with the ffmpeg encode video node. Im receiving an error message like that

Work item 'ffmpegencodevideo1_348' lists file 'D:/Proprio/Documents/HoudiniProjects/Rigid_II/video/pdg_name.mp4' as an expected output file, but it wasn't found when the item cooked

I've tried many ways to fix it by changing my directory/ output file path. I've looked other formus post and tried to fix it but nothing seems to work.

Is there something that im missing here?

Attachments:
ffmpeg.PNG (52.4 KB)
param.PNG (35.1 KB)

User Avatar
Member
1460 posts
Joined: May 2006
Offline
Your images are on D:, is ffmpeg on C:?

There's a known issue where ffmpeg can't be on a different drive to where the framelist file is. You could try forcing the framelist file to be written to c:/temp/something.
http://www.tokeru.com/cgwiki [www.tokeru.com]
https://www.patreon.com/mattestela [www.patreon.com]
User Avatar
Member
13 posts
Joined: May 2019
Offline
mestela
Your images are on D:, is ffmpeg on C:?

There's a known issue where ffmpeg can't be on a different drive to where the framelist file is. You could try forcing the framelist file to be written to c:/temp/something.

Yes my images are on my D: and my FFmpeg is on my C: You say forcing the Framelist File to be written elsewhere you mean just changing the Frame List File location? I tried to change it but it didn't work again.

Maybe by using Python or something can force it to be written elsewhere can work i imagine?
User Avatar
Member
1460 posts
Joined: May 2006
Offline
Not sure; I'm doing most of my dev on OSX at the moment.

You could at least confirm the issue by moving a few test frames to C:, that'll help you narrow down the problem.
http://www.tokeru.com/cgwiki [www.tokeru.com]
https://www.patreon.com/mattestela [www.patreon.com]
User Avatar
Member
140 posts
Joined: Oct. 2015
Offline
Hello
i've encountered this kind of problem with ffmpeg in pdg
it's not because ffmpeg is on a different drive
it's because the pdg temp file are on a different drive
if you set in your scheduler the temp directory to be the working directory it fixed the problem in my case...
maybe it's the same issue

also i put the file text in the pdg temp :
Edited by Benjamin Lemoine - Feb. 28, 2021 12:49:27

Attachments:
SharedScreenshot.jpg (103.0 KB)

User Avatar
Member
31 posts
Joined: Dec. 2012
Offline
some problem here. now i changed the path and "ffmeg encode" is crashing houdini as soon i select the node.
Edited by schwungsau - June 20, 2021 18:13:26
—————–
Heribert


+heribertraab.com
User Avatar
Member
303 posts
Joined: July 2018
Offline
I had the same problem with ffmpeg. The Frame List needed to be in my working directory. That fixed it for me
User Avatar
Member
183 posts
Joined: March 2011
Online
papsphilip
I had the same problem with ffmpeg. The Frame List needed to be in my working directory. That fixed it for me

I've seen lots of people complaining about that and I've never had that kind of problem (although I have another, haha).
Yesterday I "installed" ffmpeg on windows by their site and I started to have the same problem as described on this topic's title.
So (at least for me), a working (and better) solution is installing ffmpeg through the image magick's instalation, since It does have the option to install both, and I believe it doesn't have the need to have the frame list in the same working directory as the ffmpeg.
Edited by guilhermecasagrandi - Aug. 17, 2021 08:39:05
  • Quick Links