weird OpenCl error in vellum

   3801   2   0
User Avatar
6 posts
Joined: Oct. 2020
Hi everybody
I have a very weird problem
I have an extremely simple setup.
It's just a sphere and the basic vellum configure balloon setup and a vellum solver
when I play the simulation I get this error in my Houdini Console

OpenCL Exception: clEnqueueNDRangeKernel (-52). This is probably due to incorrect number of kernel parametrs.

I have an NVIDIA GEFORCE 2080 so I really doubt that I am running out of VRAM and I have used this exact setup in the past
and besides it's literally the most basic setup ever so I'm really confused.

I changed the OpenCL method to CPU in both preferences and the Houdini.env and I still get the same error

On my Vellum Solver I get this error:

OpenCL Context error: CL_INVALID_KERNEL_ARGS error executing CL_COMMAND_NDRANGE_KERNEL on NVIDIA GeForce RTX 2080 (Device 0).

I am really confused here what am I doing wrong?
What can I do to fix this?
User Avatar
786 posts
Joined: July 2006
This is an issue that arose from recent NVIDIA drivers updating to OpenCL 3.0. It should be fixed in Houdini version 18.5.553:

Houdini 18.5.553: Mon Apr 19 19:00:18 CDT 2021
Update the Vellum Solver to work properly with NVIDIA's recently
released OpenCL 3.0 drivers, particularly the Pressure and Shape Match
User Avatar
91 posts
Joined: Oct. 2020
I have a recent version of nvidia driver with OpenCl 3.0,I can confirm that the same error/ bug with vellum balloon has been resolved with 18.5.596 []
  • Quick Links