Gimbal mode in Kinefx Rigpose

   1081   3   4
User Avatar
Member
53 posts
Joined: Sept. 2018
Offline
Hey,

I wanted to create a rig and animate my character using kinefx.
It is a standard to use gimbal mode for animation and it works perfectly fine for bones on the object level.

When I try to use gimbal mode in kinefx rigpose node it doesn't work as expected:
1. Rotating one axis in gimbal mode shall modify the rotation values of the field for only this particular axis, yet all values are modified, which leads to horrible animation curves.
2. When you make a gimbal lock for a parent joint the child's joint inherits exactly the same transformation gizmo in gimbal mode, which is very confusing.
3. When creating joints with a skeleton node it seems like child joints' local transforms are not zeroed out, which again is super confusing as you do not have full freedom of movement for freshly created joints.

Am I missing something here? Perhaps I shouldn't use gimbal mode with kinefx? But then how shall I animate my skeleton having full control over it and not having some random flipping issues?
None of the above mentioned issues happen in object-level rigs.
If anyone has some answers on how to use kinefx for manual animation (not retargeting) I will be glad to learn about it.
Edited by wolskikrzys - Nov. 2, 2021 15:10:12
User Avatar
Member
7 posts
Joined: May 2017
Offline
Hello,

Quite curious about this as well, since being able to rotate in gimbal mode is quite an important feature for animators. I wonder if it's just a bug that will be fixed in future releases, or are there any other workarounds?
User Avatar
Member
12 posts
Joined: Aug. 2014
Offline
We are also experiencing this issue
User Avatar
Member
7271 posts
Joined: July 2005
Offline
This has been reported fixed for tomorrow's 19.0.629 daily build.
  • Quick Links