H19 unable to launch on Ubuntu 20.4 with Qt Error

   2941   4   2
User Avatar
Member
2 posts
Joined: July 2005
Offline
Hi there,

We have two systems running Ubuntu 20.4.3 LTS and we're able to launch Houdini 18.5.633 without a problem on both.

I recently installed the latest Google Chrome 96.0.4664.45 on one system, and then Houdini 19.0.383, which then fails on launch with the following error;

"Qt Error: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem. Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb. "

The other system, without the Google Chrome install, was able to run H19.0.383 without a hitch.

Even when trying to run 'hkey', there is the following error;

"qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb."

Aborted (core dumped)


I'd not seen anything when googling the error, but just wondered if anyone else had experienced this or knew of a fix. I've emailed support@sidefx.com but no reply yet.

Thanks very much,

Stuart Ramsden

Visualization Programmer
National Computational Infrastructure (NCI)
The Australian National University
User Avatar
Member
116 posts
Joined: July 2005
Offline
For the record, this was fixed with "sudo apt-get install --reinstall libxcb-xinerama0".
User Avatar
Member
2 posts
Joined: Aug. 2019
Offline
I have same error on Debian and houdini 19.5 any solution?, thanks
Edited by jorgemorales3d - Nov. 6, 2022 01:59:39

Attachments:
Screenshot from 2022-11-06 00-57-26.png (33.7 KB)

User Avatar
Member
1 posts
Joined: Oct. 2017
Offline
I had a problem like that and I solved installing the qt6.
johnmather
Staff
288 posts
Joined: Aug. 2019
Offline
You shouldn't need to install Qt yourself as Houdini bundles it in. Did you try to install the package that Drew mentioned? It's possible that when you installed Qt it installed it as a dependency.
  • Quick Links