Issue occurred when using flipbook texture node

   1625   12   2
User Avatar
Member
12 posts
Joined: Oct. 2018
Offline
Hello everyone,
I'm having issues & errors like this when using the Flipbook texture node atm.
Not quite sure why these errors are occurring & the node is in beta & new to me as well.
Can any1 help provide some guidance & help on this matter? (referring to snap01 & snap02 image)

I'm also trying out the tool itself for making a texture sheet from flipbook.
Looking back at the released video. They are using these 2 wrangle node to make motion vector & normal look.
Any1 know what would be the coding behind these 2 wrangle that give the motion vec & normal effect? (referring to snap03 image)

Much appreciated & thank you in advance for the provided guidance & help!!!

Attachments:
snap01.jpg (217.7 KB)
snap02.jpg (154.4 KB)
snap03.jpg (209.3 KB)

MaiAo
Staff
88 posts
Joined: Feb. 2021
Offline
winterlang157
Hello everyone,
I'm having issues & errors like this when using the Flipbook texture node atm.
Not quite sure why these errors are occurring & the node is in beta & new to me as well.
Can any1 help provide some guidance & help on this matter? (referring to snap01 & snap02 image)

I'm also trying out the tool itself for making a texture sheet from flipbook.
Looking back at the released video. They are using these 2 wrangle node to make motion vector & normal look.
Any1 know what would be the coding behind these 2 wrangle that give the motion vec & normal effect? (referring to snap03 image)

Much appreciated & thank you in advance for the provided guidance & help!!!

Hi there, there has been a new version of this node. You can get it from the latest Labs daily builds. The python error shouldn't have been there. Please see if you have duplicated Labs packages installed. To check that, go to Help > About Houdini. Turn on Show Details. Scroll down and look for "Loaded Packages:".

The normal and motion vector visualization is directly handled by Flipbook Textures node. But if you want to access it in SOPs, you can get a new node Labs Volume Detail Attributes from tomorrow's Labs build 19.0.531.

Let me know if you have more questions.

Cheers!
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
12 posts
Joined: Oct. 2018
Offline
Hello MaiAo,

Nice to finally get your help on this matter
I tried to check for the Loaded Packages, I cant seem to find it.
I'll provide the snapshot of the details shown on the Houdini I'm using.

I've also tried uninstalling Labs and update the latest build of Labs too.
still getting the same error message when I hit render.

Am I doing smthing wrong? I would really like to learn how to use this amazing tool if you could help guide me on this.

Looking forward to your reply.

Attachments:
01.JPG (44.2 KB)
02.JPG (58.5 KB)
03.JPG (93.4 KB)
04.JPG (56.1 KB)
05.JPG (32.1 KB)
06.JPG (43.3 KB)
07.JPG (27.8 KB)
08.JPG (98.9 KB)

MaiAo
Staff
88 posts
Joined: Feb. 2021
Offline
winterlang157
Hello MaiAo,

Nice to finally get your help on this matter
I tried to check for the Loaded Packages, I cant seem to find it.
I'll provide the snapshot of the details shown on the Houdini I'm using.

I've also tried uninstalling Labs and update the latest build of Labs too.
still getting the same error message when I hit render.

Am I doing smthing wrong? I would really like to learn how to use this amazing tool if you could help guide me on this.

Looking forward to your reply.

Hey, you can get to Houdini Text Port, and type
echo $SIDEFXLABS
to find out where the Labs is. Then try to find the file matching this link [github.com] and see if the content of the python file looks the same.
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
12 posts
Joined: Oct. 2018
Offline
Hello MaiAO,

This is amazing! It actually works flawlessly now! I would not had thought in a million years to look at python stuff hidden in folder path like this if you had not pointed them out.

This is very technical to me haha.

Thank you again MaiAo!

Much appreciated.
Cheers!
User Avatar
Member
12 posts
Joined: Oct. 2018
Offline
Hello MaiAo,

Pardon me for keep spamming question soo much.
I see this another error message that pops up when I hit the Export all texture button.


Would u know how to solve this issue?

Thanks in advance.

Attachments:
snapShot01.JPG (108.9 KB)

User Avatar
Member
1 posts
Joined: Jan. 2022
Offline
Hi,

I'm running into a similar problem with this ROP.

Error
Error rendering child: /out/flipbook_textures1/pre_render
Warning
Python error: Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "labs:river/flipbook_textures::1.0, PythonModule", line 1321, in renderAndExport
File "labs:river/flipbook_textures::1.0, PythonModule", line 1109, in renderAll
File "labs:river/flipbook_textures::1.0, PythonModule", line 1099, in renderAll
File "labs:river/flipbook_textures::1.0, PythonModule", line 889, in renderMDC
File "labs:river/flipbook_textures::1.0, PythonModule", line 829, in renderMDC
File "labs:river/flipbook_textures::1.0, PythonModule", line 500, in setColorSpace
AttributeError: 'GeometryViewport' object has no attribute 'setSceneGamma'


Renders the Final Color, Non-Emissive Color, and Depth passes.
But Errors out on the MDC , Surface Normal, and Motion Vector passes. image.png
User Avatar
Member
7 posts
Joined: Aug. 2015
Offline
Hi!

I'm getting the above error too.

In my case Final Color, Non-Emissive is output.
But then I get an error.

This symptom did not occur when I set the aces color space,
but I have to use it with gamma 2.2.

flipbook _texture node is very fast and nice so I hope this problem is solved!

Thank you
MaiAo
Staff
88 posts
Joined: Feb. 2021
Offline
winterlang157
Hello MaiAo,

Pardon me for keep spamming question soo much.
I see this another error message that pops up when I hit the Export all texture button.
Image Not Found


Would u know how to solve this issue?

Thanks in advance.

Hey! Looks like your issue might be because one of the dependent intermediate passes are not rendered or not using the same export size? ECD requires Final Color + Non-emissive Color + Depths. If you do not need depth, you can change what's packed into that channel. But you definitely need both Final Color and Non-emissive passes in order to export Emissive channels. If that's not the case, please email support@sidefx.com and attach a HIP file.
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
MaiAo
Staff
88 posts
Joined: Feb. 2021
Offline
chris_yang
Hi,

I'm running into a similar problem with this ROP.

Error
Error rendering child: /out/flipbook_textures1/pre_render
Warning
Python error: Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "labs:river/flipbook_textures::1.0, PythonModule", line 1321, in renderAndExport
File "labs:river/flipbook_textures::1.0, PythonModule", line 1109, in renderAll
File "labs:river/flipbook_textures::1.0, PythonModule", line 1099, in renderAll
File "labs:river/flipbook_textures::1.0, PythonModule", line 889, in renderMDC
File "labs:river/flipbook_textures::1.0, PythonModule", line 829, in renderMDC
File "labs:river/flipbook_textures::1.0, PythonModule", line 500, in setColorSpace
AttributeError: 'GeometryViewport' object has no attribute 'setSceneGamma'


Renders the Final Color, Non-Emissive Color, and Depth passes.
But Errors out on the MDC , Surface Normal, and Motion Vector passes. image.png

Hey, this issue is now fixed in Labs 19.0.566. Sorry about that.
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
MaiAo
Staff
88 posts
Joined: Feb. 2021
Offline
ankoro
Hi!

I'm getting the above error too.

In my case Final Color, Non-Emissive is output.
But then I get an error.

This symptom did not occur when I set the aces color space,
but I have to use it with gamma 2.2.

flipbook _texture node is very fast and nice so I hope this problem is solved!

Thank you

Hey, this issue is now fixed in Labs 19.0.566. Sorry about that.
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
7 posts
Joined: Aug. 2015
Offline
Hello MaiAo!

Thank you for the upgrade information.
I will try it.

Thank you!
User Avatar
Member
12 posts
Joined: Oct. 2018
Offline
Hello MaiAo,

Likewise, this is awesome!

Very much appreciated for the update & help!

Ku-dos to you, mate!

Thank & cheers!
  • Quick Links