Labs Flipbook Texture doesn't render

   1067   6   1
User Avatar
Member
109 posts
Joined: Nov. 2015
Offline
I am stuck with this error message...

Error 
Error rendering child: /out/pyro_smoker/pre_render
Warning
Python error: Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 1321, in renderAndExport
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 1109, in renderAll
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 1097, in renderAll
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 566, in renderFinalColor
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 554, in renderFinalColor
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 483, in setColorSpace
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.561/houdini/python3.7libs\hou.py", line 74509, in setOCIODisplayView
return _hou.SceneViewer_setOCIODisplayView(self, display, view)
hou.OperationFailed: The attempted operation failed.
Invalid display or view name

any suggestions on what might be the problem?
Edited by chf - March 22, 2022 13:20:09
MaiAo
Staff
88 posts
Joined: Feb. 2021
Offline
chf
I am stuck with this error message...

Error 
Error rendering child: /out/pyro_smoker/pre_render
Warning
Python error: Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 1321, in renderAndExport
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 1109, in renderAll
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 1097, in renderAll
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 566, in renderFinalColor
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 554, in renderFinalColor
File "labs::Driver/flipbook_textures::1.0, PythonModule", line 483, in setColorSpace
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.561/houdini/python3.7libs\hou.py", line 74509, in setOCIODisplayView
return _hou.SceneViewer_setOCIODisplayView(self, display, view)
hou.OperationFailed: The attempted operation failed.
Invalid display or view name

any suggestions on what might be the problem?

Can you go to Houdini Text Port and type
echo $OCIO
? What result do you get?
Mai Ao
Lead of SideFX Labs
twitter.com/aomai01
User Avatar
Member
109 posts
Joined: Nov. 2015
Offline
/ -> echo $OCIO
C:/Users/Fasching/Documents/houdini19.0/SideFXLabs/19.0.566/SideFXLabs19.0/misc/ocio/aces_config.ocio
User Avatar
Member
109 posts
Joined: Nov. 2015
Offline
I changed it via "Edit - Color Settings" to a different OCIO Folder on my disk and now it works.
Seems it didn't like the Labs OCIO Setting.
User Avatar
Member
2 posts
Joined: Jan. 2014
Offline
What directory did you change it to? I'm running into the exact same thing on Build 568 (of Houdini and Labs), changed my OCIO directory to "C:\Users\(user_name)\Documents\OpenColorIO-Configs-feature-aces-1.2-config\aces_1.2" and got the same error.
Edited by AramG - March 25, 2022 17:57:24
Aram Granger
Sr. VFX Artist
Respawn Entertainment
https://www.respawn.com [www.respawn.com]
User Avatar
Member
109 posts
Joined: Nov. 2015
Offline
AramG
What directory did you change it to? I'm running into the exact same thing on Build 568 (of Houdini and Labs), changed my OCIO directory to "C:\Users\(user_name)\Documents\OpenColorIO-Configs-feature-aces-1.2-config\aces_1.2" and got the same error.

I put it on C: directly and referenced it in the houdini.env file:

OCIO = "C:\OpenColorIO\aces_1.0.3\config.ocio"

this seems to have done it
User Avatar
Member
2 posts
Joined: Jan. 2014
Offline
Thank you, that helped me! I had that variable in the windows environment variables and it was getting ignored every time I restarted Houdini.
Aram Granger
Sr. VFX Artist
Respawn Entertainment
https://www.respawn.com [www.respawn.com]
  • Quick Links